Steam for Linux > Limited Beta > Topic Details
macflecknoe Dec 2, 2012 @ 6:36pm
Team Fortress 2 Crash after Valve Screen
Getting the following error on the command line and would like to know if you would like a copy of the core file; this is running on a vaio e series laptop with an Intel HD graphics card. The Team Fortress 2 beta however runs perfectly:

Loaded program cache file "glbaseshaders.cfg", total keyvalues: 266, total successfully linked: 266
Could not load program cache file glshaders.cfg
Could not find user GL shader cache file
Precache: Took 35955 ms, Vertex 928, Pixel 1367
Game.so loaded for "Team Fortress"
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20121202213139_1.dmp
success = yes
response: CrashID=bp-94bb1ca7-b99f-422a-9a21-729a52121202

/home/lamberm/.local/share/Steam/SteamApps/macflecknoe/Team Fortress 2/hl2.sh: line 72: 12610 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 12610
Generating new string page texture 158: 256x256, total string texture memory is 1.33 MB
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

Showing 1-7 of 7 comments
< >
macflecknoe Dec 2, 2012 @ 6:39pm 
nm... just read the report and it looks like its automatically uploaded... :-)
macflecknoe Dec 3, 2012 @ 6:55pm 
this might be a significant detail. I believe that the problem was that the team fortress 2 beta was installed alongside team fortress 2.

I have two laptops that were experiencing this problem... one with an nvidia chipset and the other with an intel graphics card. I installed both team fortress 2 beta and team fortress 2 on each machine. I reinstalled ubuntu 12.10 on the intel machine and then reinstalled team fortress 2 but NOT the beta... that machine runs team fortress 2 without a hitch.

I will now try to remove team fortress 2 beta from the nviida machine to see if that resolves the issue there.
macflecknoe Dec 4, 2012 @ 2:16pm 
seems i was mistaken. team fortress 2 is now crashing on the intel laptop after i rebooted.
Frank Dec 4, 2012 @ 4:00pm 
Could you please provide your System Information? The easiest method is to open the Steam for Linux client and click About | Hardware Information. Once your information appears, right-click within the dialog and choose Select All, right-click again, and then choose Copy. Paste this information into your post.
thanks!
macflecknoe Dec 4, 2012 @ 5:07pm 
You bet:

Processor Information:
Vendor: GenuineIntel
Speed: 2501 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-19-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2

Driver Version: 3.0 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x8086
DeviceID: 0x166
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 13.58" x 7.64" (15.55" diag)
34.5cm x 19.4cm (39.5cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Intel PantherPoint HDMI

Memory:
RAM: 7888 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 695965 Mb
Largest Free Hard Disk Block: 628030 Mb

Installed software:

Recent Failure Reports:
Tue Dec 4 22:12:05 2012 GMT: file ''/tmp/dumps/crash_20121204171204_1.dmp'', upload yes: ''CrashID=bp-b0087885-2521-4246-8d0c-121cb2121204
''
Tue Dec 4 22:22:04 2012 GMT: file ''/tmp/dumps/crash_20121204172202_1.dmp'', upload yes: ''CrashID=bp-e08ea296-2216-480f-92a8-0025c2121204
''
Tue Dec 4 22:34:31 2012 GMT: file ''/tmp/dumps/crash_20121204173428_1.dmp'', upload yes: ''CrashID=bp-88816531-f8da-4a25-8600-484e52121204
''
Tue Dec 4 22:40:44 2012 GMT: file ''/tmp/dumps/crash_20121204174038_1.dmp'', upload yes: ''CrashID=bp-e1b8d7ad-086a-45d7-8a0f-fb2d32121204
''

1domagoj1 Dec 10, 2012 @ 5:57am 
Same here. TF2 crashes after intro screen, I see the "Valve" and "Source" intro screens then it hangs a bit on that "vintage picture" screen with "Loading..." text and then the game crashes. After that I added -nojoy to launch parameters and game launched normally. I also tried to add -novid but then I don't go through intro screens, game throws me directly to game menu. Then I tried to remove joydev LKM with modprobe and launch the game without any launch parameters and it lauched normally. So the problem probably has to do something with the joydev module and/or joysticks/gamepads.

This is the terminal log:

Loaded program cache file "glbaseshaders.cfg", total keyvalues: 266, total successfully linked: 266
Could not load program cache file glshaders.cfg
Could not find user GL shader cache file
Precache: Took 15633 ms, Vertex 864, Pixel 1367
Game.so loaded for "Team Fortress"
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20121210141627_1.dmp
success = yes
response: CrashID=bp-118d76a6-e5ab-4c96-a6dc-1656d2121210
/home/domagoj/.local/share/Steam/SteamApps/1domagoj1/Team Fortress 2/hl2.sh: line 72: 7577 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 7577
Generating new string page texture 111: 256x256, total string texture memory is 2.38 MB
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Generating new string page texture 113: 256x256, total string texture memory is 393.22 KB
Generating new string page texture 114: 24x256, total string texture memory is 2.40 MB
Shutting down. . .
unlinked 6 orphaned pipes
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 258969 single object sleeps, 2982 multi object sleeps
CAsyncIOManager: 6294 single object alertable sleeps, 6 multi object alertable sleeps

And this is my System info:

Processor Information:
Vendor: AuthenticAMD
Speed: 3400 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 7800 Series

Driver Version: 4.2.11762 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6819
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 18.90" x 10.55" (21.61" diag)
48.0cm x 26.8cm (54.9cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 7969 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 345576 Mb
Largest Free Hard Disk Block: 239753 Mb

Installed software:

Recent Failure Reports:
Mon Dec 10 13:10:21 2012 GMT: file ''/tmp/dumps/crash_20121210140946_1.dmp'', upload yes: ''CrashID=bp-3724ac3b-3177-46da-b0c8-45fdd2121210''
Mon Dec 10 13:13:18 2012 GMT: file ''/tmp/dumps/crash_20121210141303_1.dmp'', upload yes: ''CrashID=bp-47b5a851-a8b7-41b9-a678-dcc7b2121210''
Mon Dec 10 13:16:36 2012 GMT: file ''/tmp/dumps/crash_20121210141627_1.dmp'', upload yes: ''CrashID=bp-118d76a6-e5ab-4c96-a6dc-1656d2121210''
Mon Dec 10 13:48:21 2012 GMT: file ''/tmp/dumps/crash_20121210144812_1.dmp'', upload yes: ''CrashID=bp-44ef2610-8b9d-4f17-86ce-15a022121210''

I'm running Gnome Shell, not Unity, but I don't believe that means too much.
Esophagus Now Dec 10, 2012 @ 6:02am 
I read somewhere to try this:
sudo apt-get install compizconfig-settings-manager
Then open it (run ccsm in the terminal), go to opengl, and uncheck lighting.
Let me know if it works
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Dec 2, 2012 @ 6:36pm
Posts: 7