Steam for Linux > Limited Beta > Topic Details
lxdlam Dec 2, 2012 @ 4:30am
I start Steam for liunx on ubuntu 12.10, but nothing happend.
I am new at liunx, and i am studying liunx system now. I start steam for many times, but it is always nothing happen.The terminal tell me that:

Installing breakpad exception handler for appid(steam)/version(1354334278_client)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 5046 with name 0eBlobRegistryMutex_686B6452E622A7426542B36BCF587359
removing stale semaphore last operated on by process 5046 with name 0eBlobRegistrySignal_686B6452E622A7426542B36BCF587359
removing stale semaphore last operated on by process 5046 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 5046 with name 0eSteamEngineLock
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)

(process:5122): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
Installing breakpad exception handler for appid(Steam)/version(1354334278_client)
GLError: 1280
GLError: 1280
GLError: 1280
GLError: 1280
GLError: 1280
GLError: 1280
GLError: 1280
GLError: 1280
GLError: 1280
GL: [API][ERROR][HIGH][0]: GL_INVALID_ENUM in glTexParameter(pname=GL_TEXTURE_MAX_ANISOTROPY_EXT)
/home/lxdlam/.local/share/Steam/steam.sh: 行 325: 5122 跟踪/断点陷阱 $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

And i am not find the folder is ~/steam. What should i do?
Last edited by lxdlam; Dec 2, 2012 @ 4:32am
Showing 1-15 of 15 comments
< >
Shigutso Dec 2, 2012 @ 5:23am 
LINUX****

What's your Ubuntu arch? 32 ou 64 bits? What's your graphics card and driver version?

I may be wrong, but reading the "GLError" in your terminal output, I can imagine that you don't have 3D hardware acceleration.

Run this command and paste here what returns to you:
glxinfo | grep -i direct

If everything is ok, you must receive a "direct rendering: Yes".
Last edited by Shigutso; Dec 2, 2012 @ 5:27am
Magbed@Linux! Dec 2, 2012 @ 5:27am 
Originally posted by Shigutso:
LINUX****

What's your Ubuntu arch? 32 ou 64 bits? What's your graphics card and driver version?

I may be wrong, but reading the "GLError" in your terminal output, I can imagine that you don't have 3D hardware acceleration.

Run this command and paste here what returns to you:
glxingo | grep -i direct

If everything is ok, you must receive a "direct rendering: Yes".

glxinfo | grep -i direct

Fixed there was a typo
Shigutso Dec 2, 2012 @ 5:29am 
Originally posted by Magbed@Linux!:
Fixed there was a typo

LOL I fixed at the same time
lxdlam Dec 4, 2012 @ 3:31am 
No help.
Originally posted by Shigutso:
LINUX****

What's your Ubuntu arch? 32 ou 64 bits? What's your graphics card and driver version?

I may be wrong, but reading the "GLError" in your terminal output, I can imagine that you don't have 3D hardware acceleration.

Run this command and paste here what returns to you:
glxinfo | grep -i direct

If everything is ok, you must receive a "direct rendering: Yes".
Frank Dec 4, 2012 @ 3:08pm 
Originally posted by The best winner:
No help.
Originally posted by Shigutso:
LINUX****

What's your Ubuntu arch? 32 ou 64 bits? What's your graphics card and driver version?

I may be wrong, but reading the "GLError" in your terminal output, I can imagine that you don't have 3D hardware acceleration.

Run this command and paste here what returns to you:
glxinfo | grep -i direct

If everything is ok, you must receive a "direct rendering: Yes".
What do you mean by no help? What was the output of the command?
tecs Dec 7, 2012 @ 1:26am 
Same problem here, exits with above errors. First run was fine until download (update?) finished, didn't run again, even after reinstall.

glxinfo | grep -i direct
direct rendering: Yes

32bit 12.10, xf86-video-intel 14-1
Decivre Dec 7, 2012 @ 4:15am 
I'm having similar problems. When I try to start Steam for the first time, it asks for authorization, but then the window closes after the password is inputted and it ceases to do anything. System monitor shows a process called "steam.sh", but it does not take up any CPU time at all.
Decivre Dec 7, 2012 @ 4:22am 
Disregard. I think I found a fix. Purge your install of Steam, then delete both the "Steam" and ".steam" folders from your home folder. This seems to have fixed the problem for me.
simplisto Dec 7, 2012 @ 5:23am 
Originally posted by Decivre:
Disregard. I think I found a fix. Purge your install of Steam, then delete both the "Steam" and ".steam" folders from your home folder. This seems to have fixed the problem for me.

Sadly, this hasn't fixed the issue in my case.
lxdlam Dec 9, 2012 @ 1:04am 
thank you for everybody.i am a chinese. I just check them later.
jspenguin Dec 10, 2012 @ 8:24am 
It seems pretty obvious to me that the underlying problem is that GTK is refusing to initialize because the program is setuid-root.

No GTK = no interface. The GLerrors are obviously caused by there being no connection to the X server to begin with.

Why is steam setuid root? Check the output of ls -l ~/.steam/bin .
akrito Dec 20, 2012 @ 8:04pm 
I had the same problem. Executing
export MESA_EXTENSION_OVERRIDE='GL_EXT_texture_filter_anisotropic'
before running steam fixed it for me.
ugeen75 Dec 24, 2012 @ 1:48am 
Originally posted by akrito:
I had the same problem. Executing
export MESA_EXTENSION_OVERRIDE='GL_EXT_texture_filter_anisotropic'
before running steam fixed it for me.

I've same problem. Where i should write this text?In the terminal?
Getterac7 Jan 10, 2013 @ 7:31pm 
Originally posted by akrito:
I had the same problem. Executing
export MESA_EXTENSION_OVERRIDE='GL_EXT_texture_filter_anisotropic'
before running steam fixed it for me.

I run this command in terminal, then "steam" directly after to launch steam and it fixed the error for me. Thanks!
Leandros Feb 5, 2013 @ 3:02pm 
Yep, fixed it for me, too.

Arch Linux x64 running the Open Source AMD drivers.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50