Steam for Linux > Limited Beta > Emnedetaljer
Neutron 1. des, 2012 @ 11:23am
[FIXED]: Issue Report: Steam segfault
Steam segfaults on Kubuntu/KDE(4.9.3) if you minimize Steam by clicking its name on the taskbar, restore it clicking it again and then, for example, click the 'show friends'-button on restored Steam window which results in opened Friends window and Steam uploading dump and segfaulting. Trying to open any menu also triggers the segfault, but does not trigger the dump upload.

Segfault was not triggered if Steam was minimized from its own window controls.

Remotely relevant part of the Steam output on Konsole:
ExecSteamURL: "steam://open/friends"
Uploading dump (in-process) [proxy '']
success = yes
response: CrashID=bp-81fa302e-e70f-4677-b8ae-b68c62121201

/home/joni/Steam/ rivi 325: 6842 Muistialueen ylitys (luotiin core-tiedosto) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
If triggered by menus, the dump messages are not there but just the segfault line.
(The last line says problem on line 325, segmentation fault, core dump created)

System information:
Suorittimen tiedot:
Toimittaja: GenuineIntel
Nopeus: 2667 Mhz
2 loogisia suorittimia
2 fyysisiä suorittimia
HyperThreading: Ei tuettu
FCMOV: Tuettu
SSE2: Tuettu
SSE3: Tuettu
SSSE3: Tuettu
SSE4a: Ei tuettu
SSE41: Ei tuettu
SSE42: Ei tuettu

Verkon tiedot:
Verkon nopeus:

Windowsin versio:
Ubuntu 12.10 (64 bittiä)
Ytimen nimi: Linux
Ytimen versio: 3.5.0-19-generic
X-palvelimen julkaisija: The X.Org Foundation
X-palvelimen julkaisu: 11300000

Ajuri: ATI Technologies Inc. ATI Radeon HD 5700 Series

Ajurin versio: 4.2.11903 Compatibility Profile Context
Työpöydän värisyvyys: 24 bittiä/pikseli
Näytön virkistystaajuus: 60 Hz
Toimittajatunnus: 0x1002
Laitetunnus: 0x68b8
Näyttöjen lukumäärä: 1
Loogisten näytönohjainten lukumäärä: 1
Ensisijainen näyttötarkkuus: 1280 x 1024
Työpöydän näyttötarkkuus: 1280 x 1024
Ensisijainen näytön koko: 13,31" x 10,63" (halkaisija 17,01")
33,8 cm x 27,0 cm (halkaisija 43,2 cm)
Ensisijaista VRAMia ei tunnistettu

Äänikortti: Realtek ALC883

Käyttömuisti: 3953 Mt

Käyttöliittymän kieli: suomi
Mikrofoni: Not set
Kiintolevytilaa yhteensä: 422831 Mt
Suurin vapaa levylohko: 40703 Mt

Asennetut ohjelmat:

Recent Failure Reports:
Sat Dec 1 17:49:25 2012 GMT: file ''/tmp/dumps/crash_20121201194902_1.dmp'', upload yes: ''CrashID=bp-83e0381a-9d80-4358-aada-1e8a72121201
Sat Dec 1 18:07:34 2012 GMT: file ''/tmp/dumps/crash_20121201200709_1.dmp'', upload yes: ''CrashID=bp-2fae2a90-af2d-44fb-9496-394222121201
Sat Dec 1 19:03:14 2012 GMT: file ''/tmp/dumps/crash_20121201210249_1.dmp'', upload yes: ''CrashID=bp-81fa302e-e70f-4677-b8ae-b68c62121201
Sorry for the Finnish info, but it should be fairly clear what they say.
Sist redigert av Frank; 4. des, 2012 @ 3:15pm
Viser 1-7 av 7 kommentarer
< >
Silvershock 1. des, 2012 @ 12:51pm 
I have a similar issues when attempting to start Steam after the latest update. I'd just installed the latest AMD graphics driver beta (on Kubuntu 12.10 x64), and when I tried to start, I got this little beauty, that looks quite similar to the one above:

Installing breakpad exception handler for appid(steam)/version(1354334278_client)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(steam)/version(1354334278_client)
Installing breakpad exception handler for appid(steam)/version(1354334278_client)
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 2820 with name 0eBlobRegistryMutex_F9717B8F251EE01D8E7AD753A176B749
removing stale semaphore last operated on by process 2820 with name 0eBlobRegistrySignal_F9717B8F251EE01D8E7AD753A176B749
removing stale semaphore last operated on by process 2820 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 2820 with name 0eSteamEngineLock
Installing breakpad exception handler for appid(steam)/version(1354334278_client)
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
/home/greg/Steam/ line 325: 4613 Segmentation fault (core dumped) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Silvershock 1. des, 2012 @ 1:07pm 
Following up on this, I went to the file, to line 325, and found the line where it attempted to set up the debugger. I commented that line out, tried to start Steam, and it began running a file update. The file update replaced the *.sh file with a new version, tried to run it, segfaulted. I updated the *.sh file again, ran it, and it ran the same update again, segfaulting again. I'm now stuck in a loop. Damn!
Neutron 1. des, 2012 @ 1:44pm 
Just ran it with gdb in hopes of a useful backtrace, but all I got was two addresses in, which makes this look like a driver issue. I'm currently using the (k)ubuntu's fglrx-updates 2:9.000-0ubuntu3-package. I guess I'll be updating them soon-ish.
Once again fglrx is a disappointment.
Tarvitz 2. des, 2012 @ 10:24am 
Steam won't start with amd/ati 12.11beta8 drivers. Problem causes by drivers withing segmentation fault while steam tries to run ADL_ApplicationProfiles_System_Reload function
and it fails.

Found this information here. So nobody can run steam within catalyst 12.11beta8 drivers.
Frank 3. des, 2012 @ 5:54pm 
I can't offer much regarding AMD drivers but I can say that AMD is currently setting up a public forum for issues encountered with AMD drivers and the Steam fro Linux client. Once it's live, I will be announcing it to the Steam for Linux group.
Neutron 4. des, 2012 @ 10:04am 
Just updated to Catalyst 12.11 Beta 11 and the segfault doesn't happen anymore.
/dev/whack 8. des, 2012 @ 12:28am 
I'm on Catalyst 12.11 beta11 and I still see this segfault. gdb backtrace has nothing useful other than the crash occurred in

(gdb) where
#0 0xf68654f5 in ?? () from /usr/lib/dri/
#1 0x088fbe60 in ?? ()
#2 0xf6272580 in ?? () from /usr/lib/dri/
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
Viser 1-7 av 7 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 1. des, 2012 @ 11:23am
Innlegg: 7