Steam for Linux > Limited Beta > Topic Details
Ripper003 Dec 1, 2012 @ 5:26am
Issue Report: Black Screen on TF2 Launch but can hear sound?
Hi,
Only recently got accepted into the beta and I was extremely eager to test TF2. You can imagine that I was a little disappointed when it finished downloading and didn't run as expected...but then it is Beta ;)
Anyway, the black screen problem appears to have been reported numerous times but with fixes primarily relating to NVidia graphics issues. I have Intel HD Integrated Graphics and the supposed 'fix' by editing /usr/bin/steam doesn't work.
I am somewhat confused however, this is a graphics only issue, I get a fullscreen blackness but I can hear sound playing i.e. the Valve loadup screen and menus ingame...
UPDATE: Here's a log from terminal when I launch TF2 and the audio is playing without video. http://paste.ubuntu.com/1402074/

Ubuntu 12.10 AMD64
3GB DDR3 RAM
Intel Integrated HD Graphics
Core i3 Gen 1 2.3GHz

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2

Driver Version: 2.1 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x8086
DeviceID: 0x46
Number of Monitors: 1
Number of Logical Video Cards: 1
Last edited by Ripper003; Dec 1, 2012 @ 8:25am
Showing 1-15 of 16 comments
< >
blackout24 Dec 1, 2012 @ 5:38am 
Simply start steam in Terminal (and redirect the output into a file if you wish).
Ripper003 Dec 1, 2012 @ 6:12am 
I looked over the output and I don't even see any error codes, just a load of jumbled text not relating to anything in particular.
Ripper003 Dec 1, 2012 @ 6:29am 
Here's the log from the terminal, start to end after the flood of gobbledegook. http://paste.ubuntu.com/1402074/
Ripper003 Dec 1, 2012 @ 8:25am 
Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2

Driver Version: 2.1 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x8086
DeviceID: 0x46
Number of Monitors: 1
Number of Logical Video Cards: 1
Don Rego Dec 1, 2012 @ 8:42am 
Buddy, I Have Intel HD Graphics to. This problem is vertex shader and in the Mac and Linux, vertex shader is not implemented. The problem is your hardware, no the game.
Ripper003 Dec 3, 2012 @ 8:40am 
Bit naff that it works fine under Wine and Windows then...
Ripper003 Dec 19, 2012 @ 12:19am 
OK I did a quick Google, the hardware isn't the problem as the Core i3 First Gen #350M has Intel HD Graphics 3000 as requested by http://steamcommunity.com/app/221410/discussions/1/882965118609963322/
It would seem that some software somewhere is the problem then.
SUSEd Dec 19, 2012 @ 3:29am 
env LANG=C steam
But it must be fixed. Check for updates.
Ripper003 Dec 19, 2012 @ 5:22am 
I add that to/usr/bin/steam? I don't know whether I should use Beta TF2 or Normal to test? I'd guess both.
Ripper003 Dec 20, 2012 @ 4:50am 
Didn't work anyway, still get a black screen it just loads faster xD
SUSEd Dec 20, 2012 @ 5:12am 
Originally posted by callumh003:
I add that to/usr/bin/steam? I don't know whether I should use Beta TF2 or Normal to test? I'd guess both.

No. Just launch in terminal. Launch TF2 not beta.
Last edited by SUSEd; Dec 20, 2012 @ 5:12am
Ripper003 Dec 20, 2012 @ 11:35am 
OK I'll download normal TF2 then report back.
Ripper003 Dec 22, 2012 @ 7:42am 
OK done, it still doesn't work and I've even tested xorg-edgers ppa and it still isn't right.
play3man Dec 22, 2012 @ 8:47am 
Originally posted by callumh003:
OK done, it still doesn't work and I've even tested xorg-edgers ppa and it still isn't right.

Hey, you don't have Intel HD 3000, but only Intel HD (2010 - Ironlake) which support only OpenGL 2.1, so now you can't run TF2 in linux.

https://github.com/ValveSoftware/steam-for-linux/issues/19

http://steamcommunity.com/app/221410/discussions/6/846939071071956036/#p1
Last edited by play3man; Dec 22, 2012 @ 8:47am
Ripper003 Dec 25, 2012 @ 7:21am 
Well that really sucks because WINE worked fine with them...
Showing 1-15 of 16 comments
< >
Per page: 15 30 50