Steam for Linux > Limited Beta > 제목 정보
DeXP 2012년 12월 1일 오전 2시 29분
Issue Report: Steam main menu not working in WMII
There is trouble in WMII and, maybe, another tile window managers.
Here a screenshot: http://pic4.ru/images/e8c246a268eaeafe847828848c1d901f.png (I'm trying to hover "My Profile" submenu). As you can see, "Store" is hovered through opaque menu.
If I manually move menu window to another WMII tag (ex. Mod+Shift+7), than on that tag I can operate this menus.
Is it need to fix some "activeWindow" codes? WMII activates all new opened windows..
My hardware: http://pastebin.com/BrubaNc0
13개 중 1-13 표시중
< >
plajuck 2012년 12월 1일 오전 2시 57분 
Experiencing same problem with awesomeWM: http://awesome.naquadah.org/
plajuck 2012년 12월 1일 오전 5시 41분 
Sometimes menu works. So I managed to get system information:
Processor Information:
Vendor: GenuineIntel
Speed: 3300 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
"Calculate Linux Scratch 12.0" (64 bit)
Kernel Name: Linux
Kernel Version: 3.4.5-calculate
X Server vendor: The X.Org Foundation
X Server release: 11202000

Video Card:
Driver: ATI Technologies Inc. ATI Radeon HD 5670

Driver Version: 4.2.11903 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID Not Detected
DeviceID Not Detected
Number of Monitors: 1
Number of Video Cards Not Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20,08" x 11,42" (23,07" diag)
51,0cm x 29,0cm (58,6cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC889

Memory:
RAM: 5947 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 47584 Mb
Largest Free Hard Disk Block: 10481 Mb

Installed software:

Recent Failure Reports:
Sat Dec 1 10:43:14 2012 GMT: file ''/tmp/dumps/assert_20121201124308_1.dmp'', upload yes: ''CrashID=bp-9993be42-fae0-43bb-9148-f177b2121201
''
Sat Dec 1 13:38:55 2012 GMT: file ''/tmp/dumps/assert_20121201153849_1.dmp'', upload yes: ''CrashID=bp-da9dda4f-8872-49e2-ba2a-d8aeb2121201
''

spacepope 2012년 12월 4일 오전 7시 54분 
wmii user here, same problem:
- sometimes menus just work but more often than not I can't focus them
- open menus are always displayed on every tag.

Processor Information:
Vendor: GenuineIntel
Speed: 3801 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-33-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 660 Ti/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1183
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1200
Desktop Resolution: 1920 x 1200
Primary Display Size: 20.39" x 12.76" (24.02" diag)
51.8cm x 32.4cm (61.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2048 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT2020

Memory:
RAM: 16011 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 639796 Mb
Largest Free Hard Disk Block: 234710 Mb

Installed software:

Recent Failure Reports:
Thu Nov 29 21:23:36 2012 GMT: file ''/tmp/dumps/assert_20121129222325_1.dmp'', upload yes: ''CrashID=bp-4c50e110-3a3f-4b6f-9345-11aec2121129
''
Tue Dec 4 15:27:09 2012 GMT: file ''/tmp/dumps/assert_20121204162626_1.dmp'', upload yes: ''CrashID=bp-579a41f9-e8d5-4dce-8207-260172121204
''
spacepope님이 마지막으로 수정; 2012년 12월 4일 오전 7시 55분
Brummbaer [AUT] 2012년 12월 4일 오전 8시 35분 
Same Problem with WindowMaker 095.3 (+latest git)
powrtoch 2012년 12월 4일 오전 9시 10분 
I've been able to make them work in Awesome WM by simple holding right-click button down while left-clicking the menu header.

After that I am able to keep focus without holding right-click.
Frank 2012년 12월 4일 오후 3시 14분 
This has been added to our bug database.
rkfg 2012년 12월 8일 오후 12시 22분 
Same here on Awesome WM. There's another workaround, pressing Ctrl or Shift (maybe Alt, too, but I use it for controlling Awesome) while clicking the menu makes it work. But if you select another top-level item like move from Steam to View then it loses focus again.
z33ky 2012년 12월 8일 오후 1시 05분 
Another Awesome user here. I do not have the problem.
I'm running the git-version and I have set the floating layout for the Steam-windows.
NightStalker 2012년 12월 9일 오후 2시 34분 
I got the same bug in awesome (v3.4.13). Adding a rule that sets all "Steam" windows to floating does not help.
DarkStarSword 2012년 12월 10일 오후 5시 10분 
Same problem here on wmii (latest mercurial head + a bunch of my own custom scripts).

The menus will work if the mouse never hovers over the main Steam window after the menu is opened at which point the main Steam window gets all the mouse events. The main menus (Steam, View, etc) are a problem since the menu always opens slightly below the cursor, while the context menu (right clicking on a game) tends to open at the cursor so they can work as long as the cursor isn't moved away from the menu.

The workaround I've been using is to switch to another tag without the main Steam window displayed - the menu is still displayed and can be operated normally (even if other non-Steam windows are moused over).
DarkStarSword 2012년 12월 10일 오후 10시 15분 
Does anyone else here running wmii (or possibly other tiling window managers) also experience this issue with text fields? Just curious that I haven't seen any other threads mentioning the problem and wondering if it's specific to my setup? http://steamcommunity.com/app/221410/discussions/1/846939071408885734/
Seegras 2012년 12월 11일 오전 4시 11분 
Something very similar happens on WindoMaker. Anyway, it's probably all the same bug, resulting from menus being actual separate windows.
http://steamcommunity.com/app/221410/discussions/1/846939071417218739/
http://steamcommunity.com/app/221410/discussions/1/882965239886289817/
http://steamcommunity.com/app/221410/discussions/1/846939071404014309/
http://steamcommunity.com/app/221410/discussions/1/846939071365705568/
this one maybe too:
http://steamcommunity.com/app/221410/discussions/1/846939071408885734/
Also, there are several issues with the focus in games themselves. There's a chance this might be related to this as well.
happs 2012년 12월 11일 오전 7시 52분 
I'm not sure if this is related; but I cannot move nor re-size any of the windows.
wm 0.95
13개 중 1-13 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 12월 1일 오전 2시 29분
게시글: 13