Steam for Linux > Limited Beta > Topic Details
Rain Ninja Dec 1, 2012 @ 12:19am
Issue Report: Serious Sam 3 - Vsync somehow on by default, even when not enabled
http://pastebin.com/DWPJPHqn - system info
http://pastebin.com/8GW5Kziv - sam3.log

I searched but couldn't see any existing thread on this. Anyway I'm playing the game in KDE with effects suspended (not just fullscreen undirecting, actually shut off effects with ALT-SHIFT-F12).

Even though Vsync is turned off in NVIDIA Control Panel and I have desktop effects disabled and Vsync is also turned off in SS3, everytime I startup the game and play I notice that its still exhibiting Vsync behavior. Looking at the sky I get a maximum of 60FPS. Most elsewhere it runs at pretty much exactly 30fps.

However if I go into the Graphics Settings menu of SS3 and enable Vsync...then disable it again, the game starts running as expected.
i.e no Vsync behaviour
Looking at the sky I can get over 60fps, up to around 70fps and general FPS is much smoother (understandable as my machine obviously cant manage 60FPS constantly), around 45fps.

But to get the game "un-Vsync'd" after everytime I start the game I have to enable and then disable Vsync like that.
Showing 1-9 of 9 comments
< >
Vash Dec 1, 2012 @ 12:55am 
Does this happen in other games? I noticed nvidia-settings doesn't actually load its settings at boot by default, so you have to turn it on and off. You can set it to load up with your xinitrc or a DE script if you prefer to fix that issue.
blackout24 Dec 1, 2012 @ 1:08am 
http://scr3.golem.de/screenshots/1107/KDE_SC_4.7/thumb620/kde_47_14.png

See the V Sync Option at the bottom for KWin? Disable it. It also toggels system wide vsync.
Vash Dec 1, 2012 @ 1:09am 
Okay, was in game before but I got the command. Try putting 'nvidia-settings --load-config-only' into any script that loads with Xorg. I put mine in /etc/X11/xinit/xinitrc.d/45-nvidia-settings but there's a lot of ways to do it per your preference and distribution.
Rain Ninja Dec 1, 2012 @ 1:39am 
Does having the Vsync option on KDE actually affect anything if the effects are disabled though? Doesn't make sense to me.
Nevertheless I'll try it. I'll also make note of the NVIDIA settings thing too.

Seems strange that toggling it ingame would have effect though if it's caused by something else in the system.
Last edited by Rain Ninja; Dec 1, 2012 @ 1:41am
blackout24 Dec 1, 2012 @ 1:44am 
Originally posted by Rain Ninja:
Does having the Vsync option on KDE actually affect anything if the effects are disabled though? Doesn't make sense to me.
Nevertheless I'll try it. I'll also make note of the NVIDIA settings thing too.

Seems strange that toggling it ingame would have effect though if it's caused by something else in the system.

From my testing the KWin settings have always overwritten the applications settings. Just like enabling/disabling VSync in games doesn't do squat when you have enabled it globaly in nvidia-settings.

I had to disable it in 3 places (KWin, nvidia-settings and in-game) to make sure it won't be enabled in any form.

In Kwin also make sure to disable desktop effects for fullscreen windows. It should help the performance.
Last edited by blackout24; Dec 1, 2012 @ 1:47am
Rain Ninja Dec 1, 2012 @ 2:11am 
Okay thank you both. And apologies to any Croteam guys, your game has done nothing wrong :P Except be a victim of a lack of Adaptive VSync I guess.

This is going to seem pretty stupid, but after much head scratching I realised that in NVIDIA-settings I have to press "Quit" instead of clicking the close button on the window manager border for it to actually apply the changes in real time after disabling Vsync. Then I started SS3 again and what do you know... working as it should.

So nvidia-settings strikes again. I did re-enable VSync in KWin (I hate my composited desktop windows tearing when I move them lol) and found that the game was still unaffected and running in all its non-VSync glory, once I nailed the nvidia part of it. So that's an odd one t.jp, but I guess YMMV and all that.
Last edited by Rain Ninja; Dec 1, 2012 @ 2:12am
blackout24 Dec 1, 2012 @ 3:21am 
That's why I submitted an issue report for the lack of adaptive vsync so valve can request that the next time they work together with nvidia.
http://steamcommunity.com/app/221410/discussions/1/882966057015293690/

If you have adaptive VSync there is no reason to not enable it.

Here is a thread with a simliar problem that someone has to toggle on and off gain to disable it.
http://steamcommunity.com/app/221410/discussions/1/882966056698583150/

I guess there is no clear rule what setting overwrites what so only after toggeling on and off once the problem is solved.

"Heh, I've got the opposite problem. Xubuntu 12.10, vsync is enabled in both nvidia settings and in TF2, no vsync in the game (obvious tearing on viewpoint rotation with mouse)."

What he writes is probably due to X server short-comings. If you don't get clearly more FPS than your native refrash rate enabled V Sync will not do it's job. Because simply limiting it to 30 FPS will still result in tearing. This seems to be a problem in video playback also where you have a real fixed framerate of 25 or 30 FPS according to this article.
http://www.phoronix.com/scan.php?page=news_item&px=MTIzOTQ

Last edited by blackout24; Dec 1, 2012 @ 3:28am
Rain Ninja Dec 1, 2012 @ 3:25am 
Yep it seems like it. The funny thing is TF2, even without me playing with nvidia-settings, has been running with FPS between 50-140 FPS the whole time I've had it installed.

So I guess in my case TF2 was somehow bypassing it anyway.
blackout24 Dec 1, 2012 @ 3:31am 
To get a perfect gameing experience we'll have to wait for Wayland to be useable and the NVIDIA driver supporting it in the first place ( it needs Kernel Mode Setting I guess which is only in the open source drivers) along with adaptive VSync.
Last edited by blackout24; Dec 1, 2012 @ 3:31am
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Dec 1, 2012 @ 12:19am
Posts: 9