Steam for Linux > Limited Beta > Topic Details
Rorschach Nov 30, 2012 @ 9:01am
Issue Report: Team Fortress 2 in Black Screen
The Team Fortress 2 is Launching but stills in a Black Screen with the Valve's theme song and nothing happens after. Here my system configuration:


Processor Information:
Vendor: GenuineIntel
Speed: 2200 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (32 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-19-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Mobile Intel® GM45 Express Chipset x86/MMX/SSE2

Driver Version: 2.1 Mesa 9.0
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x8086
DeviceID: 0x2a42
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 12,17" x 6,85" (13,94" diag)
30,9cm x 17,4cm (35,4cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC272

Memory:
RAM: 1978 Mb

Miscellaneous:
UI Language: English
LANG: pt_BR.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 154956 Mb
Largest Free Hard Disk Block: 18615 Mb
Showing 1-5 of 5 comments
< >
steve12123 Dec 8, 2012 @ 12:49pm 
I can confirm the issue. I am using a Lenovo Thinkpad X201 NUSDBGE.

Processor Information:
Vendor: GenuineIntel
Speed: 2667 Mhz
4 logical processors
3 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
"Arch Linux" (64 bit)
Kernel Name: Linux
Kernel Version: 3.6.9-1-ARCH
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: Intel Open Source Technology Center Mesa DRI Intel(R) Ironlake Mobile x86/MMX/SSE2

Driver Version: 2.1 Mesa 9.0.1
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x8086
DeviceID: 0x46
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1280 x 800
Desktop Resolution: 1280 x 800
Primary Display Size: 10,28" x 6,42" (12,09" diag)
26,1cm x 16,3cm (30,7cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Intel IbexPeak HDMI

Memory:
RAM: 7786 Mb

Miscellaneous:
UI Language: English
LANG: de_DE.utf8
Microphone: Not set
Total Hard Disk Space Available: 122200 Mb
Largest Free Hard Disk Block: 355 Mb

Installed software:

Recent Failure Reports:

Tux Dec 8, 2012 @ 1:27pm 
Try this: http://steamcommunity.com/app/221410/discussions/0/846938351032713908/

Edit: Although that looks more like an Intel Video driver issue.
play3man Dec 8, 2012 @ 3:39pm 
Here guys http://steamcommunity.com/app/221410/discussions/6/846939071071956036/ Write here. Let Valve see that we want support for older Intel GPUs!
vange Dec 8, 2012 @ 3:44pm 
Confirmed here as well on Lenovo X201s
Esophagus Now Dec 10, 2012 @ 6:44am 
Confirmed with an Intel HD 300 card. Ironlake mobile driver. I've also started a thread to discuss new suggestions, if you'd like to join it: http://steamcommunity.com/app/221410/discussions/1/846939071357669557/
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Nov 30, 2012 @ 9:01am
Posts: 5