Steam for Linux > Limited Beta > Details van topic
Walther 30 nov 2012 om 6:52vm
Issue report: nvidia-experimental-310 and bumblebee incompatibility
For those running a laptop with Optimus technology, installing bumblebee/optirun and the new, improved drivers (nvidia-experimental-310) is impossible. Installing the new drivers causes bumblebee to uninstall, due to missing dependency, nvidia-current.

I submitted a bug report about this https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-experimental-310/+bug/1085044 and it could be useful to know if / how many others are affected.

Ubuntu 12.10 and Ubuntu 13.04,
nvidia-current, nvidia-experimental-310, bumblebee
1-4 van 4 reacties weergegeven
< >
DaVince 30 nov 2012 om 6:58vm 
I was a victim of this problem before and solved it by adding the Xorg-edgers[launchpad.net] repository. The repository has the latest driver available as nvidia-current, so it won't uninstall bumblebee. This also seems to be working perfectly (for the moment).

Do note that Xorg-edgers is so cutting edge it might end up breaking Xorg, so you should be prepared to take the risk. You should be able to apt-purge the repository if it failed and get back on a stable Xorg release, though.
Laatst bewerkt door DaVince; 30 nov 2012 om 6:59vm
Walther 30 nov 2012 om 7:57vm 
However, installing / setting up that edgers repository should *not* be the solution - an experimental beta driver should be possible to install and use without making your entire system at risk with a bleeding edge / alpha repository for your entire X. Besides, the 310 is even the recommended one by Valve, if i recall correctly ;)
DaVince 30 nov 2012 om 8:03vm 
Yup, the "stable" one in that repo is the 310.x one, actually (310.19 to be exact).

I think this is just a solution for us testers - I'm more or less counting on 310.x or higher being the nvidia-current driver once Steam gets officially released. Or at least that bumblebee will accept the nvidia-experimental-310 package (good of you to have reported that :) ).
Laatst bewerkt door DaVince; 30 nov 2012 om 8:04vm
Barbarian 30 nov 2012 om 10:09vm 
I've passed this on to the #bumblebee IRC channel, hopefully they take a look at this.

EDIT: Lol, walther beat me to it :P Official bug report is here: https://github.com/Bumblebee-Project/bumblebee-ppa/issues/1
Laatst bewerkt door Barbarian; 30 nov 2012 om 10:17vm
1-4 van 4 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 30 nov 2012 om 6:52vm
Aantal berichten: 4