Steam for Linux > Limited Beta > รายละเอียดกระทู้
branchman 29 พ.ย. 2012 @ 3:50pm
Issue Report: A Steam Engine Instance already exists
Steam reported error just after starting:
Fatal Error: Steam failed to load: *SteamStartEngine(0xfffa7a00) failed with error 1: A Steam Engine Instance already exists.

This bug could not be reproduced, but it could help when revealing another problems, so am reporting it.
Steam on Ubuntu 12.10 (64bit),
กำลังแสดง 1-3 จาก 3 ความเห็น
< >
StolenArt 7 ธ.ค. 2012 @ 3:09pm 
This happens to me each time I try to load Steam.

I suspect it's because I had steam on my system before I got my beta key. Un-installing steam it with:

sudo apt-get remove steam

and re-installing does not fix the issue.

No fix as yet but I'll post when I have something.

Specs:
Ubuntu 12.04.
system Dell Studio XPS 8100
processor Intel i5 3.47GHz
memory 8GiB System Memory
display Redwood [Radeon HD 5670]
bridge 82801 PCI Bridge
Morgawr 20 ธ.ค. 2012 @ 10:28am 
I just found out a solution/fix to this problem... I know it's late but somebody might find it useful. Apparently steam on linux uses a process called "MainThrd" so when you're looking for the various processes on your task list you may not identify it immediately as steam-related.

Just kill the "MainThrd" process (killall MainThrd in your terminal) and then steam should start normally again.
kleshas 20 ธ.ค. 2012 @ 10:50am 
Thankyou Morgawr - that fixed my Steam not running at all.
กำลังแสดง 1-3 จาก 3 ความเห็น
< >
ต่อหน้า: 15 30 50