Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Topic Details
kamjau Nov 27, 2012 @ 10:16pm
Issue Report: Incorrect default Xbox 360 pad mappings, custom mappings not remembered
Not sure if this is considered a bug, but anyway.. Big Picture mode seems to be designed for an Xbox 360 pad, but the default mappings are incorrect for that pad. For example, the UI says to press A to select and B to go back, but with the default mapping you press B to select, X to go back, and apart from that and the left stick nothing else seemed to do anything.

I'm using the normal wired usb Xbox 360 controller from Microsoft. The controller customization says it detected the controller as "Microsoft X-Box 360 pad". Also tried with a Logitech F510 (xbox360 compatible, exact same layout in SDL, but detected as "Generic X-Box pad"), with same results.

Anyway, after customizing the controls, it works fine. (Uploaded the mappings, too.)

edit: Mappings are reset to the default between launches of Big Picture mode if you switch to a different controller and then switch back again. They're not remembered for each pad. Also, you can't swap controllers while in Big Picture (pad just stops working)

System info: (hey, why not)
Processor Information: Vendor: GenuineIntel Speed: 2794 Mhz 4 logical processors 4 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-18-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2 Driver Version: 4.3.0 NVIDIA 310.14 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x10de DeviceID: 0xe22 Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 1920 x 1080 Primary Display Size: 20,04" x 11,26" (22,95" diag) 50,9cm x 28,6cm (58,3cm diag) Primary Bus: PCI Express 16x Primary VRAM: 767 MB Supported MSAA Modes: 2x 4x 8x 16x Sound card: Audio device: SigmaTel STAC9721,23 Memory: RAM: 7981 Mb Miscellaneous: UI Language: English LANG: nb_NO.UTF-8 Microphone: Not set Total Hard Disk Space Available: 2816683 Mb Largest Free Hard Disk Block: 1417816 Mb Installed software:
Last edited by kamjau; Nov 27, 2012 @ 10:34pm
< >
Showing 1-11 of 11 comments
CompanionTube Nov 27, 2012 @ 10:47pm 
noticed the same problem, it's a show stopper for using big picture mode.
mjau could you tell us how you remapped the keys please thanks
Last edited by CompanionTube; Nov 27, 2012 @ 10:47pm
kamjau Nov 27, 2012 @ 10:54pm 
Originally posted by RandomWeeJ:
noticed the same problem, it's a show stopper for using big picture mode.
mjau could you tell us how you remapped the keys please thanks
In Big Picture mode, use the mouse to go to settings (gear icon) -> controller -> edit settings, click the top one and start pressing the buttons indicated in green on the left hand side (for shoulders, set the flat ones first). It'll only remember the settings for as long as you keep using the same controller for Big Picture mode though.

Also, just noticed the Cancel button on that screen doesn't work. Esc does though.
Last edited by kamjau; Nov 27, 2012 @ 10:55pm
CompanionTube Nov 27, 2012 @ 10:55pm 
thanks again :-)
ThOR27 Nov 28, 2012 @ 3:18am 
In my controller every buttons works but the "middle button" that was supposed to call the steam overlay.

I have a XBOX 360 compatible controller Razer Onza
Last edited by ThOR27; Nov 28, 2012 @ 3:18am
Thyago Dec 7, 2012 @ 2:23am 
Happened the same to me, Big Picture starts with the B button working as the primary action. But going in the settings and updating it helped.
ximian Dec 7, 2012 @ 3:43am 
Same here. No matter if I'm using xpad or xboxdrv driver.
Mohero Dec 7, 2012 @ 3:53am 
I also noticed this, and looking at the Joystick settings it looks like Linux is picking 'A' up as button 0 and 'B' as button 1, so perhaps the problem is that windows is starting at Button 1, so all the mappings under Linux the buttons are out by 1 (index origin of 0 / 1).
mastorak Dec 8, 2012 @ 2:02pm 
the mappings for x360 controller are mapped incorrectly for me as well. I am using the default xpad driver
Br.uNo Dec 15, 2012 @ 3:29am 
Same here, the keys wrongly mapped.
Arxcis Dec 18, 2012 @ 7:05pm 
+1 but Valve has made it easy to fix this in Big Picture from controller-settings. If only it was this easy in every game, or if we could configure this in the OS/BigPicture to have it work across all-games.
Last edited by Arxcis; Dec 18, 2012 @ 7:22pm
Kwazii Dec 21, 2012 @ 3:24pm 
Not really much more to say other than I'm having the same issue.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Steam for Linux > Limited Beta > Topic Details