Steam for Linux > 一般討論 > 主題細節
Werm_Rolent 2012 年 11 月 24 日 @ 上午 10 時 42 分
fatal error: failed to load steamui.so
Prompt. How to cope with this problem?
顯示 1-13,共 13 則回應
< >
Werm_Rolent 2012 年 11 月 24 日 @ 上午 10 時 46 分 
Olorin 2012 年 11 月 24 日 @ 下午 4 時 19 分 
64 bit right? In that case, install the package «ia32-libs».
Werm_Rolent 2012 年 11 月 25 日 @ 上午 2 時 31 分 
I have 64 bit system. ia32-libs is already installed
Werm_Rolent 2012 年 11 月 25 日 @ 上午 3 時 49 分 
gksudo:9411): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
Installing breakpad exception handler for appid(steam)/version(1353457964_client)
Installing breakpad exception handler for appid(steam)/version(1.0)




werm@localhost:~/Рабочий стол$ steam

(gksudo:9819): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
/home/werm/Steam/ubuntu12_32/steam: /lib32/libc.so.6: version `GLIBC_2.15' not found (required by /home/werm/Steam/ubuntu12_32/steam)
/home/werm/Steam/ubuntu12_32/steam: /lib32/libc.so.6: version `GLIBC_2.15' not found (required by /home/werm/Steam/ubuntu12_32/steam)
最後修改者:Werm_Rolent; 2012 年 11 月 25 日 @ 上午 3 時 55 分
Novalax 2012 年 11 月 25 日 @ 下午 7 時 06 分 
i'm also having this problem. I have ia32-libs installed too.
FiXIDeA 2012 年 11 月 25 日 @ 下午 7 時 46 分 
sudo sh -c 'echo "/usr/lib32\n/usr/lib/i386-linux-gnu/mesa\n" >> /etc/ld.so.conf.d/steam.conf' && sudo ldconfig
FiXIDeA 2012 年 11 月 25 日 @ 下午 7 時 47 分 
And use search!
FiXIDeA 2012 年 11 月 25 日 @ 下午 7 時 48 分 
it's correcting for your user
sudo sh -c 'echo "/usr/lib32\n/usr/lib/i386-linux-gnu/mesa\n/home/werm/Steam/ubuntu12_32\n" >> /etc/ld.so.conf.d/steam.conf' && sudo ldconfig
Werm_Rolent 2012 年 11 月 25 日 @ 下午 9 時 06 分 
FiXIDeA 發表:
And use search!
ok
master_zion 2012 年 12 月 6 日 @ 下午 10 時 21 分 
Try this command!
------------------
export LD_LIBRARY_PATH=/usr/lib32:/usr/lib/i386-linux-gnu/mesa:$LD_LIBRARY_PATH/usr/bin/steam:~/.steam/bin32
~/.steam/bin32


if not worked, try remove the local usser folder, re-execute using menu and repeat last step
rm -rf ~/.steam/bin32

abstractalchemist 2012 年 12 月 6 日 @ 下午 11 時 33 分 
don't like the fact i have to start it from the command line; would prefer it to be through the double click icon on the desktop. adding it to the /usr/bin/steam script doesn't help, either, because updating causes the script to be re-written, over-writing my change.

a little irritating; hopefully the team fortress beta will help liven things up.
Amerika 2013 年 01 月 26 日 @ 下午 12 時 31 分 
FiXIDeA 發表:
it's correcting for your user
sudo sh -c 'echo "/usr/lib32\n/usr/lib/i386-linux-gnu/mesa\n/home/werm/Steam/ubuntu12_32\n" >> /etc/ld.so.conf.d/steam.conf' && sudo ldconfig

I'd like to thank you as I was getting this error on Mint 14 and it fixed my issue.
randomsalad 2013 年 01 月 26 日 @ 下午 2 時 02 分 
If by chance you are using a laptop with hybrid graphics (such as Nvidia Optimus technology in my case) and none of the solutions above work, try installing Bumblebee and use the terminal command

optirun steam
顯示 1-13,共 13 則回應
< >
每頁: 15 30 50
張貼日期: 2012 年 11 月 24 日 @ 上午 10 時 42 分
回覆: 13