uh20 Nov 23, 2012 @ 8:30pm
will there be source support for lower opengl versions
with some info about tf2 apparently needing an extension my video card does not have.
-fx1400. by the way. ๏_๏ http://steamcommunity.com/app/221410/discussions/0/882966056532198187/
will there be a launch option simmilar to windows (-dxlevel <90) to bypass such feature and be able to play on older cards?

can someone on the beta try -dxlevel 81 -gllevel 22 (etc.) to see if anything happens?
-edit, -dxlevel is the proper usage, but 90 and 92 seem to be the only possible selections
Last edited by uh20; Nov 26, 2012 @ 5:16pm
Showing 1-6 of 6 comments
< >
TimePath Nov 23, 2012 @ 8:40pm 
We still use -dxlevel to lower the graphics settings - the directX shaders and such are mapped to those of openGL. Like emulation, if you will.
uh20 Nov 23, 2012 @ 10:49pm 
is that just speculation, or did you actually try it?
i asked the guys in the forum above to try -dxlevel 81 and -dxlevel 71, hope it works.

still, theres evidence the linux version is doing some more checking than usual for extensions, so i want a bit more of a guarantee than just technical speculation.
TimePath Nov 23, 2012 @ 11:03pm 
It seemed to have the same effect as it does on windows - though further inspection reveals 'mat_dxlevel' is restricted between 90 and 92. So it may not actually do a lot, but it does still reset the video settings as usual.
uh20 Nov 25, 2012 @ 8:45pm 
take a read at this
http://steamcommunity.com/app/221410/discussions/0/882966057002278732/
apparently there are opengl3.3 stuff that you cant bypass, i sure hope valve can get previous hardware support because its going to be one LONG time till chistmas before i can finally run tf2 (and properly support my irrlicht stuff)
bl33ding_silence Nov 25, 2012 @ 9:41pm 
I second this. Seeing that TF2 runs on lower DX levels (and that it runs on the same hardware on windows, but not on OpenGL), I think they should allow for lower OpenGL versions here too. Someone on the post you linked to (my post) has already tried -dxlevel 71, and it doesn't seem to work. (But I think you should try it as well. I will need to reinstall TF2 to do that)
Alex Dead Nov 25, 2012 @ 10:19pm 
тоже очень интересно
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Nov 23, 2012 @ 8:30pm
Posts: 6