c☢re meltd☢wn Nov 23, 2012 @ 2:45pm
[Issue Report] No sound in TF2
I run Ubuntu 12.10 with XFCE and Steam and TF2 seems to run fine except there is no sound in TF2. I can still hear sound started from other programs, also sound in SS3 works fine.

I don't think this issue is related to the other TF2sound related problem somewhere in the forums since I don't get any errors on the console.

A whole console dump and system configuration dump seems a bit long for a forum post, so here the breiefs:
* Kernel: 3.5.0-19-generic x86_64
* CPU:1100T 6C@stock3700
* GPU: 2*GTX 570, 310.14 driver
* RAM: 32GB 1600MHz
Showing 1-8 of 8 comments
< >
Maurice the Cat Nov 23, 2012 @ 5:54pm 
Do you have PulseAudio installed? It seems like sound in TF2 works only with Pulse.
p1r8t3 Nov 24, 2012 @ 12:58am 
Issue reports should be at the Limited Beta Section, and check if someone already posted this issue by using the search.
c☢re meltd☢wn Nov 24, 2012 @ 1:29am 
Pulseaudio is installed. Sorry for posting in the wrong section. The other TF2 sound thread looks unrelated.
c☢re meltd☢wn Nov 25, 2012 @ 2:08pm 
Resolved. Problem was sound being sent to HDMI output instead of speakers/headphones.
MaximB Nov 27, 2012 @ 12:45am 
Got the same issue, but I use only ALSA on my system so it could be the reason.
Nickoe Dec 9, 2012 @ 3:27am 
Well as mentioned in http://steamcommunity.com/app/221410/discussions/0/846938351064371367/ starting steam with 'SDL_AUDIODRIVER=alsa steam' works
Aperion Dec 13, 2012 @ 11:42pm 
Originally posted by Core Meltdown:
Resolved. Problem was sound being sent to HDMI output instead of speakers/headphones.

I have the same issue, I have a headphone jack on my keyboard that registers as a sound card when headphones are plugged in. Sounds for steam and other games work fine (ie through headphones), but TF2 still comes out of the speakers. even as steam notifications sounds come through the headphones.

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Sound card:
Audio device: Realtek ALC889A

I do not see my keyboard listed on there.
CallMeThing Dec 15, 2012 @ 1:32am 
export SDL_AUDIODRIVER=alsa before starting Steam works. Still, shouldn't be necessary.
I encountered the bug on the following system:

OpenSuSE 12.2 x64
KDE Desktop
Kernel 3.4.11
fglrx drivers

Hardware:
Sound: Realtek HD (ALC889A)
Graphics: AMD Radeon HD 6950
CPU: AMD Phenom II x4


Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Nov 23, 2012 @ 2:45pm
Posts: 8