cabal Nov 22, 2012 @ 6:35pm
S3TC failure
I get a failed to load S3tc error when I start TF2. I'm running Linux Mint 13 but a few days ago I was running Ubuntu 12.10 and TF2 was launching fine. Any ideas on what the problem could be?
Showing 1-5 of 5 comments
< >
cabal Nov 22, 2012 @ 6:39pm 
I'm on my mobile (at work) but when I get a chance I'll post the exact wording of the error message.
c3141st Nov 22, 2012 @ 8:54pm 
S3TC is a patented texture compression algorithm. A lot of distros don't bundle it by default as a result. I don't know what it is on Mint but on Arch the package name is lib32-libtxc-dxtn. Perhaps there is something similar in the Mint repositories.
sortie Nov 22, 2012 @ 10:35pm 
sudo apt-get install libtxc-dxtn-s2tc0:i386 (add the :i386 part if on a 64-bit system) (installs a patent-free implementation of s3tc)
kavika Sep 20, 2014 @ 4:41pm 
This solved the problem for me on my 64 bit system (`sudo apt-get install libtxc-dxtn-s2tc0:i386`) after I installed xorg-edgers on top of mint. Working A'OK now! This fixed Dota 2 and Legend of Grimrock for me, so I no longer have to do the `force_s3tc_enable=true steam` work-around (which also worked for me - but this is way easier).
Last edited by kavika; Sep 20, 2014 @ 4:43pm
Showing 1-5 of 5 comments
< >
Per page: 15 30 50

Date Posted: Nov 22, 2012 @ 6:35pm
Posts: 5