Steam for Linux > 일반 토론 > 제목 정보
Kultsinuppeli 2012년 11월 22일 오전 11시 47분
Issue Report: TF2 Crashes with segfault in-game
II just installed TF2, and it runs, I can play the training. When I play online, TF2 segfaults after ~10 minutes of play (just tested twice). System info below. I have the Catalyst 12.11 beta drivers (not beta8).

Segfault from the terminal:

/home/username/Steam/SteamApps/accoutname/Team Fortress 2/ line 72: 3308 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 3308

Processor Information:
Vendor: GenuineIntel
Speed: 2668 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-18-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 7800 Series

Driver Version: 4.2.11978 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6819
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.91" x 11.77" (23.98" diag)
53.1cm x 29.9cm (60.9cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: VIA VT1828S

RAM: 12008 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 636645 Mb
Largest Free Hard Disk Block: 335438 Mb

Installed software:

25개 중 1-15 표시중
< >
b0z0 2012년 12월 4일 오전 9시 15분 
Also getting segfault at line 72

Got similar setup, Ubuntu 12.10 64-bit and AMD Radeon HD 7700
[LINUX]FinCoder 2012년 12월 5일 오후 3시 23분 
Also have 12.10 version, but KUBUNTU with ati 7770. Seg fault error.
Kultsinuppeli 2012년 12월 6일 오전 11시 22분 
Just noticed that this at least happened when changing levels. I've played a fair bit today, and that's the only time I noticed
Kultsinuppeli 2012년 12월 6일 오전 11시 55분 
And more info, found this in dmesg. I think it's related
[42504.604961] MainThrd[11232]: segfault at 0 ip 00000000eb0b87a8 sp 00000000ffe0ccc0 error 4 in[eaf60000+5f8000
portets 2012년 12월 7일 오전 12시 44분 
Are you guys running TF2 Beta? For some reason Steam had me download the Beta at first.
EPIC VOID 2012년 12월 7일 오전 1시 24분 
same error with TF2 and TF2 BETA
Kultsinuppeli 2012년 12월 7일 오전 1시 28분 
Nope, not running TF2 Beta
3edcv 2012년 12월 7일 오전 11시 32분 
Same error for me, segfault line 72, not able to start TF2
Ubuntu 12.10 amd hd6800
Ruekov 2012년 12월 8일 오후 3시 50분 
Maybe it isn't an useful information at all: I get this error after changing the drivers from default open drivers to privative ones.
e633 2012년 12월 8일 오후 4시 35분 
Me too. Can't find the actual dump though. Where is it?
line 72: 4050 Segmentation fault (core dumped)
Happened after loading the very first tutorial.
Sys specs:
e633님이 마지막으로 수정; 2012년 12월 8일 오후 4시 36분
mikesart 2012년 12월 8일 오후 5시 44분 
There should be something like this that is spewed out to the terminal when TF2 crashes.


Can you let me know what the CrashID is and I'll try to see what the stack dump says. Thanks.
e633 2012년 12월 9일 오전 2시 20분 
Here's mine.
DrakeDranil 2012년 12월 9일 오전 6시 16분 
Same issue here.
~/.local/share/Steam/SteamApps/drakedranil/Team Fortress 2 Beta/ line 72: 2679 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"


Reproduction: Every time I load TF2 beta. It happens after the 'Powered by steam' logo and before the TF2 menu. (So during the wait screen with some random building in the background)

Additional info:
* Started to happen when I switched from nvidia-304 to nvidia-310. Purging nvidia-310 and switching back to 304 didn't help. (No matter how many reboots)

* Even after the segfault the "steam steam://rungameid/520" process remains alive (so do the 40+ threads with the same name) with a steady 6.0% load and keeps holding the allocated memory (14.4 MEM%). But nothing what a SIGTERM (15) can't fix.

If there is any additional information that would be useful, please ask. We are all here to help. :-)

@e633: On my system, the dumps are located under /tmp/dumps/.
Steam - System Information:

@mikesart: I just figured it out that it's my wireless mouse. I went here to update my post, but it seems you have beat me by two hours :). Awesome to hear a fix is already implemented!

The three workarounds mentioned by [DeTag] Defrag and yours seem to work:
DeTag Defrag님이 먼저 게시:
Workaround: Unplug mouse, launch TF2 with keyboard, plug mouse back in after menu has loaded.

UPDATE: This seems to be a issue with the mouse. I have tried a very standard mouse and it seemed to work. info on my mouse here[]. Most notably, it has variable sensitivity.

UPDATE2: giving the -nojoy parameter to TF2 (through properties > "set launch options") seems to be another workaround

Nonetheless my apologies for posting in this thread which now seems to be unrelated with my issue, apart from segfaulting in line 72.
DrakeDranil님이 마지막으로 수정; 2012년 12월 9일 오후 1시 36분
mikesart 2012년 12월 9일 오전 10시 20분 
Looks like those last two are hitting the buffer overrun bug in the joystick code - I just fixed that on Saturday and it should be pushed out this week. Can you add -nojoy to your command line for TF2 - that should fix it. Sorry!

e633: d904700a-43a5-4420-8fb0-f3f37212120 is an assert in Steam. You say this happened after loading the tutorial? Does this repro?
e633 2012년 12월 9일 오전 10시 56분 
Tried to reproduce. But this time i completed the first part of the soldier tutorial just fine. Then quit the game, reopened it with the intention of playing the second part but as soon as it showed the in-game "movie" thing it crashed to Desktop.
Console says:
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197971868066 [API loaded yes]
Steam_SetMinidumpSteamID: Setting Steam ID: 76561197971868066
Game update: AppID 440 "Team Fortress 2", ProcID 8918, IP
Installing breakpad exception handler for appid(hl2_linux)/version(1.0_client)
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0_client)
Installing breakpad exception handler for appid(hl2_linux)/version(1.0_client)
ExceptionHandler::GenerateDump waitpid failed:No child processes
Uploading dump (in-process) [proxy '']
success = no
error: Failed to open/read local data from file/application
Game removed: AppID 440 "Team Fortress 2", ProcID 8918
/home/ste/.local/share/Steam/SteamApps/e633/Team Fortress 2/ line 72: 8918 Segmentation fault (core dumped)
Sun Dec 9 18:47:10 2012 GMT: file ''/tmp/dumps/crash_20121209194710_1.dmp'', upload no: ''Failed to open/read local data from file/application''
The actual dump of course is nowhere to be found.
e633님이 마지막으로 수정; 2012년 12월 11일 오전 10시 53분
25개 중 1-15 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 11월 22일 오전 11시 47분
게시글: 25