Colgy Nov 21, 2012 @ 9:57pm
Serious Sam 3: Unable to change Pulse Audio Device
Serious sam refuses to output to anything but my HDMI out device(which has nothing connected to it). Any way to make it route through my surround out? In paucontrol, it lists all my audio devices correctly, but when I tell it to swap, it doesn't change.

I could record the monitor of the HDMI out and output that to the surround out, but I would really prefer to just be able to just tell it to output to the correct device.
Showing 1-10 of 10 comments
< >
^1Gentoo Nov 21, 2012 @ 10:07pm 
Just change what your PulseAudio outputs too. Like installing some PulseAudio settingsmanager.
Colgy Nov 21, 2012 @ 10:12pm 
Did you even read my post? I tried that. It doesn't change.
Colgy Nov 21, 2012 @ 10:20pm 
Completely disabling the HDMI out in pulse works for now. It changed its output device to the correct one at least, but it is hardly a permanent solution.
joe Nov 22, 2012 @ 12:51am 
I have this issues with several non steam games. I deactivate all but one audio devices, start the game and it will keep using the correct device in the future. Of course still not a good behavior.
johndrinkwater [🐧︀ 🎮] Nov 22, 2012 @ 4:21pm 
So is this a PulseAudio issue with not properly sharing the primary audio device, or SS3 not picking the ones its told to use?
ThOR27 Nov 22, 2012 @ 5:07pm 
Setting default output in sound configuration tool in Ubuntu works perfectly for me. So in theory SS3 gets the device that is set there...
joe Nov 23, 2012 @ 12:25am 
I think what he means and what I have with other games is that changing the device while the game is running is not working.
Usually you can do this with all programs, these few games are the exception.
Colgy Nov 23, 2012 @ 1:08pm 
That is correct joe. I've never had this issue with any other program ever. I'm surprised that pulse wouldn't just change the device, I didn't think it cared about what the program was doing.
mdeezle Dec 10, 2012 @ 5:46pm 
you should just blacklist the module you aren't planning on using. /etc/modprobe.d/blacklist.conf, open a term window and type "lsmod" find the module for the card you want to disable and throw the module in that file. works great for me.
Colgy Dec 10, 2012 @ 7:26pm 
I don't want to blacklist the snd_hda_codec_hdmi kernel module as I do hook my computer up to my TV via hdmi on occasion.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Nov 21, 2012 @ 9:57pm
Posts: 10