Steam for Linux > 综合讨论 > 主题详情
Доктор Блейзер 2012年11月21日下午7:06
TF2 problem.
I'm trying to play Team Fortress 2.
When starting it the following error occurs: "Required OpenGL extension " GL_EXT_texture_sRGB_decode" is not supported. Please update your OpenGL driver. " (Ubuntu 12.04 32bit proprietary driver, Radeon HD 6470M)
最后由 Доктор Блейзер 编辑于; 2012年11月22日上午2:54
正在显示第 1 - 12 条,共 12 条留言
< >
Madkinder 2012年11月21日下午10:25 
Same here:

Ubuntu 12.04 x86_64
Radeon HD 7870
Proprietary fglrx drivers installed from packages, version 8.960-0ubuntu1.1

The GL_EXT_texture_sRGB extension is there, but not the GL_EXT_texture_sRGB_decode one (not sure what's the difference though):
$ glxinfo | grep GL_EXT_texture_sRGB
GL_EXT_texture_rectangle, GL_EXT_texture_sRGB,
Chumba 2012年11月22日上午9:36 
Exact same here and same response from glxinfo. Clearly steam is failing to detect this information correctly
Kano 2012年11月22日上午9:54 
You both test wrong. You only verify the 64 bit extensions, but steam checks the 32 bit part of the driver. Maybe that is incorrectly installed, possible when somebody executed the amd-installer without buildpkg option.
big'un 2012年11月22日上午10:29 
I fixed this by going to the AMD/ATI Linux drivers web page and downloading the 12.10 driver. Set it to executable and ran it. Had to uninstall the fglrx driver that Ubuntu wants to stick on there first. when I ran TF2 for the first time after it wanted to stick back on the old drivers. just cancel out of this. worked great for me. hope this works for you
ext_vir 2012年11月22日下午12:35 
Same issue here, 64bit Ubuntu 12.04
Radeon HD 6970
Managed to fix it by installing the latest AMD driver (12.10)
HadBabits 2012年11月22日下午3:30 
Drivers fixed mine too :D But now my audio is gone on my computer :D.....
HadBabits 2012年11月22日下午4:48 
Nevermind it was just muted, fixed with alsa mixer
Augy 2012年11月27日下午1:04 
What to do if I have radeon 4000 series and the latest driver version is 12.6 legacy :<
sombra2eternity 2012年12月26日上午8:28 
@avgdima Never buy ATI again, i was and ATI buyer before and have the same problem with a 4850, I hope this ♥♥♥♥ty company go bakrupt, NVIDIA is not perfect but way less far than ATI will never be.
Sunny 2012年12月26日下午12:37 
i WAS GETTING THIS ERROR wit this driver but now it is working fine in my ubuntu and RADEON HD 6570, JUST UPDATE TO 12 10 UBUNTU 32 bit AND TRY INSTALLING 3 DEC2012 DRIVER FROM AMD BUT YOU HAVE TO FIX ITS package builder because there are "issues building packages for new driver YOU HAVE TO FIX ITS SCRIPT NAMED "RULES" .deb rules script there is ARCHITECTURE TYPO in it , make it done by a linux expert if you dont know linux .now I am happily playing Team fortress 2 in my ubuntu 12 10 :-)
最后由 Sunny 编辑于; 2012年12月26日下午1:18
The Poker 2013年1月15日上午5:23 
引用自 sombra2eternity
@avgdima Never buy ATI again, i was and ATI buyer before and have the same problem with a 4850, I hope this ♥♥♥♥ty company go bakrupt, NVIDIA is not perfect but way less far than ATI will never be.
nvidia is the biggest s**t ever! I have an Ati(hd4850) and a nVidia(notebook with optimus one year old) computer running ubuntu and it is much easier to get the computer running correctly with Ati, because of the driver support by AMD. On my notebook I have to use open drivers, because there never was any driver support for linux by nVidia, without the open drivers I had very slow graphics and a 800x600 resolution. my old ATi is not more supported by AMD but my just one year old nVidia card never was supported by nVidia.
Don't tell that nVidia would be better than ATi, that's lie!!
正在显示第 1 - 12 条,共 12 条留言
< >
每页显示数: 15 30 50
发帖日期: 2012年11月21日下午7:06
帖子数: 12