Steam for Linux > Algemene discussies > Details van topic
Доктор Блейзер 21 nov 2012 om 7:06nm
TF2 problem.
I'm trying to play Team Fortress 2.
When starting it the following error occurs: "Required OpenGL extension " GL_EXT_texture_sRGB_decode" is not supported. Please update your OpenGL driver. " (Ubuntu 12.04 32bit proprietary driver, Radeon HD 6470M)
Laatst bewerkt door Доктор Блейзер; 22 nov 2012 om 2:54vm
1-12 van 12 reacties weergegeven
< >
Madkinder 21 nov 2012 om 10:25nm 
Same here:

Ubuntu 12.04 x86_64
Radeon HD 7870
Proprietary fglrx drivers installed from packages, version 8.960-0ubuntu1.1

The GL_EXT_texture_sRGB extension is there, but not the GL_EXT_texture_sRGB_decode one (not sure what's the difference though):
$ glxinfo | grep GL_EXT_texture_sRGB
GL_EXT_texture_rectangle, GL_EXT_texture_sRGB,
Chumba 22 nov 2012 om 9:36vm 
Exact same here and same response from glxinfo. Clearly steam is failing to detect this information correctly
Kano 22 nov 2012 om 9:54vm 
You both test wrong. You only verify the 64 bit extensions, but steam checks the 32 bit part of the driver. Maybe that is incorrectly installed, possible when somebody executed the amd-installer without buildpkg option.
big'un 22 nov 2012 om 10:29vm 
I fixed this by going to the AMD/ATI Linux drivers web page and downloading the 12.10 driver. Set it to executable and ran it. Had to uninstall the fglrx driver that Ubuntu wants to stick on there first. when I ran TF2 for the first time after it wanted to stick back on the old drivers. just cancel out of this. worked great for me. hope this works for you
ext_vir 22 nov 2012 om 12:35nm 
Same issue here, 64bit Ubuntu 12.04
Radeon HD 6970
Managed to fix it by installing the latest AMD driver (12.10)
HadBabits 22 nov 2012 om 3:30nm 
Drivers fixed mine too :D But now my audio is gone on my computer :D.....
HadBabits 22 nov 2012 om 4:48nm 
Nevermind it was just muted, fixed with alsa mixer
Augy 27 nov 2012 om 1:04nm 
What to do if I have radeon 4000 series and the latest driver version is 12.6 legacy :<
sombra2eternity 26 dec 2012 om 8:28vm 
@avgdima Never buy ATI again, i was and ATI buyer before and have the same problem with a 4850, I hope this ♥♥♥♥ty company go bakrupt, NVIDIA is not perfect but way less far than ATI will never be.
Sunny 26 dec 2012 om 12:37nm 
i WAS GETTING THIS ERROR wit this driver amd-driver-installer-catalyst-12.11-beta11-x86.x86_64.zip but now it is working fine in my ubuntu and RADEON HD 6570, JUST UPDATE TO 12 10 UBUNTU 32 bit AND TRY INSTALLING 3 DEC2012 DRIVER FROM AMD BUT YOU HAVE TO FIX ITS package builder because there are "issues building packages for new driver YOU HAVE TO FIX ITS SCRIPT NAMED "RULES" .deb rules script there is ARCHITECTURE TYPO in it , make it done by a linux expert if you dont know linux .now I am happily playing Team fortress 2 in my ubuntu 12 10 :-)
Laatst bewerkt door Sunny; 26 dec 2012 om 1:18nm
The Poker 15 jan 2013 om 5:23vm 
Origineel geplaatst door sombra2eternity:
@avgdima Never buy ATI again, i was and ATI buyer before and have the same problem with a 4850, I hope this ♥♥♥♥ty company go bakrupt, NVIDIA is not perfect but way less far than ATI will never be.
nvidia is the biggest s**t ever! I have an Ati(hd4850) and a nVidia(notebook with optimus one year old) computer running ubuntu and it is much easier to get the computer running correctly with Ati, because of the driver support by AMD. On my notebook I have to use open drivers, because there never was any driver support for linux by nVidia, without the open drivers I had very slow graphics and a 800x600 resolution. my old ATi is not more supported by AMD but my just one year old nVidia card never was supported by nVidia.
Don't tell that nVidia would be better than ATi, that's lie!!
1-12 van 12 reacties weergegeven
< >
Per pagina: 15 30 50
Geplaatst op: 21 nov 2012 om 7:06nm
Aantal berichten: 12