Mitch Conner Nov 21, 2012 @ 12:29pm
Issue Report: Serious Sam 3 won't launch
I purchased and downloaded Serious Sam 3, and when I click play, a window appears asking if I want to play the normal game, or the modable version. Leaving the default, I click launch, and the window disappears. Nothing further happens.
Showing 1-6 of 6 comments
< >
AlenL Nov 22, 2012 @ 12:41pm 
Please do this:

- Exit from Steam
- start Steam from shell using this cmdline:

LD_DEBUG=files ./steam.sh

- then run the game
- collect the terminal output and game logs and paste here.

Thanks!
Kano Nov 22, 2012 @ 10:59pm 
Basically these kind of problems could be easyly solved by adding more depends to the steam.deb. It is not that hard to run ldd/dpkg -S. However some libs (libpci.so.3) are not found that way, right AlanL? I never tested your game as i do not want to buy it just for testing purpose, i absolutely dislike that idea.

I would suggest to automatically test for depends all games and collect the ones that could not be found that way and just add all those as hard depend in the control file (but without hardcoded version).

It would be very smart not to build against libc6 on Ubuntu but maybe against Debian wheezy, but maybe thats to hard right now as wish ;)
Tristan Schmelcher Nov 23, 2012 @ 12:12pm 
I was having this problem reproducibly until I ran "LD_DEBUG=files ./steam.sh" as requested. Somehow that "fixed" the problem. SS3 now opens and plays successfully, even when running Steam normally. Can't explain that.

Here's the info I collected before the problem went away:

I was experiencing the same user-visible behaviour as Mad Echidna. The window for choosing normal/moddable would disappear and nothing further would happen. When I retried, I would get an error that said "Failed to start game (app already running)".

Looking at the running processes, I was able to see that the game process was indeed running:

$ ps -ef | grep Sam3
tristan 4496 4106 0 11:44 ? 00:00:00 /bin/sh -c "/home/tristan/Steam/SteamApps/common/Serious Sam 3/Bin/Sam3"
tristan 4497 4496 0 11:44 ? 00:00:00 /home/tristan/Steam/SteamApps/common/Serious Sam 3/Bin/Sam3
tristan 4616 2567 0 11:54 pts/3 00:00:00 grep --color=auto Sam3
$

And it had a bunch of defunct children for running "uname":

$ ps -ef | grep -E '4496|4497'
tristan 4496 4106 0 11:44 ? 00:00:00 /bin/sh -c "/home/tristan/Steam/SteamApps/common/Serious Sam 3/Bin/Sam3"
tristan 4497 4496 0 11:44 ? 00:00:00 /home/tristan/Steam/SteamApps/common/Serious Sam 3/Bin/Sam3
tristan 4498 4497 0 11:44 ? 00:00:00 [uname] <defunct>
tristan 4499 4497 0 11:44 ? 00:00:00 [uname] <defunct>
tristan 4500 4497 0 11:44 ? 00:00:00 [uname] <defunct>
tristan 4618 2567 0 11:54 pts/3 00:00:00 grep --color=auto -E 4496|4497
$

(I doubt this is the problem here, but if you are going to fork child processes, you ought to clean them up (e.g., with waitpid()). But 90% of the uses of the "uname" command can be replaced with the uname syscall (see uname(2)) which is simpler than forking children.)

If I tried to exit Steam, it would complain that Serious Sam 3 is still running. I would have to kill it from the terminal to be able to exit Steam.

I have uploaded the terminal output from running "LD_DEBUG=files ./steam.sh" to http://pastebin.com/VE256pt9 . This is the output of the run where SS3 started working for the first time.
Last edited by Tristan Schmelcher; Nov 23, 2012 @ 12:12pm
PlofKat Dec 11, 2012 @ 1:50am 
Same problem. SS3 starts to launch then closes.

From end of Sam3.log
11:03:10 LOG: XDG_CURRENT_DESKTOP: XFCE
11:03:10 LOG: GDMSESSION: xubuntu
11:03:10 LOG: DESKTOP_SESSION: xubuntu
11:03:10 LOG: KDE_SESSION_VERSION: (null)
11:03:10 LOG:
11:03:10 LOG: * CPU...
11:03:10 LOG: Vendor: GenuineIntel
11:03:10 LOG: Type: 0, Family: 6, Model: 10, Stepping: 5
11:03:10 LOG: Clock: 3.21 GHz
11:03:10 LOG: Cores: 8
11:03:10 LOG: CMOV: Yes
11:03:10 LOG: SSE: Yes
11:03:10 LOG:
11:03:10 LOG: * Memory...
11:03:10 LOG: Total physical memory: 16041 MB
11:03:10 LOG: Free physical memory: 837 MB
11:03:10 LOG:
11:03:10 LOG: Loaded "/home/petrus/.local/share/Steam/SteamApps/common/Serious Sam 3/Bin/ScriptLua.so".
11:03:10 LOG: Loaded "/home/petrus/.local/share/Steam/SteamApps/common/Serious Sam 3/Bin/GameEnv_Steam.so".
11:03:10 INF: GameEnv API: Steam
11:03:10 INF: Encoded user ID = f79911d8:53b4ddfb
11:03:10 LOG: "$/home/petrus/.local/share/Steam/userdata/41526225/41070/local/SeriousSam3.ini" does not exist, skipping cvar loading.
11:03:10 LOG: Loaded "libX11.so.6".
11:03:10 LOG: Loaded "libXi.so.6".
11:03:10 LOG: Loaded "libXrandr.so.2".

LD_DEBUG=files ./steam.sh
http://pastebin.com/7gmxvaVN


OS: Ubuntu precise (12.04.1 LTS)
Architecture: x86_64

3x Nvidia 550 Ti GPU
6x Samsung syncmaster B2330




Mitch Conner Dec 12, 2012 @ 10:53am 
Sorry for the late reply, had some life issues. AllenL's solution worked for me, actually, it ran when I used those commands.
Grimnir Jan 7, 2013 @ 12:46am 
Same problem here, Ubuntu 12.04 x64, ATI Radeon 5800 HD with newest ATI driver (ATI Catalyst 12.10).

The newest driver fixed TF2 and Red Orchestra for me, but now SS3 won't start.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Nov 21, 2012 @ 12:29pm
Posts: 6