Steam for Linux > Discusiones generales > Detalles del tema
Reisen Udongein Inaba [因幡] 20 de Nov, 2012 a las 23:21
TF2 Performance Worse Than in Wine
After finally updating my video card drivers (NVIDIA, version 304.64), I went ahead and ran TF2 to try it out. As soon as I started a match, I noticed that 1.) Steam was using most of my processor, whereas TF2 was barely up there, and 2.) Although cl_showfps showed that I was getting around 150 fps, it felt more like I was getting around 15 fps along with random moments where the game just freezes up for a few seconds. I've even set everything to the lowest settings possible and disabled multicore rendering, and it still has the worst performance I've ever experienced (even under Wine, TF2 was never this bad). After playing for a little while, the game also crashed (dmp file here[s000.tinyupload.com]).
I'm just wondering if anyone has experienced this as well, and if so, has there been a way to improve the overall performance.
Mostrando 1-15 de 23 comentarios
< >
^1Gentoo 20 de Nov, 2012 a las 23:41 
Steam tells you that you are required to use atleast the 310.14 drivers.
bl33ding_silence 21 de Nov, 2012 a las 0:01 
Yes, try upgrading your driver to 310.14. If you can't (old graphics card), then this might be due to unity 3d (this is also suggested by the fact that cl_fps shows a higher framerate than you're getting)

In my case, unity 3d did not support my graphics card and was drastically affecting the performance of any OpenGL application. I installed Gnome and ran the old 2d gnome desktop (not the gnome 3 thing), and it improved Quake 4's performance by 30-40% on my system.
Reisen Udongein Inaba [因幡] 21 de Nov, 2012 a las 0:15 
The thing is, I'm not using that God awful Unity DE, I'm using Gnome Classic (which should have better OpenGL performance than Unity based on some recent benchmarks I've seen).
310.14 isn't the current, but rather experimental, so that's why I'm a little weary of installing it.
mruuh 21 de Nov, 2012 a las 0:40 
Just FYI, I'm getting comfortable 30-60 fps (much more when it's quiet, e.g. before a MVM wave starts) with nvidia drivers 304.48. Geforce GTX 260 card.
Última edición por mruuh; 21 de Nov, 2012 a las 0:41
Pk77 21 de Nov, 2012 a las 1:00 
I have a 2500k overclocked @4.2 ghz and a 670 GTX and the game is perfect, very very fluid, cl_showfps show 150-200 fps and i think it's correct, no pauses, no stuttering.
Maybe it's because i have an ssd drive?
NeoTheFox 21 de Nov, 2012 a las 1:18 
Publicado originalmente por LinuxSpice:
The thing is, I'm not using that God awful Unity DE, I'm using Gnome Classic (which should have better OpenGL performance than Unity based on some recent benchmarks I've seen).
310.14 isn't the current, but rather experimental, so that's why I'm a little weary of installing it.

Whell, you have to install it, valve been working with nVidia to master theese drivers. Any other drivers are not compatible with beta, and unfortunatly will never be.
Reisen Udongein Inaba [因幡] 21 de Nov, 2012 a las 1:20 
Publicado originalmente por Pk77:
I have a 2500k overclocked @4.2 ghz and a 670 GTX and the game is perfect, very very fluid, cl_showfps show 150-200 fps and i think it's correct, no pauses, no stuttering.
Maybe it's because i have an ssd drive?

I've been suspecting it might be my drive might also be a problem. I'll try with a different one and see if that's it.
Wait, I just remembered I'm running it off the same drive I have the Windows version on, so it can't be that.
Última edición por Reisen Udongein Inaba [因幡]; 21 de Nov, 2012 a las 2:13
shiba87 21 de Nov, 2012 a las 3:13 
Publicado originalmente por LinuxSpice:
310.14 isn't the current, but rather experimental, so that's why I'm a little weary of installing it.
There is a new stable version of the R310 series, 310.19

http://www.geforce.com/drivers/results/52241
sortie 21 de Nov, 2012 a las 4:10 
Using the open-source radeon drivers, I get very poor performance too. Fetching and building git master of mesa, xf86-video-ati and libdrm, I get significantly better performance (but with visual regressions). Unfortunately, when the performance gets that high, the bottleneck becomes loading sound files off the disk: the good old shuttering bug where the game halts for a half second while the sound file is being streamed.
Última edición por sortie; 21 de Nov, 2012 a las 4:11
[Linux] Schrödinger's cat 21 de Nov, 2012 a las 4:59 
Publicado originalmente por Sortie (x86_64-gnu-linux):
Using the open-source radeon drivers, I get very poor performance too. Fetching and building git master of mesa, xf86-video-ati and libdrm, I get significantly better performance (but with visual regressions).
go you have something like this with GUI?
http://♥♥♥♥♥♥♥/d/72wnkDQh0p0-K
sortie 21 de Nov, 2012 a las 6:15 
gcc: Yes, I do.
Reisen Udongein Inaba [因幡] 21 de Nov, 2012 a las 13:41 
After trying it a bit more, the game seems to constanlty stay at 17 fps, dips to 1 fps, then just freezes for 5 seconds. I'm not even sure it's utilizing my GPU at all.
Pk77 21 de Nov, 2012 a las 14:22 
New drivers boost my performance from 150-200 fps to 200-250. Great, maybe you can try to update to 310.19.
ATE|CoolHwip 21 de Nov, 2012 a las 15:04 
I manually installed 310.19 from the binary blob from the nvidia site and it seems to work fine. Your fps problems are not with Unity but with Compiz, which slows gaming performance down if not configured correctly. Both Unity and Gnome Classic use Compiz for compositing, whereas Gnome Fallback does not. Enable "Unredirect fullscreen apps" in CompizConfig settings under the "Composite" category (NOTE: You might have to install the settings manager via apt-get or synaptic).
Reisen Udongein Inaba [因幡] 21 de Nov, 2012 a las 15:49 
Publicado originalmente por TAE|WhippingLlama:
<stuff about Compiz>

I've already got it all configured, but, like the release notes say, "Unredirect Fullscreen Apps" is pretty much useless if you have multiple monitors (and I can confirm that having enabled it).
In any rate, thanks to this thread I now know it's because my processor is ♥♥♥♥ poor and OCing isn't an option (have no money to get a better heatsink).
Mostrando 1-15 de 23 comentarios
< >
Por página: 15 30 50
Publicado el: 20 de Nov, 2012 a las 23:21
Mensajes: 23