Mister_v3 Nov 20, 2012 @ 1:12pm
TF2 failing to start
This is what I'm getting

Installing breakpad exception handler for appid(steam)/version(1.0)
Game update: AppID 440 "Team Fortress 2", ProcID 8307, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
/bin/sh: 1: /home/kris/Steam/SteamApps/mister_v3/Team Fortress 2/hl2.sh: not found
Game removed: AppID 440 "Team Fortress 2", ProcID 8307
Showing 1-11 of 11 comments
< >
Chiancheri Nov 20, 2012 @ 2:09pm 
me too, not the same problem, but tf2 don't start. I ear the valve group jingle but don't see nothing, and after it freeze

Ubuntu 12.10-nvidia 9600gt, tested with different driver (310, 304.54)
Scaramanga Nov 20, 2012 @ 10:53pm 
go to /home/kris/Steam/SteamApps/mister_v3/ and rename the "team fortress 2" directory to "Team Fortress 2"

Mister_v3 Nov 21, 2012 @ 12:01am 
I tried renaming the folder and files (Team Fortress 2 Client Content.gcf, etc) so the first letter of each word is a capital. Nothing has changed.capital

I found the hl2.sh file and deleted it so steam would download a new copy that didnt work ether. if I try to run the game without hl2.sh I get even more wierd errors than the one I reported.

To save time did obtain most of the tf2 files from a Windows pc. Is there anything else I should check?

I'm using AMD 10.11 Beta drivers ( Not Beta 8)
Ubuntu 12.10 64-bit

nou しにがみ Nov 21, 2012 @ 3:21am 
TF2 seems crashing with joystick enabled. run "sudo rmmod joydev" no steam restart required and it may work. this is not solution for black screen.
etam Nov 21, 2012 @ 6:13am 
rmmod may be dangerous. You should use "modprobe -r" instead. (see: man rmmod)
Evil Penguin Nov 21, 2012 @ 6:23am 
"-nojoy" also seems to work for some people.
Mister_v3 Nov 21, 2012 @ 1:39pm 
Hello all. Tried the above but that didnt help. But I did manage to move forward. The problem was my profile folder was named Mister_v3 but steam was trying to look for hl2 in mister_v3
Now that i've renamed the folder to use all lower case steam is not looking for hl2.sh any more.

this is the next problem i'm having now though

CUser::OnRemoteStorageConflictResolution() - result Timeout
roaming config store loaded successfully - 1634 bytes.
migrating temporary roaming config store
CAsyncIOManager: creating I/O worker thread
Game update: AppID 440 "Team Fortress 2", ProcID 3676, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Failed to load the launcher
Game removed: AppID 440 "Team Fortress 2", ProcID 3676
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
CAsyncIOManager: creating I/O worker thread

Skells Dec 1, 2012 @ 1:39am 
I have exactly the same problem as you Mister_v3, I renamed my tf2 folder to Team Fortress 2 and now I'm getting these errors as well!
Aleks Dec 2, 2012 @ 6:26am 
I also have the same problem. I renamed the "team fortress 2" folder to "Team Fortress 2" and error with hl2.sh was solved.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
It seems that tf2 can't load game overlay, so I unchecked "Enable Steam Community In-Game" in game properties. Now I have only "Failed to load the launcher" error and don't know what to do with that (.
Last edited by Aleks; Dec 2, 2012 @ 6:28am
Kramer Dec 10, 2012 @ 11:44pm 
Check the permissions of the files in ~/Steam/SteamApps/username/Team\ Fortress\ 2/bin/ and ~/Steam/SteamApps/username/Team\ Fortress\ 2/tf/bin/

I found that the necessary libraries did not have the 'r' permission even for the owner. After using "chmod +r *" in each directory, TF2 finally launched for me.
The Chosen Juan #1 Jun 11, 2013 @ 7:31pm 
I can't seem to get to /home/mcb/steam let alone any further than that. I go to my folder, and there is no steam file. Any advice?
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Nov 20, 2012 @ 1:12pm
Posts: 11