Steam for Linux > Általános témák > Téma részletei
JnvSor 2012. nov. 20. @ de. 3:49
TF2 crashing with 'Unknown shader "Bik"'
When the video loads the game crashes. Terminal output in pastebin[pastebin.com]

I'm on 64bit 12.04 - as far as I know I have all the necessary libraries.

The only notable specific to my system is that I moved the SteamApps dir to a partition with more space and symlinked it back into ~/Steam
Legutóbb szerkesztette: JnvSor; 2012. nov. 20. @ de. 3:52
115/28 megjegyzés mutatása
< >
Alastair Campbell 2012. nov. 20. @ de. 3:56 
DEAR PEOPLE FROM THE FUTURE:

This issue is caused by symlinking your steamapps directory. To resolve this, either remove the symlink or symlink the whole of ~/Steam, instead of just steamapps.

It seems if you symlink specific directories, such as steamapps/<username/tf2, it works, but if you symlink steamapps/ as a whole, it breaks.

Credit goes to everyone who helped resolve this.

BACK TO MY ORIGINAL POST:
If I am not incorrect, BIK is a filetype used to display BINK video.

Try doing sudo apt-get install ia32-libs
Legutóbb szerkesztette: Alastair Campbell; 2012. dec. 22. @ du. 9:29
JnvSor 2012. nov. 20. @ de. 3:58 
That was already installed actually
Alastair Campbell 2012. nov. 20. @ de. 4:00 
Tried validating your game files? Right click the game, click properties and then, click "Validate game cache", if I remember correctly.

You might also want to take a look at this crash log:
/tmp/dumps/crash_20121120122457_1.dmp
Lauri 2012. nov. 20. @ de. 4:11 
SteamApps directory being symlinked seems to cause it. I had the same problem but after moving SteamApps back to ~/Steam TF2 doesn't crash on launch anymore.
JnvSor 2012. nov. 20. @ de. 4:12 
Chartax #ubuntu eredeti hozzászólása:
Tried validating your game files? Right click the game, click properties and then, click "Validate game cache", if I remember correctly.
All files successfully validated.

You might also want to take a look at this crash log:
/tmp/dumps/crash_20121120122457_1.dmp
Most of that is bytecode, but what isn't bytecode doesn't say anything to me, there's a heap dump but no trace so I can't really find the problem.

Edit: Thanks lauri, perhaps we can get this as a bug report somehow? (Symlinks are wonderful little things and will among other things save me a lot of precious home partition space)
Legutóbb szerkesztette: JnvSor; 2012. nov. 20. @ de. 4:13
Alastair Campbell 2012. nov. 20. @ de. 4:15 
Ah well -- it would seem that the symlink is indeed the culprit then. Strange, on my Windows box, I use the Windows' symbolic links which work flawlessly with Steamapps.
JnvSor 2012. nov. 20. @ de. 4:16 
Chartax #ubuntu eredeti hozzászólása:
Ah well -- it would seem that the symlink is indeed the culprit then. Strange, on my Windows box, I use the Windows' symbolic links which work flawlessly with Steamapps.
I suppose the difference is that steam is installed in a users folder rather than a system wide "Program files" folder on linux.
Alastair Campbell 2012. nov. 20. @ de. 4:18 
Possibly -- it could be some sort of permissions error. Did you try chmod / chown on the target, or something like that?
JnvSor 2012. nov. 20. @ de. 4:29 
Well it was mv'd from my home folder so I doubt there were any permission problems, in any case it's back now and the problem is solved.
Alastair Campbell 2012. nov. 20. @ de. 4:55 
As long as your problem is solved mate, that's good news.

I'll take a look into this later and see if I can reproduce.
sheepdestroyer | Linux 2012. nov. 23. @ de. 7:13 
I have the exact same problem.
I use a symlincked steamapps folder to an other partition (NTFS), i took care of permission problem by setting "users,exec,permission" in fstab.
I get this error when launching TF2 : Error: Material "fullscreenvideomaterial" uses unknown shader "Bik"
i tried the export LC_NUMERIC=POSIX and LANG=C tricks mentionned in an other post but no success

I don't have room on my system partition to take back the steamapps folder...
Legutóbb szerkesztette: sheepdestroyer | Linux; 2012. nov. 23. @ de. 7:14
Kano 2012. nov. 23. @ du. 12:59 
It's much simpler, move the complete Steam dir to ntfs, Steam itself can be a symlink.
Legutóbb szerkesztette: Kano; 2012. nov. 23. @ du. 12:59
JnvSor 2012. nov. 24. @ de. 6:21 
Kano eredeti hozzászólása:
It's much simpler, move the complete Steam dir to ntfs, Steam itself can be a symlink.
Right but then those of us with encrypted home directories can't safely hit "Remember password" can we?
System_Failure 2012. dec. 6. @ du. 1:43 
+1 to this, but fortunately I can move it. When you think you fixed it I'll be happy to move it back out and test again^^
StuckMojo 2012. dec. 7. @ de. 8:42 
I have the same issue. I symlinked because my home dir is on an SSD and I didn't want to suck up space on expensive storage for my game files:

jon@stuck:~/.local/share/Steam$ ll ~/.local/share/Steam/SteamApps
lrwxrwxrwx 1 jon jon 23 Dec 6 21:22 /home/jon/.local/share/Steam/SteamApps -> /usr/local/games/Steam/

I'm going to try symlinking ~/.local/share/Steam instead and see if that clears it up...
115/28 megjegyzés mutatása
< >
Laponként: 15 30 50
Küldés ideje: 2012. nov. 20. @ de. 3:49
Hozzászólások: 28