bl33ding_silence 19. nov, 2012 @ 11:50pm
Team fortress 2 error: glColorMaskIndexedEXT
I downloaded TF2, but when I run it, I get the following error:

Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I have Ubuntu 12.10 (32-bit) installed on my system which has an nvidia Geforce Go 7400 graphics card. My current nvidia graphics driver version is 304.64.

I read somewhere that the game works fine on Windows using the same graphics card, so I'm not sure if it is a problem with the driver or if the video card itself does not support this function.

Does anyone have suggestions?

EDIT: check out Fibble's post based on RunningRiot's work for a workaround. This is comment #106 in the comments.
Sist redigert av bl33ding_silence; 29. mar, 2013 @ 2:25pm
Viser 1-15 av 125 kommentarer
< >
bl33ding_silence 20. nov, 2012 @ 12:01am 
The full output from the console is:

Game update: AppID 440 "Team Fortress 2", ProcID 7202, IP 0.0.0.0:0
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system supports the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system DOES NOT support the OpenGL extension GL_EXT_draw_buffers2.
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
bl33ding_silence 20. nov, 2012 @ 12:17am 
Argh. It seems that my graphics card is not supported after all. TF2 seems to be complaining about GL_EXT_draw_buffers2, which contains the function "glColorMaskIndexedEXT". glxinfo does not report this extension for my graphics card, and this website doesn't list it too:

http://feedback.wildfiregames.com/report/opengl/device/GeForce%20Go%207400

:(
bialyikar 20. nov, 2012 @ 4:26am 
The same with the GF7900GS card. Works under Windows XP.

My system:
Ubuntu 12.04 64bit
NVIDIA Driver Version: 304.48

Console:
Game update: AppID 440 "Team Fortress 2", ProcID 8186, IP 0.0.0.0:0
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system supports the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system DOES NOT support the OpenGL extension GL_EXT_draw_buffers2.
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Installing breakpad exception handler for appid(steam)/version(1.0)
Installing breakpad exception handler for appid(steam)/version(1.0)
Game removed: AppID 440 "Team Fortress 2", ProcID 8186
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Sist redigert av bialyikar; 20. nov, 2012 @ 4:29am
Alastair Blake Campbell 20. nov, 2012 @ 4:56am 
Have you tried upgrading to nvidia-experimental-310? May be worth a shot!

Sist redigert av Alastair Blake Campbell; 20. nov, 2012 @ 4:56am
MEXAHOTABOP 20. nov, 2012 @ 8:11am 
310 don't supported old video card i.e. all <8800 GT
ps +1 7600 GS
uh20 23. nov, 2012 @ 8:24pm 
hmm, im going to post another about previous card support, i know the windows version has
-dxlevel that can go all the way down to 7.1, so hopefully this will be supported

also, i beat you all, fx1400, its the fastest card you could find.... about 7 years ago XD

still, i sure hope i dont run into this when i get my access, my new computers not going to be funded until a bit after christmas, me no wanna wait 2 months
uh20 23. nov, 2012 @ 8:35pm 
arggggg, all this time waiting for beta access and my video card might not work, im going to post some more and hope that lets off steam
uh20 23. nov, 2012 @ 10:45pm 
can any of you try -dxlevel 81 or -dxlevel 71 for me, they should work and get you past the shader requirement, no promises, im just hoping it does work for when i get in
Elvis 25. nov, 2012 @ 12:10pm 
I got the same issue.

This system DOES NOT support the OpenGL extension GL_EXT_draw_buffers2.
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I tried -dxlevel 81 and 71 without any success.

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G71 [GeForce Go 7900 GS] (rev a1)

NVidia dropped Series 7 and 6 from 310, as mentionned by MEXAHOTABOP. I'm currently running on 12.04LTS with NVidia 304 experimental (304.48).
ftp27 28. nov, 2012 @ 1:09pm 
The same problem
$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
lspci -v about VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 440] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Giga-byte Technology Device 3518
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at de000000 (64-bit, prefetchable) [size=32M]
I/O ports at dc00 [size=128]
[virtual] Expansion ROM at fea00000 [disabled] [size=512K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidia, nvidia_experimental_310, nvidia_current, nouveau, nvidiafb

uh20 29. nov, 2012 @ 5:59pm 
i became part of the beta today, and as my suspicions went, tf2 wont start because of this
but running tf2 in wine works!, so whats with the heightened requirements, can we get some opengl2.2 support soon.
Head in a Bag 1. des, 2012 @ 4:13am 
:(

lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation NV43 [GeForce 6600 GT] (rev a2)

SDL failed to create GL compatibility profile (whichProfile=0!
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system supports the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system DOES NOT support the OpenGL extension GL_EXT_draw_buffers2.
Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
SZ 6. des, 2012 @ 11:03pm 
Hi, i have this same problem.
"Could not find required OpenGL entry point 'glColorMaskIndexedEXT'! Either you video card is unsupported, or your OpenGL driver needs to be updated.

02:00.0 VGA compatible controller: NVIDIA Corporation G71 [GeForce 7900 GS] (rev a1) (prog-if 00 [VGA controller])
Subsystem: Giga-byte Technology Device 342e
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fa000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at fb000000 (64-bit, non-prefetchable) [size=16M]
I/O ports at ac00 [size=128]
[virtual] Expansion ROM at fc000000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: nvidia
Kernel modules: nvidia_experimental_304, nouveau, nvidiafb
paulguy119 6. des, 2012 @ 11:48pm 
-dxlevel is directx shader level. This game uses opengl in linux.

Anyway, I imagine as the engine is further developed, they'll find workarounds for missing features in various video cards. I'm sure they had to do it over time for the direct3d version as well, and that's many years old. This engine is probably not nearly as old.
innerspace 7. des, 2012 @ 12:20am 
I can report this issue effects my setup as well, leaving me unable to participate in the beta. Bummer! I was excited to see my invite come through this evening :(

GeForce 7300 Go, Ubuntu 12.10 32bit, nvidia-experimental-304.

Have subscribed to thread, hope to see these features work their way into existence soon.
Viser 1-15 av 125 kommentarer
< >
Per side: 15 30 50