[E]Symmetry 19. marras, 2012 19.07
"Failed to load steamui.so"
Hello, I recently got into the beta and just downloaded the .deb for the installer. I ran it and everything seemed to go fine, but then after I restarted and clicked on the 'Steam' icon on my desktop I got an error in a popup, "Fatal Error: Failed to load steamui.so" and that, as they say, was that. Running in the terminal all I get is:

Installing breakpad exception handler for appid(steam)/version(1353371323_client)
Installing breakpad exception handler for appid(Steam)/version(1.0)

which doesn't seem particularly helpful here.

I'm running Ubuntu 12.10 on a Thinkpad T430s with Intel graphics. I'm using the default "Ubuntu" session with Unity and the only thing I can think of that might have messed things up is that I've set fish as my default shell, though I've tried running Steam on the command line in bash of course. Trying to add the path to steamui.so to my LD_LIBRARY_PATH doesn't seem to have helped matters.

Well, hopefully my desktop has finished installing Linux so I can test things out on there, now.
Näytetään 1-15 / 90 kommentista
< >
ArsNG 20. marras, 2012 6.41 
Funny stuff. I'm just reinstalled my ubuntu 12.04 and got this error too.
Iskander ibn Fafnir an-Nakbah 20. marras, 2012 6.54 
I've encountered the same problem.
Ubuntu 12.10, up-to-date, x64. Fresh install of Steam client from .deb found on this forum (I wasn't updating Steam, it was a first install). Installation works fine, but when launching Steam client, I receive a popup with:
"Fatal Error: Failed to load steamui.so"

No other errors. I can confirm that steamui.so is present in the directory where it should be.
DenisBelo 20. marras, 2012 7.00 
Got this error too. I've just installed Ubuntu 12.10 x64, installed Steam and when I've tried to run Steam, it started updating and after the update, got this same error. I'm using Radeon HD5770 and AMD Phenom II x2.
ArsNG 20. marras, 2012 7.01 
Looks like new update broke it for fresh installs.
DenisBelo 20. marras, 2012 7.06 
MACHETE MACHETE lähetti viestin:
Looks like new update broke it for fresh installs.
Seens that the Update doesn't like fresh installs.
DenisBelo 20. marras, 2012 7.07 
I'll just try a fresh install of 12.04 on my netbook, I'm at work and my x64 plataform is at home. Let's see what happens. I'll post here as soon as it is installed.
ArsNG 20. marras, 2012 7.12 
Hey, just rebooted after installation and all works fine! Try it.
MonoBOY 20. marras, 2012 8.36 
Try run bin_steam.sh in Steam folder and reed errors in terminal
sortie 20. marras, 2012 11.35 
Using LD_DEBUG=libs $HOME/Steam/ubuntu12_32/steam, I found that it attempted to find an i386 libGL.so.1 on my x86_64 and failed because I don't have libgl1-mesa-dev:i386 installed. Installing this, I end up with the traditional X Error Occured (BadMatch) error that everybody has these days.
Red Heretic 20. marras, 2012 17.38 
I just installed Steam for Linux for the first time, and I am also having this issue. I tried a reboot as ArsNG suggested, but that did now help. when I run bin_steam.sh in terminal I get:

"Unknown Steam Package"

allan 20. marras, 2012 19.12 
LD_DEBUG=libs steam

7970: /home/allan/Steam/ubuntu12_32/libcef.so: error: symbol lookup error: undefined symbol: gdk_window_get_screen (fatal)
ndarkduck 20. marras, 2012 20.11 
I'm not from the steam support team, but why don't you post a strace on the client?
Red Heretic 20. marras, 2012 20.19 
ndarkduck, tell me how and I will
travisman1994 20. marras, 2012 20.34 
I had the same problem. try purging steam than install sudo apt-get install ia32-libs and reinstall the steam.deb package. It worked for me. Tell me how it goes.
esc_u83_onewing 20. marras, 2012 20.44 
Oh good.. im not losing my mind. I wait a good month to try this out and the one day I finally decide to drop everything, install ubuntu, and test out steam, it fails :(

travisman, I am a fedora guy and am not to savvy on apt-get-fu .. perhaps you can explain to me how to properly "purge" steam so I can go about attempting your fix
Näytetään 1-15 / 90 kommentista
< >
Sivua kohden: 15 30 50
Lähetetty: 19. marras, 2012 19.07
Viestejä: 90