Steam for Linux > Discussioni generali > Dettagli della discussione
MercuryCC 19 nov 2012, ore 17:26
Micro-stutter in TF2 when using xfwm4 compositor
Duplicating the Unity thread.

Xubuntu 12.10 64bit
Geforce GT 440
nvidia 310.14

If I turn off xfwm4 window compositor, then the micro-stutter goes away. The game feels much more responsive and smooth. If I leave it on then the fps does not change, but the graphics game feels much much slower. Playable, but very different from when the compositor was turned off.
Visualizzazione di 1-15 commenti su 17
< >
Rain Ninja 19 nov 2012, ore 17:54 
Have you got "Undirect Fullscreen Windows" on or whatever the XFCE equivelent was called?
MercuryCC 19 nov 2012, ore 18:03 
I don't know what is the equivalent in xfce. If it works, that could be a valid work around, but this really worth a bug to be fixed.
Rain Ninja 19 nov 2012, ore 19:46 
I think it is actually called Undirect Fullscreen Windows. It's in "Window Manager Tweaks". IMO it should be on by default, but hey, I'm not a dev.
MercuryCC 20 nov 2012, ore 7:55 
There is no such thing under xfce settings. I am not using compiz, by the way.
BoTuLoX [Linux] 20 nov 2012, ore 8:08 
AFAIK, the only compositors with such an option are Compiz and KWin. That's why KDE kicks every other DE's ♥♥♥ when it comes down to gaming performance, even if it's the slowest/second slowest DE for everything else.
Rain Ninja 20 nov 2012, ore 11:50 
Apologies, I think it's called "Display fullscreen overlay windows directly".
It's under the compositor tab in WIndow Manager Tweaks http://docs.xfce.org/xfce/xfwm4/wmtweaks

But I know from experience it works more or less as the function in KDE and Compiz (though Kwin seems to be particularly good at it).
Without this setting, xfwm used to cause shocking tearing in fullscreen movies and games for me.
MercuryCC 20 nov 2012, ore 12:37 
That one is on by default. I still have to turn off the compositor to get the perf.
Rain Ninja 20 nov 2012, ore 15:07 
In that case sounds like a definite bug or path that needs some real optimizing.
theli 2 dic 2012, ore 10:53 
Same for me, though turning compositor off in xfwm4 does not make any difference :-/
gutigen o) 2 dic 2012, ore 20:20 
Messaggio originale di iH BoTuLoX:
AFAIK, the only compositors with such an option are Compiz and KWin. That's why KDE kicks every other DE's ♥♥♥ when it comes down to gaming performance, even if it's the slowest/second slowest DE for everything else.

Doesn't Gnome Shell have this option by default? I think I've read somewhere about it, not sure :)
Anyway, out of few most popular DEs (Unity, KDE, Gnome Classic, XFCE) Gnome Shell gives me best performance in benchmarks and any game.
axeolin 3 dic 2012, ore 0:02 
Messaggio originale di MercuryCC:
Duplicating the Unity thread.

Xubuntu 12.10 64bit
Geforce GT 440
nvidia 310.14

If I turn off xfwm4 window compositor, then the micro-stutter goes away. The game feels much more responsive and smooth. If I leave it on then the fps does not change, but the graphics game feels much much slower. Playable, but very different from when the compositor was turned off.

I couldn't recreate this with ATI 12.11 beta 8 which makes me wonder whether it's a specific setting for compositing triggering it (rather than just on or off) or a nvidia driver issue.

Although I'm using xfce4 installed on ubuntu rather than xubuntu, there might be a difference there.
Ultima modifica da axeolin; 3 dic 2012, ore 0:07
MercuryCC 4 dic 2012, ore 21:11 
Messaggio originale di axeolin:

I couldn't recreate this with ATI 12.11 beta 8 which makes me wonder whether it's a specific setting for compositing triggering it (rather than just on or off) or a nvidia driver issue.

Although I'm using xfce4 installed on ubuntu rather than xubuntu, there might be a difference there.

I wonder what your graphics card is. I don't have this issue with my GTX 660 Ti. I only have it with my GT 440, which is a much slower card. TF2 is playable even on Intel HD4000, so with a good card any minor perf issue probably won't even show up.
axeolin 5 dic 2012, ore 1:34 
Messaggio originale di MercuryCC:
I wonder what your graphics card is.

HD6850
MercuryCC 5 dic 2012, ore 14:08 
Messaggio originale di axeolin:

HD6850

That probably explains the problem. However if any demanding game is ported to Linux this could be a more real issue, I suppose.
Fibbles 17 mar 2013, ore 9:34 
I've noticed a similar problem whilst using Xubuntu. I have the "display fullscreen windows directly option" turned on, it's the default setting for a Xubuntu install. If I try to play TF2 with compositing switched on though, I get an unplayable 5 - 15 fps. If I turn it off I get 100 - 200 fps.

Xubuntu 12.10 (64 bit)
Nvidia 310.14 driver

AMD FX6300
8GB RAM
Nvidia 8800 GT
Ultima modifica da Fibbles; 17 mar 2013, ore 9:37
Visualizzazione di 1-15 commenti su 17
< >
Per pagina: 15 30 50
Data di pubblicazione: 19 nov 2012, ore 17:26
Messaggi: 17