Mewt :< Nov 19, 2012 @ 6:49am
Killing Floor fails to load.
I'm currently using the Arch Linux non-beta client (starting with steam steam://store). I installed Killing Floor but was unable to start. I get a splash screen for the game then a black screen. I get the steam overlay popup on the bottom right and nothing else.

I can hear the menu music and if i move my mouse around, I hear the mouse over sound effects as well but I see nothing. Pressing escape quits the game.

My current setup is as follows:

Arch x64, Intel core i5 2500k, 8gb ram, steam installed from AUR and allowed to update normally. Openbox with nvidia drivers (310.xx version)

Any ideas ?
Showing 1-14 of 14 comments
< >
icculus Nov 19, 2012 @ 9:14am 
Is it possible that the game is setting a video resolution that your monitor doesn't support?

Failing that, can you post your ~/.killingfloor/System/KillingFloor.log here?

Thanks,
--ryan.
Niko Nov 19, 2012 @ 10:20am 
You have installed libgl? (nvidia utils for nvidia), I had this problem the other day.
Mewt :< Nov 20, 2012 @ 12:01am 
Niko: I have nvidia-utils installed... icculus: I'm not sure, from the size of the steam overlay popup, i think it's setting quite a low res (800x600 ?). I'll try looking through that log and see if I can spot anything. Failing that, I'll post it here
---- Nov 24, 2012 @ 5:34am 
I have the same issue, below is my KillingFloor.log:

http://sprunge.us/PTJI

It seems like the culprit is package PixoDrv, whatever that is.

Edit: I've also tried checking game integrity, but that didn't fix it.
icculus Nov 24, 2012 @ 6:25am 
Hmm, why on earth is it trying PixoDrv? I'll look into this.

--ryan.

icculus Nov 24, 2012 @ 6:25am 
(PixoDrv is the software renderer from UT2004, which Killing Floor doesn't include.)
---- Nov 24, 2012 @ 6:34am 
Actually my issue is not exactly the same, I don't even get to the menu, the game quits right after the splash screen.
Stroke Nov 24, 2012 @ 7:48am 
It's interesting. I have got ubuntu 12.04.1 lts 64 bit + unity with an Ati 4250 integrated graphics card and KF runs good with stable 30fps. I am downloading the Serious Sam 3 now and later tf2. The steam client laggy a bit sometimes and the messages what i want to send my friends deleted itself sometimes.
icculus Nov 24, 2012 @ 7:58pm 
Originally posted by b.:
Actually my issue is not exactly the same, I don't even get to the menu, the game quits right after the splash screen.

That's when it would try PixoDrv, fwiw. If you've got a log file, see if it says something similar ($HOME/.killingfloor/System/KillingFloor.log)

EDIT: whoops, I thought you were replying to the PixoDrv comment as "not the same issue," but you're the one who made the PixoDrv comment. Sorry. :)

--ryan.
Mewt :< Nov 25, 2012 @ 1:41am 
Sorry for the late replies, but I was away from my pc for a couple of days.

This: http://pastebin.com/evt6SZwP is the console log and KillingFloor.log after trying to run the game once again. The steam overlay works but I get nothing from the game. I had to kill the game from a separate terminal as I couldn't get out of it. It left my system at 800x600 (no problems setting resolution it seems)
icculus Nov 25, 2012 @ 12:03pm 
Mewt:

"Log: GL_VERSION : 1.4 (2.1.2 NVIDIA 310.19)"

You have a broken 32-bit driver install. This usually happens when you use the installer from nvidia.com and then your distro updates some part of the X server. Reinstall the nvidia drivers, let it replace the current install, and say "yes" when it asks about 32-bit drivers, and you should be good to go.

--ryan.

Mewt :< Nov 25, 2012 @ 12:12pm 
icculus: I have only installed the nvidia drivers from the arch linux repos. I'm running on 64-bit with 32-bit libraries installed for steam's sake.
Mewt :< Nov 29, 2012 @ 2:33pm 
icculus: I'v still to try Killing Floor again because I decided to reinstall it, but I found that I did indeed have a misconfiguration. It appears that if you install nvidia-utils instead of lib32-nvidia-utils, the system will use a plain libgl instead of the nvidia one. Once I fixed this I was able to load SS3 ( Now waiting for Killing Floor and TF2 to update)
dotty dot dot Dec 8, 2012 @ 7:25pm 
Game loaded for me, then i was playing around with settings and selected Direct3d (lol it gave me the option)
Then the game no longer loaded with the same error..

Just change the renderdevice in the config file

~/.killingfloor/System/KillingFloor.ini
[Engine.Engine]
;RenderDevice=PixoDrv.PixoRenderDevice
RenderDevice=OpenGLDrv.OpenGLRenderDevice

I am running arch64 nvidia here
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Nov 19, 2012 @ 6:49am
Posts: 14