Touch My Box 19. Nov. 2012 um 6:29 Uhr
Micro-stutter in TF2 when using Unity
Hello,

It would seem that there is microstutter in TF2 when playing under Unity (3d). The in-game FPS counter stays at 60 FPS, but the game feels like it is under 30. The relevant system specs are

Ubuntu 12.10 64 Bit
Core i7 930
6 GB DDR3
GTX 670 (310.19, also tried the previous beta driver)

This is not the case when running in a different DE such as Cinnamon 2D, I would try Cinnamon 3D, but I get screentearing with that.

Not sure whether there is much VALVe can do about Unity's sub-par 3D performance, but I thought it would be worth mentioning.
Beiträge 1-6 von 6
< >
Vlad Dracula IV 19. Nov. 2012 um 6:42 Uhr 
https://bugs.launchpad.net/compiz/+bug/1029085

This should be fixed with Ubuntu 12.10 and Nvidia 310 but if you still have it then its probably Compiz settings. "Unredirect fullscreen windows" + going fullscreen in game could help.
VIVID* 19. Nov. 2012 um 7:14 Uhr 
With Ubuntu 12.10 x64 and Nvidia driver 310.19 (x-edgers ppa) I do not have any such stutter. This is with all default settings for compiz and near maximum settings in game with a GTX 560 Ti.
Touch My Box 19. Nov. 2012 um 16:07 Uhr 
Thanks Horst, that seems to have made a huge difference.

It still seems to jitter ever so slightly every now and then, moreso than in Windows, but it's pretty good. I'm going to try out Gnome and see how things are there.
Touch My Box 19. Nov. 2012 um 16:53 Uhr 
Looks like using Compiz outside of Unity still results in massive tearing at the top of my screen, oh well.
MercuryCC 19. Nov. 2012 um 17:12 Uhr 
Same here but I am on Xfce with GT 430.
squirrel-the-tire 19. Nov. 2012 um 18:56 Uhr 
From my experience, anything using 3D rendering is marginally slower, and buggier when using something like Compiz. You will almost definitely notice a positive difference if you use a window manager with less overhead like Fluxbox or Enlightenment.
Beiträge 1-6 von 6
< >
Pro Seite: 15 30 50
Geschrieben am: 19. Nov. 2012 um 6:29 Uhr
Beiträge: 6