Steam for Linux > 一般的な話題 > トピックの詳細
AlenL 2012年11月14日 8時25分
Serious Sam 3 Update 172672 - public beta
Build 172672 for Serious Sam 3 is now available in beta "publicbeta", which does not require a password. It contains a number of general fixes in the game, as well as some that are specific to the Linux version.

To install the beta, do this:
- locate the game (Serious Sam 3 in this case) in the Steam's "Library" panel
- right click and invoke "Properties"
- select the "Betas" tab
- choose "publicbeta"

Update 172672 contains a number of general fixes in the game, as well as some that are specific to the Linux version.

- IMPORTANT FOR LINUX: Most of the weird performance problems in previous builds were caused by performance throttling (aka power saving) features on various CPUs not correctly identifying that the game is running and continually jittering between low and high performance modes (several times per second sometimes!). This build adds a workaround for this which should hopefully prevent the symptoms from being so extreme. It is not perfect however, as there might still be a few percents of performance to squeeze out. The recommended solution is to turn off such features in BIOS for Linux machines. They can be found in BIOS under names such as SpeedStep, Cool'N'Quiet, C1E, PowerNow!, Power Saving, CPU Throttling, Dynamic Frequency Scaling, or something else - depending on your BIOS.

- Added a script that offers to automatically install libpci.3 on linux if it is missing.
- Fixed graphics corruption under OpenGL if game is minimized or "alt-tabbed" while it is loading content.
- Fixed screen-shot grabbing and manual save-game thumbnails not working under OpenGL. 
- OpenGL library can now load even if some vendor dependent functions are missing.
- X11 libraries on Linux are now dynamically loaded, so game can properly report and error if something is missing.
- Dedicated server on Linux no longer requires X11 to be installed.
- Fixed problems with filenames of wrong case that happened only with Linux dedicated server.
- Full support for language packs in Workshop. Language mods can now work even in pure (non-moddable) version of the game, and don't require any customization from user side. Just subscribe to them.
- Workshop packages menu is now also available in non-moddable version of application (this allows enabling/disabling of language packs). 
- User is now properly notified when Steam Workshop content download fails. 
- Fixed issues that might have prevented some user accounts from uploading to Workshop.
- SeriousEditor now displays Steam Workshop sync progress in status bar.
- Upload to Steam Workshop command is no longer available until Steam Workshop sync is finished. Previuously, it locked up the application.
- Fixed an issue causing clients to always see weapon change on HUD at game start.
- Fixed a lockup happening if spectator cameras are linked in a closed loop. This only happened with user-made levels.
- Weapon change attempt is now correctly being indicated on HUD if performed during sprint. 
- Fixed popup menus in Serious Editor sometimes going off the bottom of the screen in multimonitor setups.
- Fixed duplicate directory entries being shown in Serious Editor in file browsing for directories inside user-made .gro files.
- Added vertex merge when importing fbx meshes. 
- Added facilities in Serious Editor to automate editing on entities from console scripts.
- Added cfuncs edtGetMemberValue(strUserDataPath) and edtSetMemberValue(strUserDataPath, value) used to change entity properties.
- Added cfunc edtSelectEntityPropertyByID(iEntityID).

Please let me know if you find any new issues with this build!

Thanks,
Alen
1-15 / 45 のコメントを表示
< >
blackout24 2012年11月14日 8時30分 
Croteam just climbed my sympathy ladder to new extremes.
ThOR27 2012年11月14日 8時40分 
Awesome. Will update it as soon as I got home.
mikeym 2012年11月14日 10時38分 
For me this is a big improvement. I'm getting 20-50 FPS on Ultra in the Publicbeta as opposed to about 12-35 on Medium before. I've not tried the BIOS fix yet. Though I don't think turning off CPU Scaling in the BIOS is a very satisfactory long term fix. I'm not sure how this is normally dealt with but I have a strong feeling that this problem will have been resolved by someone somewhere before.

Issues I've noticed with the new build (mostly I've already mentioned these with the first build):

  • Intro animation has a "floor" (apparently) glitch http://steamcommunity.com/sharedfiles/filedetails/?id=108277084
  • Spaceships in intro sometimes appear bright pink. I also noticed this time that in the first shot of the planet you couldn't see the planet.
  • Walls flicker on and off. I tested this again and it's still happening, but I also tested both commands given by AlenL to modify the game behaviour and found that either independently removes the glitch.
  • Some decoration in the game flicker, seems to be noticeable with the vines in the spider's nest. This may be the same as the shadow flicker bug, but I wasn't noticing it from the trees so much during last play whilst on Ultra, I did notice it from the vines.

BTW a reminder that I'm running ATI Catalyst 12.10.
Chris 2012年11月14日 11時19分 
Hi Alen,

thanks for the updated build, sadly my problems are still there:

1. Even when using fullscreen the game goes windowed in kde until i tab out and tab into the game again. Fullscreen works great using gnome or unity.

2. I still have the graphical issues all around. I even upgraded to nvidia 310.19 today, still no go.
Here ist the screenshot: http://imgur.com/f53Ug

Anything i can be helpful with to nail down this issue ?

Best regards,
Christian

AlenL 2012年11月14日 11時36分 
Christian, I don't recall what I asked whom in which thread, but have you tried disabling occlusion culling and/or instancing? I wrote about it somewhere here today and it helped one person.

Edit: I'm referring to the screen shot of yours. That minimize on start is still a mystery.
最近の変更はAlenLが行いました; 2012年11月14日 11時39分
Chris 2012年11月14日 11時44分 
AlenL の投稿を引用:
Christian, I don't recall what I asked whom in which thread, but have you tried disabling occlusion culling and/or instancing? I wrote about it somewhere here today and it helped one person.

Edit: I'm referring to the screen shot of yours. That minimize on start is still a mystery.

i tried that and i did not help :(..
Putteri 2012年11月14日 12時15分 
Hi,
thanks for the patch, performance is now much better!
Unfortunately the graphics corruption after minimize isn't fixed for me. It seems to affect only models that haven't been seen before minimizing. If I minimize the game when it is loading the level, the screen will be full of corruption, but if I play for a while, then pause, minimize and return to game only new enemies or items are corrupted

I tested this with gentoo x64, openbox and nvidia-driver 310.19 and Linux Mint x64, metacity and nvidia-driver 310.14. graphics card is gtx 670.

I also noticed that kde puts the game in window. I use alt-enter to get it fullscreen when I'm using kde.

Generally it works very well and I'm now pushing forward in The Silent Riddler. :-)
最近の変更はPutteriが行いました; 2012年11月14日 12時15分
Nerv 2012年11月14日 13時08分 
I can confirm the increased performance. I went from 30-60fps under Ubuntu-Untity to 50-60fps. In gnome clasic it barely drops under 60. (But it also never goes above it, is it capped?)

Anyway great work, much apretiated!
mikeym 2012年11月14日 13時09分 
I think I understand now what AlenL is talking about with regard to the BIOS setting for Cool'n'Quiet, CPU Throttling, etc.

I think it's CPU Frequency Scaling as managed by the Kernel using cpufreq.

There's more about this here.[wiki.archlinux.org]

But I think if you really want to get the most out of your CPU the more linux-y way to do it than messing about with your BIOS settings is to do this:

# Show the available Scaling Governor Profiles
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
# Then show the current Scaling Governor Profile
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
# Change to root for this bit
sudo -i
# Then change to Performance Profile if available
echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

You can test it by running "cpupower frequency-info" if available the package on Fedora was kernel-tools. It will show you the current CPU Frequency and the range of available frequencies in use.

You restore your old profile by echoing back the profile shown at the beginning, in my case it was ondemand:

sudo -i
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

I don't think it's really required to mess around with these on most systems, it did make the game a tiny bit more 'snappy' for me but didn't really improve my frame rates over the patched build.



Cyb.org 2012年11月14日 13時11分 
Debian sid/unstable amd64 :)
ATI RV730 XT [Mobility Radeon HD 4670]

ii fglrx-legacy-atieventsd 8.97.100.3+1-1 amd64 legacy events daemon for the non-free AMD RadeonHD display driver
ii fglrx-legacy-driver 8.97.100.3+1-1 amd64 non-free ATI/AMD RadeonHD display driver (legacy)
ii fglrx-legacy-modules-dkms 8.97.100.3+1-1 amd64 dkms module source for the non-free ATI/AMD RadeonHD display driver (legacy)
ii fglrx-legacy-source 8.97.100.3+1-1 amd64 kernel module source for the non-free ATI/AMD RadeonHD display driver (legacy)
ii glx-alternative-fglrx 0.2.90 amd64 allows the selection of FGLRX as GLX provider
ii libfglrx-legacy:amd64 8.97.100.3+1-1 amd64 non-free ATI/AMD RadeonHD display driver (runtime libraries) (legacy)
ii libfglrx-legacy:i386 8.97.100.3+1-1 i386 non-free ATI/AMD RadeonHD display driver (runtime libraries) (legacy)
ii libfglrx-legacy-amdxvba1:amd64 8.97.100.3+1-1 amd64 AMD XvBA (X-Video Bitstream Acceleration) runtime libraries (legacy)
ii libfglrx-legacy-amdxvba1:i386 8.97.100.3+1-1 i386 AMD XvBA (X-Video Bitstream Acceleration) runtime libraries (legacy)
ii libgl1-fglrx-legacy-glx:amd64 8.97.100.3+1-1 amd64 proprietary libGL for the non-free ATI/AMD RadeonHD display driver (legacy)
ii libgl1-fglrx-legacy-glx:i386 8.97.100.3+1-1 i386 proprietary libGL for the non-free ATI/AMD RadeonHD display driver (legacy)



Intro:
http://steamcommunity.com/sharedfiles/filedetails/?id=108289781
http://steamcommunity.com/sharedfiles/filedetails/?id=108289656

In any animated sequence (after few seconds):
[ 2539.096892] MainThrd[18436]: segfault at 2000 ip 0000000000002000 sp 00000000ffe17de0 error 14 in Sam3[8048000+146c000]
[ 2851.206691] MainThrd[18719]: segfault at 2000 ip 0000000000002000 sp 00000000ff8da830 error 14 in Sam3[8048000+146c000]
[ 3013.923092] MainThrd[18830]: segfault at 2000 ip 0000000000002000 sp 00000000ffd8e9b0 error 14 in Sam3[8048000+146c000]
[ 3153.115541] MainThrd[18904]: segfault at 2000 ip 0000000000002000 sp 00000000ffb8d1b0 error 14 in Sam3[8048000+146c000]
[ 3611.846899] MainThrd[19042]: segfault at 2000 ip 0000000000002000 sp 00000000ffa6e900 error 14 in Sam3[8048000+146c000]
[ 3701.785570] MainThrd[19150]: segfault at 2000 ip 0000000000002000 sp 00000000ffaa5bb0 error 14 in Sam3[8048000+146c000]

When I've set graphics+cpu oprions to Lowest it happened after one minute or so. Other interesting lines from Steam output:

WRN: Memory block injectors occupy additional 4 bytes per memory block.
INF: GameEnv API: Steam
Setting breakpad minidump AppID = 41070
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198019860227 [API loaded no]
INF: Encoded user ID = d2821ff7:abbd3f6f
WRN: Failed to capture mouse
...
INF: Started simulation on 'Content/SeriousSam3/Levels/Menu/Intro.wld' in 0.56 seconds.
ERR: Failed to precache texture Content/SeriousSam3/Models/Vehicles/FrontLoader02/Textures/Wheel_01_CM.tex; it doesn't exist in memory
INF: Started simulation on 'Content/SeriousSam3/Levels/Menu/MenuLevel.wld' in 0.07 seconds.
WRN: inpSysIsMouseAccelerationEnabled: Not yet implemented
...
INF: Started simulation on 'Content/SeriousSam3/Levels/01_BFE/01_CairoSquare/01_CairoSquare.wld' in 24.56 seconds.
ERR: Failed to precache texture Content/SeriousSam3/Models/Vehicles/UH_60_BlackHawk_cutscenes/Textures/OuterParts_CM.tex; it doesn't exist in memory
Game removed: AppID 41070 "Serious Sam 3: BFE", ProcID 19660


If you need some more info...
blackout24 2012年11月14日 13時21分 
Nerv の投稿を引用:
In gnome clasic it barely drops under 60. (But it also never goes above it, is it capped?)

Anyway great work, much apretiated!

You're obviously using Vsync either enabled in the application settings or in your nvidia/catalyst control center. So this behavior is normal and intended. You can disable it (for benchmarking for example) and get as much frames as possible but you'll probably see some screen tearing.
最近の変更はblackout24が行いました; 2012年11月14日 13時22分
ThOR27 2012年11月14日 13時24分 
No FPS improvement here, but it looked quite ok already, around 30fps. The screenshot saving issues was fixed.

Thanks for the update :)
Rain Ninja 2012年11月14日 13時37分 
Not that you should have to in most cases, but if you installed the cpufreq indicator (search in Software Centre) for Ubuntu Unity you could just click on it and select Maximum Performance whenever you go to play a game.
keks 2012年11月14日 13時52分 
Rain Ninja, you are correct, using an indicator applet is simpler and especially useful on laptops. But we noticed that performance is even better, albeit not by much, if power saving is disabled in the bios.
mikeym 2012年11月14日 14時38分 
@keks, sorry if I've confused the issue, my belief was that running in performance mode and disabling Cool'n'Quiet (or whatever) in the BIOS would be equivalent as the CPU should be running at a constant maximum frequency. I apologise if this was wrong advice.
1-15 / 45 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2012年11月14日 8時25分
投稿数: 45