Steam for Linux > Discussioni generali > Dettagli della discussione
»xѕєвa360« #3Ginternet 13 nov 2012, ore 13:22
Linux noob question.
Hey, I've been getting ready in case i get beta access. I've installed fresh Ubuntu 12.10, i haven't installed almost anything but Steam. I've heard something about these experimental drivers, but oh ffs, how do i install them, i don't want to mess anything up, so yeah :C ...
In case it's needed, i'm using x64 version on GeForce GTS 450.
Ultima modifica da »xѕєвa360« #3Ginternet; 13 nov 2012, ore 13:23
Visualizzazione di 1-10 commenti su 10
< >
hunter_thom 13 nov 2012, ore 13:24 
Go to Additional Drivers, select the experimental nvida driver for 304 or 310, activate and reboot.
»xѕєвa360« #3Ginternet 13 nov 2012, ore 13:58 
»xѕєвa360« #3Ginternet 14 nov 2012, ore 6:04 
Ok, so before i rebooted, i ran 'nvidia-settings'. it asked me to do 'nvidia-xconfig' and restart x server. thats what i did (by rebooting, i guess?) and now i ended up with really low resolution (somewhere near 640x480) and only desktop icons showing. even the window frames aren't showed properly. I've managed to open up the browser though. Help :c?

Oh, and before i even installed the drivers, some of the text and other stuff were stretched and just weird, now it's worse mess.

Do i need to provide any more info :c?
Ultima modifica da »xѕєвa360« #3Ginternet; 14 nov 2012, ore 6:08
Tórus 14 nov 2012, ore 8:44 
That appears to be a bug(you should have upgraded your system before installing things).
Install the packpages linux-source and linux-headers-generic then reinstall the driver and reboot.
Ultima modifica da Tórus; 14 nov 2012, ore 8:45
»xѕєвa360« #3Ginternet 14 nov 2012, ore 9:10 
Messaggio originale di Jechx:
That appears to be a bug(you should have upgraded your system before installing things).
Install the packpages linux-source and linux-headers-generic then reinstall the driver and reboot.
I have done that before installing the driver, i mean, only these 2 packages.
Ultima modifica da »xѕєвa360« #3Ginternet; 14 nov 2012, ore 9:11
12345678 14 nov 2012, ore 12:34 
I had the same thing happening. Follow this short tutorial, I think it's in the first answer.
Basically what you're doing is uninstalling the drivers, installing linux source and headers, reinstalling graphics drivers, and allowing the kernel to configure properly so the driver gets loaded the way it should.
Zoktar - ECM Feedback 15 nov 2012, ore 9:33 
This ppa covers bleeding edge drivers and related packages. Can be nice for benching, testing.

Get ppapurge and or ppa manager so that you can purge the entire ppa to go back to normal repo packages.
BJORN 15 nov 2012, ore 10:22 
I wouldn't recommend bleeding edge drivers to a Linux noob, imho, but above all, make sure you don't have more than one driver installed. It's very important that, if you choose different methods to install your nvidia drivers, you only install one driver.

If you try to install via synaptic, for example, and it doesn't work, don't try to fix it by installing via ppa until you have removed what was installed via synaptic.

I've had the best luck installing in console mode myself, so I download the .run file from nvidia's website, then Ctrl+Alt+F1 to tty1, do "sudo service lightdm stop" then cd to the directory with the file and do "sudo ./" Keep us updated with your progress.
»xѕєвa360« #3Ginternet 15 nov 2012, ore 10:45 
Ok. i've managed to get it to install.

I've followed the guide from 12345678 (

Just instead of: (what i was doing before and it wasn't working)
sudo apt-get install linux-headers-generic
i've done: (and then it worked...)
sudo apt-get install linux-headers-3.5.0-17-generic

It's working fine now :) thanks for the support.

And yeah, I've tried to download the drivers from nvidia driver download page (.run file) but that was just too complicated to install it for me (complete noob, yeah ikr :/)
Zoktar - ECM Feedback 16 nov 2012, ore 7:37 
A little offtopic, but something i found that helped me fix some package management issues, while getting the correct drivers and dependency's working.

Sometimes the package management gets clogged up and doesn't uninstall some stuff correctly.
This will purge-uninstall stuff that has been selected for uninstall, but have not uninstalled.

Having the package management issues early on can really drive you nuts!. Here it is. Note you will need to install aptitude, "sudo apt-get install aptitude", its another package manager app like synaptic but for console. Purge instead of remove can be helpful where remove leaves some configuration files or caches behind at times.

sudo aptitude purge `dpkg --get-selections|grep deinstall|cut -f 1`

Visualizzazione di 1-10 commenti su 10
< >
Per pagina: 15 30 50
Data di pubblicazione: 13 nov 2012, ore 13:22
Messaggi: 10