Steam for Linux > Γενικές συζητήσεις > Λεπτομέρειες θέματος
[Emp'G]»xѕєвa360« 13 Νοε, 2012 @ 1:22μμ
Linux noob question.
Hey, I've been getting ready in case i get beta access. I've installed fresh Ubuntu 12.10, i haven't installed almost anything but Steam. I've heard something about these experimental drivers, but oh ffs, how do i install them, i don't want to mess anything up, so yeah :C ...
In case it's needed, i'm using x64 version on GeForce GTS 450.
Τελευταία επεξεργασία από [Emp'G]»xѕєвa360«; 13 Νοε, 2012 @ 1:23μμ
Εμφάνιση 1-10 από 10 σχόλια
< >
hunter_thom 13 Νοε, 2012 @ 1:24μμ 
Go to Additional Drivers, select the experimental nvida driver for 304 or 310, activate and reboot.
[Emp'G]»xѕєвa360« 13 Νοε, 2012 @ 1:58μμ 
Thanks.
[Emp'G]»xѕєвa360« 14 Νοε, 2012 @ 6:04πμ 
Ok, so before i rebooted, i ran 'nvidia-settings'. it asked me to do 'nvidia-xconfig' and restart x server. thats what i did (by rebooting, i guess?) and now i ended up with really low resolution (somewhere near 640x480) and only desktop icons showing. even the window frames aren't showed properly. I've managed to open up the browser though. Help :c?

Oh, and before i even installed the drivers, some of the text and other stuff were stretched and just weird, now it's worse mess.

Do i need to provide any more info :c?
Τελευταία επεξεργασία από [Emp'G]»xѕєвa360«; 14 Νοε, 2012 @ 6:08πμ
Tórus 14 Νοε, 2012 @ 8:44πμ 
That appears to be a bug(you should have upgraded your system before installing things).
Install the packpages linux-source and linux-headers-generic then reinstall the driver and reboot.
Τελευταία επεξεργασία από Tórus; 14 Νοε, 2012 @ 8:45πμ
[Emp'G]»xѕєвa360« 14 Νοε, 2012 @ 9:10πμ 
Αναρτήθηκε αρχικά από Jechx:
That appears to be a bug(you should have upgraded your system before installing things).
Install the packpages linux-source and linux-headers-generic then reinstall the driver and reboot.
I have done that before installing the driver, i mean, only these 2 packages.
Τελευταία επεξεργασία από [Emp'G]»xѕєвa360«; 14 Νοε, 2012 @ 9:11πμ
12345678 14 Νοε, 2012 @ 12:34μμ 
I had the same thing happening. Follow this short tutorial, I think it's in the first answer.
http://askubuntu.com/questions/202574/desktop-does-not-show-when-i-installed-nvidia-drivers
Basically what you're doing is uninstalling the drivers, installing linux source and headers, reinstalling graphics drivers, and allowing the kernel to configure properly so the driver gets loaded the way it should.
Zoktar 15 Νοε, 2012 @ 9:33πμ 
This ppa covers bleeding edge drivers and related packages. Can be nice for benching, testing.

https://launchpad.net/~xorg-edgers/+archive/ppa

Get ppapurge and or ppa manager so that you can purge the entire ppa to go back to normal repo packages.
BJORN 15 Νοε, 2012 @ 10:22πμ 
I wouldn't recommend bleeding edge drivers to a Linux noob, imho, but above all, make sure you don't have more than one driver installed. It's very important that, if you choose different methods to install your nvidia drivers, you only install one driver.

If you try to install via synaptic, for example, and it doesn't work, don't try to fix it by installing via ppa until you have removed what was installed via synaptic.

I've had the best luck installing in console mode myself, so I download the .run file from nvidia's website, then Ctrl+Alt+F1 to tty1, do "sudo service lightdm stop" then cd to the directory with the NVIDIAblahblahblah-304.xx.run file and do "sudo ./NVIDIAblahblah.run" Keep us updated with your progress.
[Emp'G]»xѕєвa360« 15 Νοε, 2012 @ 10:45πμ 
Ok. i've managed to get it to install.

I've followed the guide from 12345678 (http://askubuntu.com/questions/202574/desktop-does-not-show-when-i-installed-nvidia-drivers)

Just instead of: (what i was doing before and it wasn't working)
sudo apt-get install linux-headers-generic
i've done: (and then it worked...)
sudo apt-get install linux-headers-3.5.0-17-generic

It's working fine now :) thanks for the support.

And yeah, I've tried to download the drivers from nvidia driver download page (.run file) but that was just too complicated to install it for me (complete noob, yeah ikr :/)
Zoktar 16 Νοε, 2012 @ 7:37πμ 
A little offtopic, but something i found that helped me fix some package management issues, while getting the correct drivers and dependency's working.

Sometimes the package management gets clogged up and doesn't uninstall some stuff correctly.
This will purge-uninstall stuff that has been selected for uninstall, but have not uninstalled.

Having the package management issues early on can really drive you nuts!. Here it is. Note you will need to install aptitude, "sudo apt-get install aptitude", its another package manager app like synaptic but for console. Purge instead of remove can be helpful where remove leaves some configuration files or caches behind at times.

sudo aptitude purge `dpkg --get-selections|grep deinstall|cut -f 1`

Εμφάνιση 1-10 από 10 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 13 Νοε, 2012 @ 1:22μμ
Αναρτήσεις: 10