Fantu Nov 10, 2012 @ 5:25am
Trine 2
I played more than 1 hour, work perfect also with intel sandybridge graphic card, for now I not found bugs or graphic problem, very good.
Last edited by Fantu; Nov 10, 2012 @ 5:25am
Showing 1-15 of 18 comments
< >
AJSB Nov 10, 2012 @ 5:32am 
How about frame rate ? What's your CPU exactly ?
Fantu Nov 10, 2012 @ 5:42am 
I have core I5-2430, about frame rate what I must do for see it?
ʕ•ᴥ•ʔ Nov 10, 2012 @ 5:53am 
Works for me, too. Just a few bugs. Launcher can't find gtk+2 theme so it looks wierd, but it is my lib32 set's problem. Also the window which says that it can't detect my distibution appears behind the steam window so it looks like game doesn't start. And a bug within the game, sound effects and/or music sometimes stop and start again. However, this game fully works, doesn't lag and never crashed. Oh, and it is a damn beautiful game :D
mdkcore Nov 12, 2012 @ 12:51pm 
Ran perfectly and smoothly for me. Need to play more yet :p
nineinchnick Nov 13, 2012 @ 10:37am 
Runs fine on Ivy with HD4000, i5 3570k not overclocked. At max details you can feel there are few fps too little, but it's playable all right.
mozes Nov 15, 2012 @ 6:16pm 
My specs:
[Hardware]
AMD Phenom II x4 955 @ 3600 Mhz
ATI Radeon HD4870 @ 800/1100Mhz
[Software]
Ubuntu 12.04 & Gnome 3
fglrx 2:8.960-0ubuntu1

I've played the first level of Trine 2 @ 1920x1080 on the highest settings, no AA, no vsync.
There were no problems launching the game in both fullscreen and windowed mode. The game runs good overall. I don't know the exact FPS but it felt like somewhere between 20-30.

The biggest issue is performance. I ran the following command while playing:
$ watch "aticonfig --odgc; aticonfig --odgt"

Results:
GPU temp idle : 52 °C
GPU temp load: 59° C <- this is too low, on Windows this is around 70°C
Max GPU load: 28% <- too low, this is at 99% on Windows

It would be nice if other people also run the game while looking at the load using the command above. Remember to mention your hardware specs and GPU driver version. Also, if someone knows how to get the current FPS inside the game that would be cool.

-- UPDATE
I've switched to Gnome classic and the framerates are a lot better. I'd recommend testing all games in a non compositing window manager
Last edited by mozes; Nov 17, 2012 @ 3:01am
sorath Dec 9, 2012 @ 12:50pm 
The game seems run perfectly with FPS equal 28-30 and 28% GPU loading with 58-66 C temperature (very high settings, FXAA 2xSSAA, no vsync)

[Hardware]
AMD Phenom II X4 955 @ 3.2 GHz (standart freq.)
ATI Radeon 5850 @ 725/1000 (standart freq.)
[Software]
Gentoo x86_64 kernel-3.5.7
KDE 4.9.3 (with enabled kwin compositing)
Catalyst-12.10

I disabled kwin compositing but without any results to FPS improvement

P.S.
to enable showing FPS open
~/.frozenbyte/Trine2/options.txt
find setOption(renderingModule, "ShowFPS", false)
and change "false" to "true", namely:
setOption(renderingModule, "ShowFPS", true)
Last edited by sorath; Dec 9, 2012 @ 1:04pm
kilavil Dec 9, 2012 @ 12:58pm 
I really like this game and its atmosphere. Unfortunately I've got problems with my two monitors for the game asks for a screenresolution but ignores it and tries to show the game over both monitors ....If I disable one of them everything works fine :-)

[Hardware]
AMD Phenom II X2
nVidia GTX 560
Monitor 1: 1920x1080; Monitor 2: 1280x1024
[Software]
Ubuntu 12.10
nvidia-current driver
fighterpenguin Dec 10, 2012 @ 10:29am 
The first time I wanted to play, all went perfect. But at the second time, even steam did not open. I changed from Cinnamon to Unity, and I could open steam again. But when I click on "Play" now, it opens and immediately closes the window again.
Has anybody got an idea what I can do?

I want to play this game again... :(
sorath Dec 10, 2012 @ 10:35am 
It seems that problem with max of 30 fps is related with config of game (~/.frozenbyte/Trine2/options.txt)
In spite of FPSCap is turn of inside game settings via appropriate menu this option remain ON:
setOption(trine2Module, "FPSCapEnabled", true)
setOption(trine2Module, "TargetSmooth30FPS", true)
Maybe game developer decide lock this on Linux platform, as I read today that on game consoles this value is locked for 30 FPS. As I see the option "Enable FPSCap" in game Video Settings doesn't have influence at all and doesn't rewrite appropriate section in "~/.frozenbyte/Trine2/options.txt"

If I manualy change
setOption(trine2Module, "FPSCapEnabled", true)
to
setOption(trine2Module, "FPSCapEnabled", false)
then after start of game then FPS increase up to 32-40 in game (and 60 in game menu) at these preferences (with 36% GPU load, maybe it depends also on enabled CPU Cool&Quite):

[Hardware]
AMD Phenom II X4 955 @ 3.2 GHz (standart freq., Cool&Quite enable)
ATI Radeon 5850 @ 725/1000 (standart freq.)

[Game Settings (pre-start )]
Screen Resolution: 1680x1050, fullscreen automatic
Anti_aliasing: FXAA + 2xSSAA
Vertical sync: off
Graphics detail level: Very High
Last edited by sorath; Dec 17, 2012 @ 11:46am
Grokit Dec 10, 2012 @ 10:55am 
Works fine for me at max settings. Not sure about the frame rates but its enough so that I dont see any lag, artifacts, etc.
  • Kubuntu 12.10 (fresh install, my main os is 12.04 and ia32 libs is totally broken there)
  • i7-2600k
  • 2x gtx 570
  • asrock extreme7
  • nvidia-310 driver
Only had a problem installing the ia32 libs. Never brought up muon or any other installer, even a konsole running apt would have been welcome. Then tried running steam as root since the message was that the account needed admin privlages. Same result. It needs to know what to call when there are missing packages. At least it looks for them, which is better than nothing.

ps. running the steam client as root borks it until you reboot - not recommended
sorath Dec 10, 2012 @ 11:16am 
Yes, I think that stable 30 fps is enough for comfortably gaming in such case, but it just interesting why it is differ so from Windows and GPU load is so small (the maximum fps is locked by 100 for this game)
Last edited by sorath; Jun 15 @ 2:15pm
Rods Dec 10, 2012 @ 2:42pm 
I run the game on extreme video settings, the fps is ok. My specs are AMD FX 6100, AMD Radeon HD 6850, 8gb MEM
sorath Dec 11, 2012 @ 10:24am 
The game run well but the only issue is that "Enable FPSCap" options in internal game's menu video settings doesn't affect config-file and remain always enable with limitation of 30 fps.
I noticed above how to enable fps-show option in "Trine 2"
Last edited by sorath; Dec 11, 2012 @ 10:25am
sorath Dec 12, 2012 @ 9:06am 
Well, disabling Cool&Quite give me 48-70 fps with 50 % GPU load while as I mentioned above it is 32-40 (36% GPU load) if this option is enabled.

[Hardware]
AMD Phenom II X4 955 @ 3.2 GHz (standart freq.)
ATI Radeon 5850 @ 725/1000 (standart freq.)

[Game Settings (pre-start)]
Screen Resolution: 1680x1050, fullscreen automatic
Anti_aliasing: FXAA + 2xSSAA
Vertical sync: off
Graphics detail level: Very High
Last edited by sorath; Dec 17, 2012 @ 11:46am
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Nov 10, 2012 @ 5:25am
Posts: 18