Steam for Linux

Steam for Linux

shatsky 8. nov, 2012 @ 2:21am
[BUG] Steam gets terminated with SIGILL
Tried Steam on my second PC which runs 32bit Ubuntu 12.04, got SIGILL:
shatsky@shatsky-desktop:~$ steam
/home/shatsky/Steam/ line 113: 2104 Illegal instruction (core dumped) ${DEBUGGER} "${STEAMROOT}"/${PLATFORM}/${STEAMEXE} "$@"
GDB shows this:
Program received signal SIGILL, Illegal instruction.
0x0823e931 in std::tr1::__detail::_Prime_rehash_policy::_M_next_bkt(unsigned int) const ()
My /proc/cpuinfo:
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2500+
stepping : 0
cpu MHz : 1837.000
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
bogomips : 3681.73
clflush size : 32
cache_alignment : 32
address sizes : 34 bits physical, 32 bits virtual
power management: ts
Sist redigert av shatsky; 8. nov, 2012 @ 2:24am
< >
Viser 1-9 av 9 kommentarer
andrew 8. nov, 2012 @ 3:46am 
same here with an AMD Ahtlon XP 2400+
shatsky 8. nov, 2012 @ 3:56am 
Seems it uses some instruction set extensions which weren't implemented in these processors yet.
andrew 8. nov, 2012 @ 4:22am 
I've checked with the strace debug... and it seems also unable to find some libs (search for i686 libs instead of the i386 present in the system)

Now I'm trying to place it manually into the steam folder to see if start or crash (the first 3/4 libs I've placed in steam folder no longer gave me "Not found" error as previously)
andrew 10. nov, 2012 @ 11:09am 
Ok, Tried... still crashing

time to buy new PC, also Adobe dropped support for flash on athlon xp...
Carogna 10. nov, 2012 @ 11:18am 
I try to guess: lack of SSE2 ?
andrew 11. nov, 2012 @ 1:42am 
GoodOlAndy [Linux] 11. nov, 2012 @ 7:07pm 
Things were working find on my Acer Aspire 1690 laptop until just now when a Steam update came down. Now it errors out with the line 113 error shown in the original post. It was great using Steam while it lasted.
andrew 16. nov, 2012 @ 5:09am 
In the beta requirements the minimum processor is Athlon XP 1500+ ... maybe this bug will be fixed (or the SSE support added) later? or requirements increased?

( Anyway next week I should order a Celeron G530 or G550 )
Bomaeira Stone 3. des, 2012 @ 5:01pm 
After searching the web because of this Illegal instruction error message, i found some pages with the hint to SSE2 support. I figured out what I really had done and why suddenly the steamcmd does not work anymore.

I created a Ubuntu server in VMware player on an Intel i5 computer. Everything works fine (installing steamcmd etc. works.) After that I ported the VM to an old PC (Athlon XP1900+) and the steamcmd didn't work anymore.

I read along and fond some pages. The CPU only supports SSE not SSE2.

So hopefully they fix this bug and don't change the minimum requirements.

< >
Viser 1-9 av 9 kommentarer
Per side: 15 30 50

Dato lagt ut: 8. nov, 2012 @ 2:21am
Innlegg: 9