Steam for Linux > 일반 토론 > 제목 정보
shatsky 2012년 11월 8일 오전 2시 21분
[BUG] Steam gets terminated with SIGILL
Tried Steam on my second PC which runs 32bit Ubuntu 12.04, got SIGILL:
shatsky@shatsky-desktop:~$ steam
/home/shatsky/Steam/steam.sh: line 113: 2104 Illegal instruction (core dumped) ${DEBUGGER} "${STEAMROOT}"/${PLATFORM}/${STEAMEXE} "$@"
GDB shows this:
Program received signal SIGILL, Illegal instruction.
0x0823e931 in std::tr1::__detail::_Prime_rehash_policy::_M_next_bkt(unsigned int) const ()
My /proc/cpuinfo:
processor : 0
vendor_id : AuthenticAMD
cpu family : 6
model : 10
model name : AMD Athlon(tm) XP 2500+
stepping : 0
cpu MHz : 1837.000
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
bogomips : 3681.73
clflush size : 32
cache_alignment : 32
address sizes : 34 bits physical, 32 bits virtual
power management: ts
shatsky님이 마지막으로 수정; 2012년 11월 8일 오전 2시 24분
9개 중 1-9 표시중
< >
andrew 2012년 11월 8일 오전 3시 46분 
same here with an AMD Ahtlon XP 2400+
shatsky 2012년 11월 8일 오전 3시 56분 
Seems it uses some instruction set extensions which weren't implemented in these processors yet.
andrew 2012년 11월 8일 오전 4시 22분 
I've checked with the strace debug... and it seems also unable to find some libs (search for i686 libs instead of the i386 present in the system)

Now I'm trying to place it manually into the steam folder to see if start or crash (the first 3/4 libs I've placed in steam folder no longer gave me "Not found" error as previously)
andrew 2012년 11월 10일 오전 11시 09분 
Ok, Tried... still crashing

time to buy new PC, also Adobe dropped support for flash on athlon xp...
fpo 2012년 11월 10일 오전 11시 18분 
I try to guess: lack of SSE2 ?
andrew 2012년 11월 11일 오전 1시 42분 
Maybe
GoodOlAndy [Linux] 2012년 11월 11일 오후 7시 07분 
Things were working find on my Acer Aspire 1690 laptop until just now when a Steam update came down. Now it errors out with the line 113 error shown in the original post. It was great using Steam while it lasted.
andrew 2012년 11월 16일 오전 5시 09분 
In the beta requirements the minimum processor is Athlon XP 1500+ ... maybe this bug will be fixed (or the SSE support added) later? or requirements increased?
http://steamcommunity.com/app/221410/discussions/1/882965118609963322/

( Anyway next week I should order a Celeron G530 or G550 )
Bomaeira Stone 2012년 12월 3일 오후 5시 01분 
After searching the web because of this Illegal instruction error message, i found some pages with the hint to SSE2 support. I figured out what I really had done and why suddenly the steamcmd does not work anymore.

I created a Ubuntu server in VMware player on an Intel i5 computer. Everything works fine (installing steamcmd etc. works.) After that I ported the VM to an old PC (Athlon XP1900+) and the steamcmd didn't work anymore.

I read along and fond some pages. The CPU only supports SSE not SSE2.

So hopefully they fix this bug and don't change the minimum requirements.

Greetings,
Bomaeira
9개 중 1-9 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2012년 11월 8일 오전 2시 21분
게시글: 9