stamasd Nov 7, 2012 @ 4:40am
[BUG] Radeon: bad window flicker
Ubuntu 12.04 64-bit with latest fglrx driver.

The Steam window flickers very badly, to the point of being unusable. You have to guess where buttons/menus are to click them. Managed to install a few games (darwinia, Defcon, Psychonauts etc) by creative guess-and-click. When attenpting to start them, they pop up an error box- however I can't read what it says because of the flickering.

Posting this from the Steam client on Windows, because the Linux one is unusable.
Last edited by stamasd; Nov 7, 2012 @ 6:38am
Showing 1-15 of 20 comments
< >
The19thFighter Nov 7, 2012 @ 5:15am 
1.st you could write this from an Internet Browser 2nd. Have you tried to use another DM instead of (I guess) Unity? Also, it would interest me, what glxgears says about the Framerate. Because if it's around 60 FPS Vsync is enabled.
stamasd Nov 7, 2012 @ 5:18am 
Here is more info.
Yes, now I'm replying from browser. That much is fixed.
glxgears gives me around 5600 FPS.
Looking through stderr I see this:
"surface_linux.cpp (1207) : Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt..."

However, glxinfo tells me direct rendering is enabled:
"name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4"

Looks like a bug.
stamasd Nov 7, 2012 @ 5:23am 
Even more info.

I have uninstalled fglrx. Now glxinfo rightly says "drect rendering: No".
Steam acts the same, with bad window flickering.

Full logs available on demand.

Also, I reinstalled fglrx. Same behavior, Steam will give the same error about direct rendering in stderr.
Last edited by stamasd; Nov 7, 2012 @ 5:31am
Brummbaer [AUT] Nov 22, 2012 @ 4:31am 
gonna bump this again, still bad flickering with latest radeon from xorg edgers and tf2
stamasd Nov 30, 2012 @ 1:09pm 
It's useless reporting bugs here, nobody reads them.
Muffinabus Nov 30, 2012 @ 1:11pm 
Why would you say that? I'm sure there's people reading most of everything on here.
DaVince Nov 30, 2012 @ 1:15pm 
Originally posted by stamasd:
It's useless reporting bugs here, nobody reads them.
It's useful reporting bugs here, the developers read them.

I'm not kidding. The limited beta tester forum is right next to this one. It's just one click away. And devs have replied here regularly before, to very valid issues.

However, you'd need to post a few more details about your system specs, window manager, etc.

Posting this from the Steam client on Windows, because the Linux one is unusable.
Tip: you can login and post from http://steamcommunity.com/ in any web browser! :)
stamasd Nov 30, 2012 @ 1:29pm 
It's useless and nobody reads them, or if they do they don't do anything about them. I started this topic 3 weeks ago, and the bug is still there and makes steam unusable for me.
DaVince Nov 30, 2012 @ 1:39pm 
I'm inclined to say "Just three weeks?"

The place is absolutely overflowing with reports, even in *just* the beta tester forum. There are really SO many reports coming in, it's crazy. And that's probably why they limited the testing audience in the first place. But I definitely have seen some of the devs reply on posts in the public forums a few times!

I'm sure this will be fixed in due time, whether directly thanks to this report or due to bug fixes from other reports, or driver updates, etc. If it still misbehaves like this upon official release, I think you can complain a bit more than you do now, though. :P
Scholl Dec 8, 2012 @ 6:10am 
I have the same issue. I'm using Arch Linux (64bit) with GNOME Shell and having an ATI Mobility Radeon HD 5650 with catalyst drivers installed (ver. 12.11-1) from the unofficial repository by Vi0L0 (https://wiki.archlinux.org/index.php/AMD_Catalyst ), also tried the catalyst-dkms package from the official repositories.

Seems like the main Steam window wants to be on top of anything else. While Steam is running I can't access my desktop or any other programs running, although it looks it's just a visual thing as I can click through the window if it's not focused. Also happens when I open any menu or a tooltip appears: the Steam window disappears for a moment (or it paints the screen completely black) as the application draws the menu but it quickly reappears, completely covering up the menu. I can click the menuitems, as stated before.

I don't have this problem with xf86-video-ati (but then I have like 6 FPS in TF2).

update:
I switched GNOME Shell to fallback mode, and it works for the most part: I only see a small flickering when showing menus or tooltips, but it displays correctly in front of the main window, also I can switch between applications, and they show up in front of the main Steam window correctly as well. The only problem is, the main Steam window covers up all the screen - even when not in big picture mode. Resizing not works (mimimizing the window is possible), meaning that I have to minimize the window to access the status bar, the GNOME menus or the desktop switcher. (As fallback mode is not really supported by GNOME and it's kinda broken, I don't prefer to use it either... for instance, I have two of everything on screen right now, two status menus, two desktop switcher, two application toolbar, two clock...)

Steam version is Dec 7 2012, 15:33:46

System information:
Processor Information:
Vendor: GenuineIntel
Speed: 2534 Mhz
4 logical processors
3 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Linux (64 bit)
Kernel Name: Linux
Kernel Version: 3.6.9-1-ARCH
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. ATI Mobility Radeon HD 5000 Series

Driver Version: 4.2.11978 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x1002
DeviceID: 0x68c1
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 13,39" x 7,48" (15,31" diag)
34,0cm x 19,0cm (38,9cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC269

Memory:
RAM: 7844 Mb

Miscellaneous:
UI Language: English
LANG: en_GB.utf8
Microphone: Not set
Total Hard Disk Space Available: 39371 Mb
Largest Free Hard Disk Block: 3400 Mb
Last edited by Scholl; Dec 8, 2012 @ 6:12am
semmigeci Mar 8, 2013 @ 7:50am 
Soooo... It's March, 2013. I just paid for some games and can't use them because nobody has fixed this issue in months. Paypal reversal: here we go.
Shark Mar 8, 2013 @ 7:52am 
Originally posted by semmigeci:
Soooo... It's March, 2013. I just paid for some games and can't use them because nobody has fixed this issue in months. Paypal reversal: here we go.
Don't, if you do it like that you'll get your steam account blocked. You should do it through steam support.
arc| Gps Mar 8, 2013 @ 6:04pm 
I have my steam screen almost fullscreen, but not totally.
This did solve the flickering issue for me on openSUSE.
To me it looks a kde steam conflict. about control of the screen.
zapakh Aug 24, 2013 @ 4:50pm 
Same problem in KDE, in Kubuntu Precise and Raring, with fglrx-updates. Setting the steam client to fullscreen on one monitor (Alt-F1, More Actions, F) is a workaround. Using the Maximize icon in the Steam window is not sufficient.
Langley Aug 21, 2014 @ 11:24am 
Bump, because this is a joke. I just got affected by this bug as well, also with an AMD card. In my case it might have been related to Ubuntu/the AMD driver being unable to handle my dual-monitor setup (lol, quality OS). After fixing that, Steam began locking my system up 5 seconds after boot. Removed it now, don't know if I dare install it again... What a piece of junk.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Nov 7, 2012 @ 4:40am
Posts: 20