Steam for Linux > Discuții generale > Detaliile subiectului
Orkestra 7 nov., 2012 @ 3:31am
Steam won't start
I installed the steam.deb package without any issues but nothing happen when I try to launch steam. I also tried to launch it via the Terminal and got this error :

ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 45 (X_OpenFont)
Serial number of failed request: 12
Current serial number in output stream: 13

There's nothing in my public folder.
My version of Ubuntu is in French, if that's of any help...

(Please excuse my english... :) )
Editat ultima dată de Orkestra; 7 nov., 2012 @ 3:32am
Afişate 1-15 din 25 de comentarii
< >
FluX 7 nov., 2012 @ 3:39am 
me too i fix it. Search in /home/USERNAME/Steam tmp folder and copy all files in /home/USERNAME/Steam

in terminal test

steam steam://open/store/ &



Orkestra 7 nov., 2012 @ 5:28am 
I may have misunderstood your solution but I couldn't make it work.


In "/home/USERNAME/Steam", there's just a file ("steam.sh") and two folders ("package" and "ubuntu12_32") with a single texte file ("beta") in the first one, and a steam executable in the second one. No hidden file.

In "home/USERNAME/", I found a ".steam" hidden folder but the two file shortcuts goes right into my actual "Steam" folder...


Did I miss something ?
Editat ultima dată de Orkestra; 7 nov., 2012 @ 5:28am
paradigm 7 nov., 2012 @ 6:31am 
I had a similar issue - the problem as I understand it is that steam cannot find the fonts it normally expects. Presumably these are installed and set up by default with Ubuntu - I'm doing some weird stuff with my not-exactly-Ubuntu distro such that I don't exactly get the defaults.

On Ubuntu, the relevant package seems to be "xfonts-100dpi". Install that with your package manager and it might just work from there. For me, X11 (the main back-end of the graphical part of your system) didn't seem to pick up that the newly installed fonts were there, so I had to tell it where to find them.

Running "dpkg -L xfonts-100dpi" shows me the files that were installed by that package were installed to "/usr/share/fonts/X11/100dpi/", and so I need to run the following: "xset +fp /usr/share/fonts/X11/100dpi" to add that directory to the font path. After that, X11 was able to show whatever font steam wants and steam was able to function properly.

I'm not sure how to properly add "/usr/share/fonts/X11/100dpi" to the font path in the long-term - I have that command run every time I start X11 (with .xinitrc).

Good luck!
Orkestra 7 nov., 2012 @ 8:01am 
It works, I had to run "xset" too. Thank you !

I also tried cut/paste the "100dpi" folder from the "X11" one to the "fonts" one but it didn't solve the issue.
chris.ben9 7 nov., 2012 @ 1:24pm 
Thx for your help but for me it didn't work... same error;
Installing breakpad exception handler for appid(steam)/version(0)
unlinked 0 orphaned pipes
shatsky 7 nov., 2012 @ 1:43pm 
You must install bitmap fonts which match -*-*-medium-r-normal--0-120-*-*-p-0-iso8859-1 XFLD, see http://steamcommunity.com/app/221410/discussions/0/882965239651349613/
shatsky 7 nov., 2012 @ 1:46pm 
chris.ben9 a scris:
same error;
Installing breakpad exception handler for appid(steam)/version(0)
unlinked 0 orphaned pipes
These are normal messages. Try using DEBUGGER=strace and LD_DEBUG=libs to see what's wrong.
Editat ultima dată de shatsky; 7 nov., 2012 @ 1:46pm
chris.ben9 7 nov., 2012 @ 2:19pm 
thats what my debug gets:
13232: find library=libgpg-error.so.0 [0]; searching
13232: trying file=/home/chris/Steam/ubuntu12_32/libgpg-error.so.0
13232: trying file=tls/i686/sse2/cmov/libgpg-error.so.0
13232: trying file=tls/i686/sse2/libgpg-error.so.0
13232: trying file=tls/i686/cmov/libgpg-error.so.0
13232: trying file=tls/i686/libgpg-error.so.0
13232: trying file=tls/sse2/cmov/libgpg-error.so.0
13232: trying file=tls/sse2/libgpg-error.so.0
13232: trying file=tls/cmov/libgpg-error.so.0
13232: trying file=tls/libgpg-error.so.0
13232: trying file=i686/sse2/cmov/libgpg-error.so.0
13232: trying file=i686/sse2/libgpg-error.so.0
13232: trying file=i686/cmov/libgpg-error.so.0
13232: trying file=i686/libgpg-error.so.0
13232: trying file=sse2/cmov/libgpg-error.so.0
13232: trying file=sse2/libgpg-error.so.0
13232: trying file=cmov/libgpg-error.so.0
13232: trying file=libgpg-error.so.0
13232: trying file=/lib/i386-linux-gnu/libgpg-error.so.0
13232: calling init: /lib/i386-linux-gnu/libgpg-error.so.0
13232: calling fini: /lib/i386-linux-gnu/libgpg-error.so.0 [0]

maybe its a good fact to know, that i am using Intel G33 as "Graphic"-Chip-replacement
Editat ultima dată de chris.ben9; 7 nov., 2012 @ 2:35pm
shatsky 7 nov., 2012 @ 2:47pm 
chris.ben9 a scris:
thats what my debug gets
No, this is just a normal output about a shared library which contains 'error' in its name... Problem somewhere else.
ªrturo - 16 nov., 2012 @ 4:08am 
I too received the public/steambootstraploader_english.txt errors.
I managed to get Steam running in Lubuntu:
-downloaded & ran Steam.deb
-enabled nvidia restricted drivers and repository
-installed the xfonts-100dpi package via Synaptic
Editat ultima dată de ªrturo -; 16 nov., 2012 @ 4:10am
Flutterstare 16 nov., 2012 @ 4:32am 
Hello.

I have a similar problem. In my case, my Steam client doesn't start since this week update. Now, when I run steam in a terminal, it shows this message:

"/usr/bin/steam: línea 64: /steam.sh: The file or directory doesn't exist"

I'm not in the beta.
Brer Lapin 7 dec., 2012 @ 3:04pm 
Thanks, just installed lubuntu to get a bit more performance out of my system, ran into this problem but using the xset command worked
[-(KFC)-]NM4500 26 ian., 2013 @ 1:45pm 
After the installign process i cnat launch steam and there is no steam folder
[Linux] frankweslar 26 ian., 2013 @ 3:22pm 
Steam should be under ~/.steam/ or ~/.local/share/Steam
[-(KFC)-]NM4500 27 ian., 2013 @ 4:41am 
There is no folder like this
Afişate 1-15 din 25 de comentarii
< >
Per pagină: 15 30 50
Data publicării: 7 nov., 2012 @ 3:31am
Mesaje: 25