Steam for Linux > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Meowing Ocelot 6 Νοε, 2012 @ 7:31μμ
Korean Fonts not showing up
My distro supports korean, and I can freely type in it(ㄴㅇㄹㄹㄴㅇㅎㅇㄹㅎㄹㅇㄴ) but Steam for linux shows those squares that means fonts are missing.

Don't have this on windows. Thought I should report it here
Εμφάνιση 1-13 από 13 σχόλια
< >
Benjamin 6 Νοε, 2012 @ 8:38μμ 
I can add that Japanese fonts are not working either.
librin.so.1 27 Νοε, 2012 @ 3:22πμ 
I did a bit of testing - made a steam skin where I force it to use another font. I know for sure that this font has korean, japanese and [many other] glyphs I tested. They still show up as those blocks/squares. So suspect the problem is not in missing glyphs, but somewhere else along text or font handling line.
win32.executioner 7 Δεκ, 2012 @ 1:26πμ 
Thai is not working.
Rufian [GCC] 9 Δεκ, 2012 @ 1:14μμ 
Text is retrieved and stored ok since you can copy the hidden glyphs to other program and read them. I wonder which fonts Steam expects for Asian text, if any.
rudeboyskunk 9 Δεκ, 2012 @ 4:04μμ 
Same for me. I use ibus for Korean, and when I press the button to turn it on, nothing happens. However, in Kim Jeon-eun's post, I can see the Korean letters just fine.
djee 24 Δεκ, 2012 @ 2:21πμ 
Korean and Japanese fonts does not display at all for me, not even with boxes. There is simply a blank space. I have ibus also, set up for both Korean and Japanese, and it works just fine for everything else including custom-developed games. Input Method (IM) is probably just not supported yet.
嘔吐 24 Δεκ, 2012 @ 4:09πμ 
The same thing does indeed happen with Japanese fonts. They do not display in most of the client -- the friends dialog shows them as blank boxes. TF2 doesn't display them at all. I can, however, see them in here in the discussions. Input with ibus doesn't work either.
djee 24 Δεκ, 2012 @ 7:21πμ 
AFAIK that's because "here in the discussions" is HTML-based, unlike the steam client (menus, not main content) and TF2 are not.
嘔吐 24 Δεκ, 2012 @ 12:14μμ 
Αναρτήθηκε αρχικά από djee:
AFAIK that's because "here in the discussions" is HTML-based, unlike the steam client (menus, not main content) and TF2 are not.

This seems to be the case indeed.
suore 16 Ιαν, 2013 @ 2:24μμ 
Polish special latin characters also not working ( like Ą Ś Ć Ł Ó Ż Ź Ń )
For me its very important that if someone is going to do to me LASKA (suck) or ŁASKA ( grace).
ss 16 Ιαν, 2013 @ 9:33μμ 
Αναρτήθηκε αρχικά από StackOverflow:
Polish special latin characters also not working ( like Ą Ś Ć Ł Ó Ż Ź Ń )
They're working for me, you should fix your keyboard layout/fonts.
Τελευταία επεξεργασία από ss; 16 Ιαν, 2013 @ 9:34μμ
Meowing Ocelot 9 Φεβ, 2013 @ 12:18μμ 
OP here. Issue seems to be fixed
rudeboyskunk 9 Φεβ, 2013 @ 3:43μμ 
Αναρτήθηκε αρχικά από 김일성:
OP here. Issue seems to be fixed

I can set mine to Korean and the Korean shows up fine, but I still can't type in Korean. Using ibus on Ubuntu 12.04.1 64-bit.
Εμφάνιση 1-13 από 13 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 6 Νοε, 2012 @ 7:31μμ
Αναρτήσεις: 13