Steam for Linux > 一般討論 > 主題細節
tronman 2013 年 09 月 27 日 @ 下午 7 時 40 分
Unable to login: Could not connect to Steam network
Hi guys,

I'm having trouble logging in, every time I launch I'm getting "Could not connect to Steam network. This could be due to a problem with your Internet connection, or with the Steam network. Please visit www.steampowered.com for more info."

My internet connection is working fine, as is my Steam Account (Logged in now). I don't see anything on the steam powered site. Any ideas what's going on? Anyone else having issues?

Thanks!
Jason
最後修改者:tronman; 2013 年 09 月 27 日 @ 下午 7 時 41 分
顯示 1-15,共 19 則回應
< >
tronman 2013 年 09 月 27 日 @ 下午 8 時 43 分 
I completely uninstalled from the software center, purged ~/.steam, reinstalled and it's working now again! Uninstall/reinstall without purging .steam didn't work.
Dr. Love 2013 年 10 月 7 日 @ 上午 7 時 36 分 
tronman 發表:
I completely uninstalled from the software center, purged ~/.steam, reinstalled and it's working now again! Uninstall/reinstall without purging .steam didn't work.
Would you mind explaining how you did this? Commands, directions and all that.
Cheogh 2013 年 10 月 7 日 @ 上午 7 時 45 分 
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.
Dr. Love 2013 年 10 月 7 日 @ 上午 8 時 41 分 
Cheogh 發表:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.
The first command worked, thanks.
Chibiookani 2013 年 10 月 13 日 @ 上午 8 時 43 分 
Cheogh 發表:
Try steam --reset
This one solved the problem, thanks a lot.
benmcneil102 2013 年 10 月 13 日 @ 下午 8 時 51 分 
So I just type rm -r .local/share/Steam when the terminal opens or is there a step before this...when I tried to do steam --reset it didn't do anything


I don't have any experience with linux just trying it out
crysman 2013 年 10 月 25 日 @ 上午 9 時 01 分 
Cheogh 發表:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.

steam --reset
has worked for me! thx
Mehtuus 2013 年 10 月 28 日 @ 下午 9 時 49 分 
Cheogh 發表:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.

I had to do it in the reverse order:

rm -r .local/share/Steam
steam --reset

And then I chose to reinstall when prompted. After that, everything worked.
ghostcorps 2013 年 11 月 15 日 @ 下午 2 時 53 分 
Cheogh 發表:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.

Worked like a charm
Rambo 2013 年 11 月 28 日 @ 下午 3 時 37 分 
http://www.youtube.com/watch?v=V0mjCM9XCh8

Seems sketch, but worked flawlessly. Got me in no problem.
Ulrar 2013 年 12 月 14 日 @ 下午 1 時 40 分 
Okay that's annoying, I have to do a steam --reset almost everyday to get it to connect :(
Apocryphus 2013 年 12 月 14 日 @ 下午 1 時 50 分 
Ulrar 發表:
Okay that's annoying, I have to do a steam --reset almost everyday to get it to connect :(

Which distro are you using?
Ulrar 2013 年 12 月 14 日 @ 下午 4 時 08 分 
I am using Gentoo.
For some reason, almost each time I get a connection problem, but sometimes it works without a reset.
Kranky K. Krackpot Sr. 2013 年 12 月 14 日 @ 下午 4 時 33 分 
Ulrar 發表:
I am using Gentoo.
For some reason, almost each time I get a connection problem, but sometimes it works without a reset.
I'm on stable Gentoo too. Right now tried to restart Steam once again -- no problems, as usual. We want logs!
Ulrar 2013 年 12 月 15 日 @ 下午 2 時 03 分 
http://bpaste.net/show/158821/

Just tried, it didn't worked, I restarted steam, it worked, I restarted again and it didn't work. This paste is from the third try, where it didn't work.
最後修改者:Ulrar; 2013 年 12 月 15 日 @ 下午 3 時 38 分
顯示 1-15,共 19 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 09 月 27 日 @ 下午 7 時 40 分
回覆: 19