tronman Sep 27, 2013 @ 7:40pm
Unable to login: Could not connect to Steam network
Hi guys,

I'm having trouble logging in, every time I launch I'm getting "Could not connect to Steam network. This could be due to a problem with your Internet connection, or with the Steam network. Please visit www.steampowered.com for more info."

My internet connection is working fine, as is my Steam Account (Logged in now). I don't see anything on the steam powered site. Any ideas what's going on? Anyone else having issues?

Thanks!
Jason
Last edited by tronman; Sep 27, 2013 @ 7:41pm
Showing 1-15 of 19 comments
< >
tronman Sep 27, 2013 @ 8:43pm 
I completely uninstalled from the software center, purged ~/.steam, reinstalled and it's working now again! Uninstall/reinstall without purging .steam didn't work.
Dr. Evol Oct 7, 2013 @ 7:36am 
Originally posted by tronman:
I completely uninstalled from the software center, purged ~/.steam, reinstalled and it's working now again! Uninstall/reinstall without purging .steam didn't work.
Would you mind explaining how you did this? Commands, directions and all that.
Cheogh Oct 7, 2013 @ 7:45am 
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.
Dr. Evol Oct 7, 2013 @ 8:41am 
Originally posted by Cheogh:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.
The first command worked, thanks.
Chibiookani Oct 13, 2013 @ 8:43am 
Originally posted by Cheogh:
Try steam --reset
This one solved the problem, thanks a lot.
benmcneil102 Oct 13, 2013 @ 8:51pm 
So I just type rm -r .local/share/Steam when the terminal opens or is there a step before this...when I tried to do steam --reset it didn't do anything


I don't have any experience with linux just trying it out
crysman Oct 25, 2013 @ 9:01am 
Originally posted by Cheogh:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.

steam --reset
has worked for me! thx
Mehtuus Oct 28, 2013 @ 9:49pm 
Originally posted by Cheogh:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.

I had to do it in the reverse order:

rm -r .local/share/Steam
steam --reset

And then I chose to reinstall when prompted. After that, everything worked.
ghostcorps Nov 15, 2013 @ 2:53pm 
Originally posted by Cheogh:
Try steam --reset
If that doesn't work rm -r .local/share/Steam should be all you need. You might want to move SteamApps folder to ~/ first though.

Worked like a charm
Rambo Nov 28, 2013 @ 3:37pm 
http://www.youtube.com/watch?v=V0mjCM9XCh8

Seems sketch, but worked flawlessly. Got me in no problem.
Ulrar Dec 14, 2013 @ 1:40pm 
Okay that's annoying, I have to do a steam --reset almost everyday to get it to connect :(
Sin Dec 14, 2013 @ 1:50pm 
Originally posted by Ulrar:
Okay that's annoying, I have to do a steam --reset almost everyday to get it to connect :(

Which distro are you using?
Ulrar Dec 14, 2013 @ 4:08pm 
I am using Gentoo.
For some reason, almost each time I get a connection problem, but sometimes it works without a reset.
Kranky K. Krackpot Sr. Dec 14, 2013 @ 4:33pm 
Originally posted by Ulrar:
I am using Gentoo.
For some reason, almost each time I get a connection problem, but sometimes it works without a reset.
I'm on stable Gentoo too. Right now tried to restart Steam once again -- no problems, as usual. We want logs!
Ulrar Dec 15, 2013 @ 2:03pm 
http://bpaste.net/show/158821/

Just tried, it didn't worked, I restarted steam, it worked, I restarted again and it didn't work. This paste is from the third try, where it didn't work.
Last edited by Ulrar; Dec 15, 2013 @ 3:38pm
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Sep 27, 2013 @ 7:40pm
Posts: 19