Kill all the Volucs Sep 12, 2013 @ 12:04pm
Couldn't set up the Steam Runtime
I need help downloading steam, every time i try it shows me this message and i am clueless what i can do about it.

btw this is what the console says in case anyone says what this means

STEAM_RUNTIME has been set by the user to: /home/fio/.local/share/Steam/ubuntu12_32/steam-runtime
xz: (stdin): Compressed data is corrupt
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
Unpack runtime failed, error code 3
Error: Couldn't set up the Steam Runtime. Are you running low on disk space?
Continuing...

any information in this is appreciated
Showing 1-15 of 16 comments
< >
[Linux] Junior s2 Camila Sep 12, 2013 @ 12:08pm 
I ran onto this on Debian when I was missing some libraries. Did you install the old ia32-libs?
Kill all the Volucs Sep 12, 2013 @ 12:10pm 
no, should i ?
[Linux] Junior s2 Camila Sep 12, 2013 @ 12:27pm 
Depends. The 'ia32-libs' package isn't needed to run Steam, for all I saw Steam pulls all of it's dependencies on Install if you have the video drivers already installed. You can try to install it now:

sudo apt-get install ia32-libs
[Linux] Junior s2 Camila Sep 12, 2013 @ 12:28pm 
But don't install it yet. Check for Client Updatesbeforehand
[Linux] Junior s2 Camila Sep 12, 2013 @ 12:30pm 
Also, try one of these two commands if the Client Update doesn't fix your problem:

steamcmd.sh
and
STEAMEXE=steamcmd ./steam.sh

Also, try to see if you're running out of disk space OR if you have permissions problems on fstab.
Last edited by [Linux] Junior s2 Camila; Sep 12, 2013 @ 12:31pm
Kill all the Volucs Sep 12, 2013 @ 12:36pm 
thanks i will try that
[Linux] Junior s2 Camila Sep 12, 2013 @ 12:38pm 
Also, run the following on Terminal:

STEAM_RUNTIME=0 STEAMEXE=steamcmd ./steam.sh

Some people say this happened to them because the client was updating, so Google a bit and you may find your answer =)

http://www.opengamepanel.org/forum/viewthread.php?thread_id=1823
Last edited by [Linux] Junior s2 Camila; Sep 12, 2013 @ 12:38pm
Kill all the Volucs Sep 12, 2013 @ 2:38pm 
it still shows the message, thanks anyway but i think it may be a problem with steam servers since marks a mismatch on the checksum with the package
###O?qÿáÓ Sep 12, 2013 @ 2:51pm 
Are you running low on disk space?
Kill all the Volucs Sep 12, 2013 @ 2:57pm 
Originally posted by ###O?qÿáÓ:
Are you running low on disk space?
no
Kill all the Volucs Sep 15, 2013 @ 9:00pm 
Well it's been a week since i was able to log in on steam (without wine) and i haven't5 been able to solve this problem, i alredy solved the bootstrap file problem in the usr/lib/steam using the one form the deb file but it still not working


Running Steam on manjarolinux 0.8.7 64-bit
STEAM_RUNTIME is disabled by the user
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
unlinked 0 orphaned pipes

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:4872): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
[0915/175226:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/../common/steam/client_api.cpp (290) : Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed.

Assert( Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed.
):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/../common/steam/client_api.cpp:290

Installing breakpad exception handler for appid(steam)/version(1378500910_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/assert_20130915175226_5.dmp
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/SteamStartup.cpp (652) : Assertion Failed: ! "There was a problem with your Steam installation.\n" "Please reinstall steam.\n"
unlinked 2 orphaned pipes
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 56 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 1 multi object alertable sleeps
[2013-09-15 17:52:26] Startup - updater built Sep 6 2013 12:04:22
[2013-09-15 17:52:26] Verifying installation...
[2013-09-15 17:52:26] Verification complete
Shutting down. . .
[2013-09-15 17:52:27] Shutdown
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-3abfd1a3-c840-4dd3-b31f-49a8d2130915
###O?qÿáÓ Sep 21, 2013 @ 9:14am 
I was searching for the

Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed.

I found[ppfeufer.de], that to fix this you need to do

steam --reset

If this is not going to work you can try to enable SteamRuntime.

STEAM_RUNTIME=1 steam


Hope this will help.
Last edited by ###O?qÿáÓ; Sep 21, 2013 @ 9:15am
Kill all the Volucs Sep 23, 2013 @ 12:00am 
love you thank you very much :D
###O?qÿáÓ Sep 23, 2013 @ 9:24am 
;)
oXbowe May 20 @ 2:28am 
Thank you very much too =)
Showing 1-15 of 16 comments
< >
Per page: 15 30 50