Steam for Linux > 一般討論 > 主題細節
kangstag 2013 年 09 月 1 日 @ 下午 2 時 05 分
OpenGL GLX context is not using direct rendering, which may cause performance problems.
Hi,

Whenever I start up steam, I get this error:
"OpenGL GLX context is not using direct rendering, which may cause performance problems.
For more information visit https://support.steampowered.com/kb_article.php?ref=9938-EYZB-7457."

System specs:
OS: Ubuntu 12.04.3 (LTS) 64-bit
Video card: Radeon HD 6850
I've installed the Linux graphics driver from the AMD website

I went to the link provided in the error message. I ran the 32-bit glxinfo and I get this:
name of display: :0
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

I'm guessing that "direct redendering: No" is one of the problems. I'm a noob so I'm not sure what to do. Any help? Thanks.
顯示 1-6,共 6 則回應
< >
Kesnol 2013 年 09 月 2 日 @ 下午 3 時 59 分 
I had the same problem in debian 64 bits. You need to install some 32 bits libraries... Have a look to libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 and ia32-libs
coldReactive (Iyeru) 2013 年 10 月 18 日 @ 上午 7 時 10 分 
ia32-libs is no longer needed in most debian distros, as 64-bit has 32-bit multiarch already installed. (as a result, installing the 32-bit version of a package removes the 64-bit version, and cannot be installed at the same time due to multi-arch support now included in the OSes.)
Katz 2013 年 10 月 18 日 @ 下午 3 時 17 分 
Steam installed the above mentioned 32 bit packages but still says the same thing. If you have an AMD card is there something else you need to do?
ctalk 2013 年 11 月 14 日 @ 上午 8 時 28 分 
this problem fixed at russian part internet. use this link

http://creative-zone.net/ru/error-opengl-glx-context-is-not-using-direct-rendering-which-may-cause-performance-problems/

sort command list

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases
sudo apt-get install ia32-libs-multiarch lib32gcc1 libc6-i386


(get new driver from amd.com ....)

chmod +x amd-driver-12-6-x86_64.run
sudo sh amd-driver-12-6-x86_64.run

if driver do not install try --force key

DO NOT rather REBOOT

last step

sudo aticonfig --initial -f

and now

sync;sync;reboot
最後修改者:ctalk; 2013 年 11 月 14 日 @ 上午 8 時 29 分
arc| Gps 2013 年 11 月 16 日 @ 上午 7 時 04 分 
What worked for me on openSUSE 64bit, was installing latest beta drivers from amd.
Tensor 04 月 14 日 @ 下午 1 時 38 分 
Worked for me on ubuntu 13.10 with AMD drivers for HD6450. Thanks
顯示 1-6,共 6 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 09 月 1 日 @ 下午 2 時 05 分
回覆: 6