5€95 Aug 25, 2013 @ 6:23am
[Fixed] Cant install game with STEAM on linux ubuntu
Hello,

my system is : ubuntu 12.04 LTS -64 bits
amd HD 6950 - latest driver fglrx-experimental-13

Yesterday i saw in STEAM a update for DOTA 2, i valided this update but chrash at 78 % of download.
I tried to lauchn a new update but was blocked (nothing happen).
So i decide to remove DOTA 2 and STEAM to do a new installation.

After new installation of STEAM i cant install a game (like dota 2 team frotres...).
The insatalaltion crashes always at the same time after the windows preparing game files for install a pop up windows says me : An error occured while installing GAME (unknow error).

Thx for help.
Last edited by 5€95; Aug 26, 2013 @ 9:02am
Showing 1-9 of 9 comments
< >
Zyro Aug 25, 2013 @ 6:36am 
Did you try to start steam in a console?
You'll probably get more information about the problem there.
LOLCAT Aug 25, 2013 @ 7:23am 
If you don't have a beta client, opt in. if you do, opt out.
5€95 Aug 25, 2013 @ 8:09am 
Thank u ;

Originally posted by zyro:
Did you try to start steam in a console?
You'll probably get more information about the problem there.
:

yes in a console the last error is :

KeyValues Error: RecursiveLoadFromBuffer: got EOF instead of keyname in file InstallConfigStore [offset: 4096]
InstallConfigStore, (*Software*), (*Valve*), (*Steam*), (*ConnectCache*), (*557f67e61*), (*Orko67*),
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier1/../tier1/KeyValues.cpp (2403) : Assertion Failed: Error while parsing text KeyValues for resource InstallConfigStore

Originally posted by LOLCAT:
If you don't have a beta client, opt in. if you do, opt out..
:

I opt in : same problem.

I opt out : same problem.



Thank you to all, antoher idea ?



Zyro Aug 25, 2013 @ 8:12am 
Accoding to this bug report, the messages might be due to a broken config file.
https://github.com/ValveSoftware/steam-for-linux/issues/2281

It seems someone there solved his problems with moving away the file:
mv ~/Steam/config/config.vdf ~/Steam/config-backup.vdf
Last edited by Zyro; Aug 25, 2013 @ 8:16am
5€95 Aug 25, 2013 @ 10:25am 
Ok thank you.

I dont rename the file config.vdf i just remove the file.

And for the moment i can dl the game.

I wait (to finish) and will come back, when all be alright for close the thread.

Zyro Aug 25, 2013 @ 10:32am 
:o)

If it works, you should rename the thread, so others can find the solution here.
Last edited by Zyro; Aug 25, 2013 @ 10:43am
5€95 Aug 26, 2013 @ 9:04am 
For the moment all is ok on my computer, so thank you Zyro.

And thank also to other helpers.
valdish Sep 1 @ 6:45am 
Steam -> Settings -> Downloads -> Limit bandwidth to -> 1MB/s
Zyro Sep 1 @ 7:34am 
Originally posted by valdish:
Steam -> Settings -> Downloads -> Limit bandwidth to -> 1MB/s

Wrong thread?
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Aug 25, 2013 @ 6:23am
Posts: 9