Twoonyourface Aug 20, 2013 @ 2:07pm
Definate issue with Steam client on linux
Ok, I have had a problem with Steam for linux for some time now. I logged a call with my ISP over this as they do heavy P2P throttling at peak times but no matter what time of day it is i get the problem.

My connection = 74mbps

Peak Time Throttle of P2P = maximum 4mbps

Peak times..

Steam for Windows = 4mpbs
Steam for Windows Through Wine on Linux = 4mbps
Steam for Linux = between 400mb at 2-4mbps then upto 2.0GB at 0.2mbps !! then 0% traffic download pauses for upto a day or more or until i reboot the router. Also this totals the whole connection and the PS3 i have stops streaming from youtube / lovefilm and i have to reboot the router. So far its been physically impossible to download L4D2 beta i tried for 2 weeks!

I never got this on windows, I dont get it on WINE, I do get this on the native client

Its like its spasing out my LAN / router with the way its handling ports / traffic ??


Anyone else getting this?


Last edited by Twoonyourface; Aug 20, 2013 @ 2:09pm
Showing 1-7 of 7 comments
< >
Woody Aug 20, 2013 @ 5:56pm 
Wired?
Wireless?
Any idea which wired/wireless card you have?
Any idea which drivers are driving your card?
Which Linux distro?
Twoonyourface Aug 22, 2013 @ 1:30pm 
Yea I have an idea lol

Distro Linux Mint KDE/XFCE/Cinnamon tried them, also trued SUSE and got same. Results are on 100mb wired and also with 802.11N Wireless

Woody Aug 22, 2013 @ 7:16pm 
Ok...
What wired and wireless card do you have?
Doc Holliday Aug 22, 2013 @ 7:23pm 
the lspci cammaned can tell you what card you have
Twoonyourface Aug 23, 2013 @ 12:35am 
Ethernet: Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)

Wireless isnt showing in the list but its working.

I tried once again to dowload l4d2 (beat) on linux via wireless. It only ever manages to get to a few GB before the connection is on a go slow last time I left the download overnight it got to 18% before the connection was flat, today it is stuck at 18% doing mere 02.kbps

so it seems i can get around 1.4 -2.0gb and it stops downloading. I have tried different servers.
Also this morning once again my router refused connections to other clients at anything other than the same bitrate ?

This does not seem to happen on WINE / Windows. What Im going to do when I get the chance is put wine back on my fresh install of linux mint cinnamon 15 and install steam, then try download l4d2 and see if It happens there again.

I know it sounds odd, and it might be my networking on linux rather than steam but there does seem to be a complete throttle on P2P (which my ISP does do) but its less agressive on windows / wine

???

instabilis Aug 23, 2013 @ 5:07am 
Have you checked to make sure it's not an issue with your router?
Twoonyourface Aug 23, 2013 @ 8:11am 
well.. it could be. In fact I think there is a conflict of some sort but I get no help from my ISP (they wouldnt admit an issue)

going to test soon to see what the difference is again.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Aug 20, 2013 @ 2:07pm
Posts: 7