[Whos][Black] Sha[red]dow Aug 15, 2013 @ 3:07am
Can someone please help me ? :)
My new installed dota 2 and TF 2 are not running it says that i need to update the openGL ( GL_EXT_texture_sRGB_decode not supported please update your openGL driver ) my grapich card number is ATI RV670 [Radeon HD 3870]
Showing 1-11 of 11 comments
< >
-FwG- ^ Bucky21659 Aug 15, 2013 @ 3:19am 
AMD dropped support for that GPU, so you can't use official drivers. I've heard of people having success with open source drivers, but unfortunately I don't know what people have had success with.

tl;dr
you can't use official drivers with that card, look up open sourced alternatives
Deazel Aug 15, 2013 @ 3:34am 
According to this, the HD 3000 series is still covered by the legacy driver...

http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx
Last edited by Deazel; Aug 15, 2013 @ 3:35am
Deazel Aug 15, 2013 @ 3:40am 
Although performance for AMD is very spotty on Linux from what I have gathered.
[Whos][Black] Sha[red]dow Aug 15, 2013 @ 3:51am 
Thank you all for supportin me and helping me P.S. downloading the amd driver that @Deazel send me :) if it works ill be so much appriciated
Deazel Aug 15, 2013 @ 3:53am 
Originally posted by Luka:
Thank you all for supportin me and helping me P.S. downloading the amd driver that @Deazel send me :) if it works ill be so much appriciated


Hope it works for you!
noam.mor Aug 15, 2013 @ 11:06am 
This is probably too late, but in general it is better to use your Linux distribution's tools for installing drivers (and other software).
In Ubuntu, you can switch the graphics driver through the "software & updates" dialog.
lλmbdλ Aug 15, 2013 @ 3:23pm 
Apart from the things said here, have you actually tried updating your system like the error message said and then trying it again ?
Deazel Aug 15, 2013 @ 4:50pm 
I probably should have asked what distro he was using.
[Whos][Black] Sha[red]dow Aug 16, 2013 @ 5:00am 
here you go my distro :) Ubuntu 12.04.2 LTS \n \l
Deazel Aug 16, 2013 @ 1:17pm 
Jockey (Additional Drivers) would be the best way to update your drivers then.
-FwG- ^ Bucky21659 Aug 16, 2013 @ 1:59pm 
^Not for open source ones.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Aug 15, 2013 @ 3:07am
Posts: 11