Steam for Linux > 一般討論 > 主題細節
OverPowered 2013 年 07 月 28 日 @ 上午 3 時 12 分
''New Steam library folder must be on a filesystem mounted with execute permissions''
I got the following error trying to install a new steam library folder on an external usb hard drive. I tried different external hard drives as well as flash drives, but they all get the same error. I have succeeded in installing steam games on external hard drives on windows, however my steam games need to be installed on linux in this situation.

How can I bypass this error code? Must I give execute permissions to the external drive? If this is so, how will it happen?
顯示 1-8,共 8 則回應
< >
vodik 2013 年 07 月 28 日 @ 上午 3 時 43 分 
What filesystem is on the usb drive? Is it mounted with noexec? UIf Steam is complaining it can't set executable flag on the filesystem, that filesystme is likely fat and you can't chmod on fat.

Is this drive for linux only? Reformat it to ext4 or something else.
Yoyosan 2013 年 07 月 28 日 @ 上午 3 時 48 分 
Hello.

By presuming you have Ubuntu installed, I've fixed this problem by adding this line in the /etc/fstab file:
/dev/sda6 /media/MEDIA7 ntfs-3g defaults,user,locale=en_US.utf8,exec,uid=1000,gid=1000 0 0

Presuming that your external disk is formatted AS NTFS, replace /dev/sda6 with your disk path(you can find it out using "fdisk -l"). The /media/MEDIA7 is the mount point. Make sure that you replace the integer values of uid and gid with your own(you can get them by using "id").

Note that the exec flag is what is fixing your problem.
最後修改者:Yoyosan; 2013 年 07 月 28 日 @ 上午 4 時 28 分
vodik 2013 年 07 月 28 日 @ 上午 8 時 51 分 
Thats assuming NTFS. Its an external usb, my bets is on fat32.
Lord Easpada 2013 年 10 月 24 日 @ 上午 12 時 24 分 
what i did was i clicked on Files, went down to my hard drive right clicked went to permissions and then changed it so i had read write permissions for my group which included me and that fixed it.
reznor 06 月 27 日 @ 下午 3 時 38 分 
For Linux users who are using decent file systems:
If you are using the directive "user(s)" in your /etc/fstab, you must specify "exec" afterwards. "user(s)" implies "noexec", that's an security feature. The directives are processed in order, specifying "exec" after "user(s)" solves this problem.
最後修改者:reznor; 06 月 27 日 @ 下午 3 時 40 分
GranadaFEUP 09 月 14 日 @ 下午 2 時 38 分 
@reznor

Thank you, your solution worked for me.
(`O_O!) 12 月 19 日 @ 上午 3 時 29 分 
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
LOLCAT 12 月 19 日 @ 上午 4 時 50 分 
(``o_o!) 發表:
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.
顯示 1-8,共 8 則回應
< >
每頁: 15 30 50