Steam for Linux

Steam for Linux

Steam for Linux > Discusiones generales > Detalles del tema
OverPovered 28 JUL 2013 a las 3:12
''New Steam library folder must be on a filesystem mounted with execute permissions''
I got the following error trying to install a new steam library folder on an external usb hard drive. I tried different external hard drives as well as flash drives, but they all get the same error. I have succeeded in installing steam games on external hard drives on windows, however my steam games need to be installed on linux in this situation.

How can I bypass this error code? Must I give execute permissions to the external drive? If this is so, how will it happen?
< >
Mostrando 1-15 de 21 comentarios
vodik 28 JUL 2013 a las 3:43 
What filesystem is on the usb drive? Is it mounted with noexec? UIf Steam is complaining it can't set executable flag on the filesystem, that filesystme is likely fat and you can't chmod on fat.

Is this drive for linux only? Reformat it to ext4 or something else.
Yoyo San 28 JUL 2013 a las 3:48 
Hello.

By presuming you have Ubuntu installed, I've fixed this problem by adding this line in the /etc/fstab file:
/dev/sda6 /media/MEDIA7 ntfs-3g defaults,user,locale=en_US.utf8,exec,uid=1000,gid=1000 0 0

Presuming that your external disk is formatted AS NTFS, replace /dev/sda6 with your disk path(you can find it out using "fdisk -l"). The /media/MEDIA7 is the mount point. Make sure that you replace the integer values of uid and gid with your own(you can get them by using "id").

Note that the exec flag is what is fixing your problem.
Última edición por Yoyo San; 28 JUL 2013 a las 4:28
vodik 28 JUL 2013 a las 8:51 
Thats assuming NTFS. Its an external usb, my bets is on fat32.
Emperor Easpada 24 OCT 2013 a las 0:24 
what i did was i clicked on Files, went down to my hard drive right clicked went to permissions and then changed it so i had read write permissions for my group which included me and that fixed it.
reznor 27 JUN 2014 a las 15:38 
For Linux users who are using decent file systems:
If you are using the directive "user(s)" in your /etc/fstab, you must specify "exec" afterwards. "user(s)" implies "noexec", that's a security feature. The directives are processed in order, specifying "exec" after "user(s)" solves this problem.
Última edición por reznor; 22 ENE 2015 a las 14:53
GranadaFEUP 14 SEP 2014 a las 14:38 
@reznor

Thank you, your solution worked for me.
电弧典狱长 19 DIC 2014 a las 3:29 
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
Dusk of Oolacile 19 DIC 2014 a las 4:50 
Publicado originalmente por (``o_o!):
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.
Tömer 23 DIC 2014 a las 10:25 
Thats it, that fixed the error for me
Sturmlilie 25 DIC 2014 a las 7:45 
Publicado originalmente por LOLCAT:
Publicado originalmente por (``o_o!):
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

Holy♥♥♥♥♥♥thanks so much dude, I was freaking out because my ext4 partition had always worked before and it suddenly disappeared from steam.
petran79 4 FEB 2015 a las 8:11 
Have the same issue. Problem is that the external drive is a NTFS partition instead of ext4, so I have to edit fstab for it to work. Too much trouble for what it is worth!

No serious issue, since I keep the relatively small games on Ubuntu, while running the large games from Windows on an external drive of 4 TB.
Kayzer 15 ABR 2015 a las 14:17 
Publicado originalmente por LOLCAT:
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

You saved my day. Too ad I didn't find this thread earlier.

Thank you, Thank You !
Чименто 18 ABR 2015 a las 14:27 
Publicado originalmente por Yoyosan:
Hello.

By presuming you have Ubuntu installed, I've fixed this problem by adding this line in the /etc/fstab file:
/dev/sda6 /media/MEDIA7 ntfs-3g defaults,user,locale=en_US.utf8,exec,uid=1000,gid=1000 0 0

Presuming that your external disk is formatted AS NTFS, replace /dev/sda6 with your disk path(you can find it out using "fdisk -l"). The /media/MEDIA7 is the mount point. Make sure that you replace the integer values of uid and gid with your own(you can get them by using "id").

Note that the exec flag is what is fixing your problem.
It works. Thank you :D .
Ziolet 3 MAY 2015 a las 18:48 
Publicado originalmente por LOLCAT:
Publicado originalmente por (``o_o!):
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

This totally worked for me, cheers man.
gregorej 25 JUN 2015 a las 0:00 
Publicado originalmente por Kayzer:
Publicado originalmente por LOLCAT:
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

You saved my day. Too ad I didn't find this thread earlier.

Thank you, Thank You !

Same here! Thanks a lot!
< >
Mostrando 1-15 de 21 comentarios
Por página: 15 30 50

Steam for Linux > Discusiones generales > Detalles del tema
Publicado el: 28 JUL 2013 a las 3:12
Mensajes: 21