Steam for Linux > 総合掲示板 > トピックの詳細
OverPovered 2013年7月28日 3時12分
''New Steam library folder must be on a filesystem mounted with execute permissions''
I got the following error trying to install a new steam library folder on an external usb hard drive. I tried different external hard drives as well as flash drives, but they all get the same error. I have succeeded in installing steam games on external hard drives on windows, however my steam games need to be installed on linux in this situation.

How can I bypass this error code? Must I give execute permissions to the external drive? If this is so, how will it happen?
1-15 / 15 のコメントを表示
< >
vodik 2013年7月28日 3時43分 
What filesystem is on the usb drive? Is it mounted with noexec? UIf Steam is complaining it can't set executable flag on the filesystem, that filesystme is likely fat and you can't chmod on fat.

Is this drive for linux only? Reformat it to ext4 or something else.
BOT Yoyo 2013年7月28日 3時48分 
Hello.

By presuming you have Ubuntu installed, I've fixed this problem by adding this line in the /etc/fstab file:
/dev/sda6 /media/MEDIA7 ntfs-3g defaults,user,locale=en_US.utf8,exec,uid=1000,gid=1000 0 0

Presuming that your external disk is formatted AS NTFS, replace /dev/sda6 with your disk path(you can find it out using "fdisk -l"). The /media/MEDIA7 is the mount point. Make sure that you replace the integer values of uid and gid with your own(you can get them by using "id").

Note that the exec flag is what is fixing your problem.
最近の変更はBOT Yoyoが行いました; 2013年7月28日 4時28分
vodik 2013年7月28日 8時51分 
Thats assuming NTFS. Its an external usb, my bets is on fat32.
Lord Easpada 2013年10月24日 0時24分 
what i did was i clicked on Files, went down to my hard drive right clicked went to permissions and then changed it so i had read write permissions for my group which included me and that fixed it.
reznor 2014年6月27日 15時38分 
For Linux users who are using decent file systems:
If you are using the directive "user(s)" in your /etc/fstab, you must specify "exec" afterwards. "user(s)" implies "noexec", that's a security feature. The directives are processed in order, specifying "exec" after "user(s)" solves this problem.
最近の変更はreznorが行いました; 1月22日 14時53分
GranadaFEUP 2014年9月14日 14時38分 
@reznor

Thank you, your solution worked for me.
装B若风,常伴伍声 2014年12月19日 3時29分 
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
Dusk of Oolacile 2014年12月19日 4時50分 
(``o_o!) の投稿を引用:
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.
Tömer 2014年12月23日 10時25分 
Thats it, that fixed the error for me
Ancu 2014年12月25日 7時45分 
LOLCAT の投稿を引用:
(``o_o!) の投稿を引用:
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

Holy ♥♥♥♥ thanks so much dude, I was freaking out because my ext4 partition had always worked before and it suddenly disappeared from steam.
petran79 2月4日 8時11分 
Have the same issue. Problem is that the external drive is a NTFS partition instead of ext4, so I have to edit fstab for it to work. Too much trouble for what it is worth!

No serious issue, since I keep the relatively small games on Ubuntu, while running the large games from Windows on an external drive of 4 TB.
Kayzer 4月15日 14時17分 
LOLCAT の投稿を引用:
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

You saved my day. Too ad I didn't find this thread earlier.

Thank you, Thank You !
MATE™(MKD) 4月18日 14時27分 
Yoyosan の投稿を引用:
Hello.

By presuming you have Ubuntu installed, I've fixed this problem by adding this line in the /etc/fstab file:
/dev/sda6 /media/MEDIA7 ntfs-3g defaults,user,locale=en_US.utf8,exec,uid=1000,gid=1000 0 0

Presuming that your external disk is formatted AS NTFS, replace /dev/sda6 with your disk path(you can find it out using "fdisk -l"). The /media/MEDIA7 is the mount point. Make sure that you replace the integer values of uid and gid with your own(you can get them by using "id").

Note that the exec flag is what is fixing your problem.
It works. Thank you :D .
Green Will Universe 5月3日 18時48分 
LOLCAT の投稿を引用:
(``o_o!) の投稿を引用:
my system:arch+openbox
I have mounted my disk with"mount -o default,exec,umask=0"
But it still showed wrong message.
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

This totally worked for me, cheers man.
gregorej 6月25日 0時00分 
Kayzer の投稿を引用:
LOLCAT の投稿を引用:
The error message is faulty, it doesn't actually show the real issue. You just have to rename SteamApps to steamapps (lowercase). One of the recent updates started using the new directory name.

You saved my day. Too ad I didn't find this thread earlier.

Thank you, Thank You !

Same here! Thanks a lot!
1-15 / 15 のコメントを表示
< >
ページ毎: 15 30 50

Steam for Linux > 総合掲示板 > トピックの詳細