KaBoom [LINUX] Jul 20, 2013 @ 1:03pm
[SOLVED]Please help me! TF2 doesn't start with Bumblebee after Steam Pipe Update
I have tried to launch TF2 with optirun %command% and primusrun, but only a black screen is shown for some seconds. With my intel it works fine, but with some annoing lag. Please help me to resolve this issue.

Kubuntu 13.04
Nvidia Geforce 610m 2GB
6GB RAM
Intel core i7-26700M, 2.2 GhZ
Last edited by KaBoom [LINUX]; Jul 21, 2013 @ 1:44pm
Showing 1-8 of 8 comments
< >
ProChaser [Linux] Jul 20, 2013 @ 2:33pm 
The best way is to got to the #ubuntu IRC channel and ask the ppl there.
AC/DC ROCK OR BUST!!!!!!!!! Jul 20, 2013 @ 2:36pm 
Try disabling steam community in game. Alternatively, here's my launch options: optirun -b primus --failsafe %command% -novid
KaBoom [LINUX] Jul 20, 2013 @ 2:57pm 
Originally posted by TrIcKz AC/DC ROCKS!!!!:
Try disabling steam community in game. Alternatively, here's my launch options: optirun -b primus --failsafe %command% -novid

THX, with this my TF2 works again at 60 FPS!
Do you have also left 4 dead 2? Sometimes using bumblebee the game crash.
Using the same launch option of TF2, i have only a crash when you reach the safe room and change level.
Last edited by KaBoom [LINUX]; Jul 20, 2013 @ 3:10pm
AC/DC ROCK OR BUST!!!!!!!!! Jul 20, 2013 @ 6:52pm 
Originally posted by LINUX DarkTux:
Originally posted by TrIcKz AC/DC ROCKS!!!!:
Try disabling steam community in game. Alternatively, here's my launch options: optirun -b primus --failsafe %command% -novid

THX, with this my TF2 works again at 60 FPS!
Do you have also left 4 dead 2? Sometimes using bumblebee the game crash.
Using the same launch option of TF2, i have only a crash when you reach the safe room and change level.

See this thread for a l4d2 fix: http://steamcommunity.com/app/221410/discussions/0/828939163951441775/
KaBoom [LINUX] Jul 21, 2013 @ 2:07am 
Originally posted by TrIcKz AC/DC ROCKS!!!!:
Originally posted by LINUX DarkTux:

THX, with this my TF2 works again at 60 FPS!
Do you have also left 4 dead 2? Sometimes using bumblebee the game crash.
Using the same launch option of TF2, i have only a crash when you reach the safe room and change level.

See this thread for a l4d2 fix: http://steamcommunity.com/app/221410/discussions/0/828939163951441775/

With this fix the game doesn't start at all. Report me:

failed to dlopen /home/gaetano/.local/share/Steam/SteamApps/common/Left 4 Dead 2/bin/vguimatsurface.so error=libfontconfig.so.1: impossibile aprire il file oggetto condiviso: File o directory non esistente
failed to dlopen vguimatsurface.so error=vguimatsurface.so: impossibile aprire il file oggetto condiviso: File o directory non esistente
AppFramework : Unable to load module vguimatsurface.so!
Unable to load interface VGUI_Surface031 from vguimatsurface.so
AC/DC ROCK OR BUST!!!!!!!!! Jul 21, 2013 @ 11:01am 
Originally posted by LINUX DarkTux:
Originally posted by TrIcKz AC/DC ROCKS!!!!:

See this thread for a l4d2 fix: http://steamcommunity.com/app/221410/discussions/0/828939163951441775/

With this fix the game doesn't start at all. Report me:

failed to dlopen /home/gaetano/.local/share/Steam/SteamApps/common/Left 4 Dead 2/bin/vguimatsurface.so error=libfontconfig.so.1: impossibile aprire il file oggetto condiviso: File o directory non esistente
failed to dlopen vguimatsurface.so error=vguimatsurface.so: impossibile aprire il file oggetto condiviso: File o directory non esistente
AppFramework : Unable to load module vguimatsurface.so!
Unable to load interface VGUI_Surface031 from vguimatsurface.so

Try this then:

Originally posted by whitefox7:
I have found a solution modifying the hl2.sh into Left 4 Dead 2 Beta directory in this way: search the line:
${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
and replace it with:
LD_PRELOAD=left4dead2/bin/matchmaking.so optirun ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
then adjust your video settings and enjoy!


from: http://steamcommunity.com/app/221410/discussions/0/828938354897876651/
KaBoom [LINUX] Jul 21, 2013 @ 1:36pm 
I've tried this, the game starts but at save room still crash. I'll open a new thread for this problem.
Last edited by KaBoom [LINUX]; Jul 21, 2013 @ 1:44pm
Osmoseriser Jul 24, 2013 @ 12:30pm 
thx the tf2 command helped me !
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jul 20, 2013 @ 1:03pm
Posts: 8