iKursed Jul 19, 2013 @ 4:01pm
Need Help with TF 2
So recently I have downloaded Team fortress 2 and started the game up, but encountered several problems with what I assume are graphical glitches. The first problem is when starting up the game and the valve logo appears with the valve on the mans head or whatever, there seems to be a strange shade of green layered over the logo. The second problem is in game, I started up in a random server where I attempted to play, but the problem was that I couldn't see anything, everything was practically all black, I could barely see the floor beneath me. I went on several different servers, but it was the same for all of them, I couldn't see anything. I assume both problems tie in with each other as some graphical errors some where in the system and I would love to receive assistance with my problem. If anyone can help please do so, all help is greatly appreciated.
Showing 1-5 of 5 comments
< >
Fibbles Jul 19, 2013 @ 5:02pm 
What hardware are you using?
Which distro are you using?
Which graphics drivers do you have installed?
Last edited by Fibbles; Jul 19, 2013 @ 5:03pm
iKursed Jul 19, 2013 @ 7:10pm 
Processor Information:
Vendor: GenuineIntel
Speed: 2534 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.2 LTS (32 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-41-generic-pae
X Server Vendor: The X.Org Foundation
X Server Release: 11103000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release-i386_2013-06-28

Video Card:
Driver: X.Org Gallium 0.4 on AMD RV730

Driver Version: 2.1 Mesa 8.0.4
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x1002
DeviceID: 0x9480
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 13.54" x 7.60" (15.51" diag)
34.4cm x 19.3cm (39.4cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC269

Memory:
RAM: 3887 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 49850 Mb
Largest Free Hard Disk Block: 2580 Mb

Installed software:

Recent Failure Reports:
Fri Jul 19 14:39:03 2013 GMT: file ''/tmp/dumps/crash_20130719103742_1.dmp'', upload yes: ''CrashID=bp-fb0e04b5-e4d7-4e8e-9cb3-786562130719''
Fri Jul 19 18:19:55 2013 GMT: file ''/tmp/dumps/crash_20130719141825_1.dmp'', upload yes: ''CrashID=bp-2c6151da-c390-41ba-ac70-d22c72130719''
Fri Jul 19 18:23:42 2013 GMT: file ''/tmp/dumps/crash_20130719142256_1.dmp'', upload yes: ''CrashID=bp-5e1d9443-3e6e-46d6-9816-253602130719''
Fri Jul 19 18:24:28 2013 GMT: file ''/tmp/dumps/crash_20130719142358_1.dmp'', upload no: ''Failure when receiving data from the peer''
Fri Jul 19 18:29:09 2013 GMT: file ''/tmp/dumps/crash_20130719142735_1.dmp'', upload no: ''Couldn't connect to server''
Fri Jul 19 22:30:57 2013 GMT: file ''/tmp/dumps/assert_20130719183010_35.dmp'', upload yes: ''CrashID=bp-373b4f94-13d2-4795-8de4-e5cd42130719''
Fri Jul 19 23:48:52 2013 GMT: file ''/tmp/dumps/assert_20130719185031_1.dmp'', upload yes: ''CrashID=bp-74402965-92c6-4753-aff4-9c6042130719''

Fibbles Jul 20, 2013 @ 8:34am 
Hmm, I have absolutely no experience with ATI/AMD cards under Linux. I see you're running the open-source drivers though. Have you tried the latest Catalyst drivers and do you still get the same problem?
Doc Holliday Jul 20, 2013 @ 8:38am 
your Mesa 8.0.4 is way out of date so is the Gallium 0.4 the Radeon HD 4000 Series run best on Opensource Drivers for most users
Doc Holliday Jul 20, 2013 @ 8:40am 
you can try what's posted here and see if it work's http://steamcommunity.com/app/221410/discussions/0/864973919419799306/
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Jul 19, 2013 @ 4:01pm
Posts: 5