munchluxe63 Jul 14, 2013 @ 2:20am
Steam client and game slowdown and screen tearing problem
Installed Steam (linux) earlier this evening and played for about two hours. After that time, the game's (any game) frame rate dropped dramatically and the game became sluggish and nearly unplayable. Also, a strange sort of screen tearing appeared (near the top of the screen, covering up to an inch), disappeared and moved around sporadically. The problem persisted until I restarted my system. After another ten minutes of gameplay, the problem re-appeared. The problem affects all steam windows and all games I've tried.

System: Dell XPS 15 L502X
Video card: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
Operating System: Linux Mint 15 Olivia
Kernel: 3.8.0-25-generic
Arch: x86_64
Showing 1-7 of 7 comments
< >
Fibbles Jul 14, 2013 @ 6:41am 
Sounds like your laptop is just getting too hot which will cause it to slow down or even crash. Your CPU/GPU is cooled by a tiny fan and laptop cases don't exactly have great airflow. If you're experiencing hot weather at the moment, as I am, this will only compound the problem.

Try to avoid putting your laptop on carpet/fabrics as they will trap the heat close to the laptop. If you're still experiencing heat issues perhaps consider buying a laptop cooling kit[www.amazon.co.uk].
munchluxe63 Jul 14, 2013 @ 10:03pm 
It can get quite hot here, but I always keep my laptop it elevated; the problem seems to be exclusive to Steam; I have non-Steam versions of some of my games and they work fine.

I've mostly remedied the issues by running all games with hybrid graphics instead of the Intel card alone. I still experience periodic slowdown and choppy graphics and sound in some games, however.
Last edited by munchluxe63; Jul 14, 2013 @ 10:03pm
Fibbles Jul 15, 2013 @ 8:50am 
Hmm, that is odd, it really did sound like a classic overheating issue. I can't really explain why it doesn't happen in your non-Steam games though, besides Steam perhaps putting extra strain on your CPU. Perhaps try turning off the Steam-overlay to lessen the burden? Right click on a game in your library, go to properties, un-tick the box labelled 'Enable Steam community in-game'.

I'm not sure what you mean by running in hybrid mode (does this mean you're letting your OS pick the appropriate GPU?). You should always be running your games on the nVidia graphics card in your laptop. The Intel graphics built into your CPU are really only designed for running your desktop, watching movies, etc.

munchluxe63 Jul 16, 2013 @ 2:22pm 
It's a very decent laptop; I'm able to run titles such as Deus Ex: Human Revolution. Disabling the overlay doesn't have an effect.

My laptop's hybrid graphics (NVidia Optimus; an Intel card and Nvidia card working together) isn't properly natively supported by Linux OS's; I need to run more graphically demanding programs by running them through Bumblebee and Primus, otherwise it defaults to the Intel card.
fallout4all Oct 3, 2013 @ 6:11am 
you solved the problem?
L'esprit Malin Oct 3, 2013 @ 8:43am 
The tips is .... go windows!
munchluxe63 Oct 5, 2013 @ 7:44pm 
Originally posted by volnes88:
you solved the problem?
I ran the game with the options "netbook mode" and "small textures" while using Intel graphics.

Anyhow, rebooting is quick, so I've been playing in Windows more often.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Jul 14, 2013 @ 2:20am
Posts: 7