Minty-Linux Jul 13, 2013 @ 4:37pm
User Agreement Checkbox broken when purchasing a Game (Linux)
I keep getting an error with the user agreement check box. Before i check the box off, it looks like a box with a "-" symbol in it. I then check the box, and i get the check mark symbol. I go and continue my purchase, and it says i need to agree to the agreement. I dont know whats going on. I can purchase games from the website, but not on my Linux Client.
Showing 1-15 of 20 comments
< >
Doc Holliday Jul 13, 2013 @ 4:47pm 
what linux you have?
instabilis Jul 13, 2013 @ 4:54pm 
It's a bug in the current version of Steam, for some reason checkboxes are inverted. So unchecked is checked, and checked is unchecked.

Edit: It should only apply to web pages (Webkit) though.
Last edited by instabilis; Jul 13, 2013 @ 4:57pm
Tweakedenigma Jul 13, 2013 @ 4:55pm 
I have a similar issue however, the box looks like it's checked and when I got to buy it gives me the error, but if I select it again (changes to the "-") it lets me buy without issue.
Minty-Linux Jul 13, 2013 @ 5:08pm 
ok thanks for clearing that up. Im on Linux Mint 15 64bit
*Leaf [DG] Jul 13, 2013 @ 5:24pm 
Got the same issue here. Linux Mint 15 x64 as well. The checkboxes are inverted.
tuxisagamer Jul 13, 2013 @ 7:35pm 
Kubuntu 12.04 64-bit. Yeah, its a bug in the client but its not major.
|NAC²| D.Cent Jul 13, 2013 @ 11:42pm 
Also having it on openSUSE 12.2 32 bit.
DeadWire Jul 14, 2013 @ 12:26am 
It is odd to have to remove the check to agree, but I dunno if its a bug...
Medovyj kot Jul 14, 2013 @ 5:47am 
Ubuntu 13.04
Fibbles Jul 14, 2013 @ 6:32am 
Same problem on Xubuntu 13.04.

Took me a few panic filled seconds to figure it out as I watched the seconds timer on a Steam sale slowly approach zero.
LQKI Jul 14, 2013 @ 6:47am 
Same issue on latest Arch Linux
RegSizedRudy Jul 14, 2013 @ 7:44pm 
Same issue Arch Linux x64 KDE ... Workaround : keep clicking it on and off and then trying to proceede , sometimes it will work with it unchecked , and let you buy the games.

@ Dead Wire YES ! You have to remove the check box to make it work ! weird !
Last edited by RegSizedRudy; Jul 14, 2013 @ 7:47pm
MeatBag Jul 14, 2013 @ 10:09pm 
Ubuntu 12.04, Gnome 3.4.2, same problem. No way to solve that just waiting for update?..
JoeElMex Jul 15, 2013 @ 8:28am 
Same issue here on Manjaro X64 Cinnamon Edition.
Apocryphus Jul 15, 2013 @ 10:55am 
Same issue here. You need to 'uncheck' the tick box, per se in order to purchase.
Showing 1-15 of 20 comments
< >
Per page: 15 30 50
Date Posted: Jul 13, 2013 @ 4:37pm
Posts: 20